Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


[Excel] Zeile aus Tabellenblatt kopieren
#1
Hallo,

immer wieder tauchen solche oder ähnliche Fragen auf:
Zitat:Ich habe ein Tabellenblatt, in dem in Spalte B eine Menge eingetragen wird. Wenn dort eine Zahl eingetragen wird, dann soll die ganze Zeile in ein anderes Tabellenblatt kopiert werden.

Dafür gibt es, wie so oft in Excel, mehrere Möglichkeiten.

Eine Variante ist die Nutzung einer Matrixformel, die auch in der angehängten Beispieldatei enthalten ist.

Die Ausgangstabelle

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
1ArtikelMengePreis
2A1610
3A2 20
4A3130
5A4 40
6A5 50
7A6260
8A7170
9A8 80
10A9390
11A105100
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Eine der Zieltabellen (Tabelle2):

Arbeitsblatt mit dem Namen 'Tabelle2'
ABC
8ArtikelMengePreis
9A8610
10A3130
11A6260
12A7170
13A9390
14A105100

ZelleFormel
A9=WENN(ZEILE(Tabelle1!1:1)>ZÄHLENWENN(Tabelle1!$B$2:$B$20;">0");"";INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!$B$2:$B$20>0;ZEILE(Tabelle1!$2:$20));ZEILE(A1))))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die Formel in A9, die mit Strg-Shift-Enter abgeschlossen werden muss, kann dann nach rechts und nach unten kopiert werden.

Überwacht wird der Bereich von B2 bis B11 - das kann natürlich entsprechend angepasst werden.

Wenn nur Zeilen übernommen werden sollen, die in Spalte B eine bestimmte Menge aufweisen, dann reicht eine kleine Änderung der Formel:

=WENN(ZEILE(Tabelle1!1:1)>ZÄHLENWENN(Tabelle1!$B$2:$B$20;1);"";INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!$B$2:$B$20=1;ZEILE(Tabelle1!$2:$20));ZEILE(A1))))

wobei auch in diesem Fall die Formel mit Strg-Shift-Enter abgeschlossen werden muss.

In der angehängten Beispielsdatei sind mehrere Varianten dargestellt:

Tabelle2: Es werden die Zeilen übernommen, bei denen die Menge in Spalte B größer 0 ist

Tabelle3: Es werden die Zeilen übernommen, bei denen die Menge in Spalte B gleich 1 ist

Tabelle4: Es werden die Zeilen übernommen, bei denen die Menge zwischen einer frei definierbaren Ober- und Untergrenze liegen

Tabelle5: Es werden die Zeilen übernommen, bei denen die Artikelnummer einer frei wählbaren Artikelnummer entspricht und die Menge einen frei wählbaren Wert übersteigt.

Allerdings sind Matrixformeln rechenintensiv, d.h. wenn der zu überwachende Bereich sehr groß ist, dann wäre die Nutzung einer VBA-Lösung ratsam.

.xls   526732.xls (Größe: 59 KB / Downloads: 11)
Gruß
Peter
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [Excel] Schnelles Kopieren von Arbeitsblättern WillWissen 0 940 02.06.2014, 07:03
Letzter Beitrag: WillWissen
  [Excel] Animierte *.gif-Dateien im Tabellenblatt anzeigen Kl@us-M. 0 3.917 20.05.2014, 10:03
Letzter Beitrag: Kl@us-M.
  [Excel] Balken"diagramme" im Tabellenblatt Kl@us-M. 0 1.049 14.05.2014, 08:58
Letzter Beitrag: Kl@us-M.
  [Excel] Tabellenblattbereich als Grafik in Zwischenablage kopieren Kl@us-M. 0 822 13.05.2014, 09:33
Letzter Beitrag: Kl@us-M.
  [Excel] Daten eines bestimmten Kunden in anderes Tabellenblatt kopieren Peter 0 1.074 08.05.2014, 10:20
Letzter Beitrag: Peter
  [Excel] Jede zweite Zeile ohne VBA löschen Kl@us-M. 0 6.788 14.04.2014, 13:49
Letzter Beitrag: Kl@us-M.

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste