Duplikate entfernen funktioniert nicht. Bitte um eure Hilfe
#1
Hallo Zusammen.
Ich bin neu hier und brauche mal bitte eure Hilfe.
Ich möchte zwei Excel Tabellen zusammen führen. Sie haben teilweise den gleichen Inhalt, den könnte ich über Duplikate entfernen löschen, aber das funktioniert nicht ganz, da Tabelle 1 zwei Spalten weniger als Tabelle 2 besitzt. In Tabelle 2 sind also teilweise zusätzliche Informationen. Und wenn ich jetzt Tabelle 1 und Tabelle 2 zusammenführe und dann auf Duplikate entfernen gehe, entfernt Excel nur alles, was nichts in den zusätzlichen Spalten stehen hat.
Excel sollte nach meinem Wunsch schauen, was doppelt ist und das entfernen. Aber alles, was aus Tabelle 2 zusätzliche Informationen hat, hat Vorrang und soll bestehen bleiben. Das Duplikat aus Tabelle 1 soll dann gelöscht werden.Ich hoffe, ihr versteht mich und könnt mir weiterhelfen?!
Danke. LG, NickyV


Angehängte Dateien
.xlsx   Tabelle 1.xlsx (Größe: 10,05 KB / Downloads: 8)
.xlsx   Tabelle 2.xlsx (Größe: 10,24 KB / Downloads: 6)
to top
#2
Hi Nicky,

ich würde es so lösen:

1. den Inhalt der Tabelle 1 direkt unter den Inhalt der Tabelle 2 kopieren
2. die Zeilen des Originalinhaltes der Tabelle 2 mit dieser Formel zählen:

Code:
=ZÄHLENWENN($A$2:$D$13;A15)

3 die Zeilen des eingefügten Inhaltes aus Tabelle1 mit dieser Formel zählen:

Code:
=WENN(ZÄHLENWENN($A$2:$F$13;A15)>0;0;1)

4. Filter setzen und nach 1 in der Zählspalte filtern.

Diese Zeilen sind die doppelten und können gleich gelöscht werden. Filter wieder löschen und du hast eine Tabelle ohne doppelte Zeilen.

Siehe auch:


.xlsx   vickyv-Tabelle .xlsx (Größe: 30,67 KB / Downloads: 7)
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#3
Hallo und vielen Lieben Dank für die tolle und schnelle Hilfe.
Das ist schon mal total super.
Aber leider müssten die beiden zusätzlichen Spalten aus Tabelle 2 bestehen bleiben.
Gibts dafür auch eine Lösung?
Ich bin leider totale Anfängerin, was Excel angeht...
to top
#4
Hallo,

das muss mit Duplikate entfernen gehen.
Du kopierst die Tabellen u untereinander und rufst Duplikate entfernen auf.
Im sich öffnenden Fenster entfernst Du die Häkchen in den letzten zwei spalten und OK.
Gruß Atilla
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste