Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Bräuchte Hilfe
#1
Hallo zusammen,
komme mit einer Excelformel nicht weiter:
ich habe in Spalte A Name, Spalte B Vorname und Spalte C einen Zahlenwert. Nun möchte ich dass Excel mir das Minimum der Zahlenwerte anzeigt, wenn Name und Vorname übereinstimmen. Dazu habe ich in Spalte D = A2&B2 angelegt.
Nun kann ich mir mit der Funktion =WENN(ZÄHLENWENN(D$1:D1;D1)>1;"Duplikat";"") Duplikate anzeigen lassen. Kann man denn nun statt Duplikat MIn nehmen,und wenn ja, wie heisst der Zellenbezug?
Ich hoffe meine Frage ist nicht zu einfach für dieses Forum :s:s
Vielen Dank schonmal!

Smielies ausgeschaltet für korrekte Darstellung der Formel
Ralf
?mage
to top
#2
Hallo,

suchst du sowas?

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFG
1NameVornameWert N1V13
2N1V15    
3N1V13    
4N2V21    
5       

ZelleFormel
G1{=MIN(WENN(A2:A10&B2:B10=E1&F1;C2:C10))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

BTW: Ein Titel wie 'Bräuchte Hilfe' ist nicht sonderlich aussagefähig, da solltest du zukünftig ein bisschen mehr Phantasie walten lassen.
Gruß
Peter
to top
#3
Danke schonmal und sorry für den einfallslosen Titel - verspreche mir in Zukunft mehr Mühe zu geben 17
Ja,das geht schon in die richtige Richtung, nur habe ich tausende von Namen, so dass ich gerne hätte,dass in einer Spalte jeweils das Minimum für jeden Namen ausgegeben wird,wenn Vor-und Nachname gleich ist.Da kenne ich eben auch nicht die einzelnen Zellen wie A2:A25,...
Gruss Stefan
to top
#4
Hallo,

dann nimm eine Pivottabelle.

Markiere eine Zelle deiner Datentabelle - Einfügen - Pivottable und folge dem Assistenten.

Ziehe das Feld Name und das Feld Vorname in die Zeilenbeschriftung (Alternativ kannst du auch das Feld deiner Hilfsspalte D verwenden).

Ziehe das Feld Zahlenwert in Werte. Markiere in der PT eine Zelle mit einem Wert da dir die PT automatisch die Summe der Werte gibt - rechte Maus - Werte zusammenfassen nach - Min wählen.

Man kann die PT jetzt noch etwas aufhübschen indem man die Zeilen mit Ergebnis entfernt: Eine Ergebniszelle markieren - rechte Maus - und auf 'Teilergebnis ...' klicken.

Das Ganze sieht dann etwa so aus:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGH
1NameVornameWert     
2N1V15     
3N1V13  Minimum von Wert  
4N2V21  NameVornameErgebnis
5N1V22  N1V13
6      V22
7     N2V21
8     Gesamtergebnis 1
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
to top
#5
Werde es gleich mal testen - vielen Dank!!!!!
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste