Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Aus 2 Tabellen Zellen zusammenführen
#1
Hallo Leute,

ich versuch mal zu erklären was ich brauche Wink

Ich habe 2 Tabellen, in der 1. sind Kontakte und in der 2. Firmen. Jeweils in einer Zeile durch geschrieben (ID, Adresse etc.).

Die Kontakte sowie auch die Firmen haben eine identische ID in einer Zelle, in ihrer jeweiligen Zeile.

Ich möchte nun aus der Firmen-Tabelle die ID mit der Kontakt-Tabelle abgleichen (die zwei ID's sind aber nicht in der gleichen Zeile, in ihrer jeweiligen Tabelle - also Excell muss diese erstmal finden), wurde die identische ID gefunden, soll aus der Firmen-Tabelle der "Firmenname" in die Zeile des dazu gehörigen Kontakts übertragen werden...

ich checks selber nicht mehr^^

Hoffe, es kann mir wer helfen - und wenn, dass ich das dann auch verstehe, bzw umsetzen kann.

Grüsse, Phil
to top
#2
Hi Phil,

setz Dich mal mit der Funktion =SVERWEIS() auseinander:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
1IDName
21Hans
32Ute
43Peter
54Maria

Arbeitsblatt mit dem Namen 'Tabelle2'
 AB
1IDOrt
23Berlin
32München
44Stuttgart
51Hamburg


Arbeitsblatt mit dem Namen 'Tabelle3'
 ABC
1IDNameOrt
21HansHamburg
32UteMünchen
43PeterBerlin
54MariaStuttgart

ZelleFormel
B2=SVERWEIS(A2;Tabelle1!$A$2:$B$5;2;0)
C2=SVERWEIS(A2;Tabelle2!$A$2:$B$5;2;0)
B3=SVERWEIS(A3;Tabelle1!$A$2:$B$5;2;0)
C3=SVERWEIS(A3;Tabelle2!$A$2:$B$5;2;0)
B4=SVERWEIS(A4;Tabelle1!$A$2:$B$5;2;0)
C4=SVERWEIS(A4;Tabelle2!$A$2:$B$5;2;0)
B5=SVERWEIS(A5;Tabelle1!$A$2:$B$5;2;0)
C5=SVERWEIS(A5;Tabelle2!$A$2:$B$5;2;0)
to top
#3
Danke Klaus für deine schnelle Antwort!

Kannst du mir nochmals die Formel erklären wenn die Daten jetzt in einer Tabelle sind?

...steigt noch nicht ganz durch Huh
to top
#4
Hola,

dann wirst du Klaus' Formel auf deine Tabelle umschreiben müssen. Woher soll er denn wissen, was bei dir wo steht?

Gruß,
steve1da
to top
#5
Nein ich meine, ohne die Tabellenverweise!
to top
#6
Hola,

dann nimm "Tabelle1!" usw. aus den Formeln.

Gruß,
steve1da
to top
#7
Hi Phil,

bevor das Stochern im Nebel losgeht, solltest Du die Arbeitsmappe mal hier zur Verfügung stellen.

Wie das geht, kannst Du hier [KLICK] nachlesen.

Wenn die Mappe sensible Daten enthält, mach 'ne Kopie, ersetze die sensiblen Daten durch Dummy-Daten, aber lass den Tabellenblattaufbau so wie er auch im Original ist.

Dann finden wir garantiert eine Lösung, die Du auch nachvollziehen kannst ...
[-] Folgende(r) 1 Benutzer sagt Danke an Kl@us-M. für diesen Beitrag:
JustPhil
to top
#8
Hi Klaus,

danke aber hat sich schon anderweitig geklärt!

VG
to top
#9
Hi Phil,

dann wäre es fair gewesen, wenn Du die Lösung hier auch gepostet hättest ...
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Zusammenführen von Spalteninhalten kochhase 6 110 17.11.2016, 13:44
Letzter Beitrag: kochhase
  Tabellenblätter zusammenführen andrea75w 27 1.172 02.10.2016, 06:55
Letzter Beitrag: schauan
  Inhalte aus Zellen zusammenführen - Excel 2013 HagenBe 11 441 08.09.2016, 15:58
Letzter Beitrag: HagenBe
  Arbeitsblätter aus Mappen Zusammenführen BlackyBabe 7 279 03.09.2016, 15:25
Letzter Beitrag: snb
  Daten aus 2 verschiedenen Quellen zusammenführen s.daehne 4 283 20.07.2016, 07:59
Letzter Beitrag: Rabe
  Makro Tabellen zusammenführen spengery 3 391 17.06.2016, 17:42
Letzter Beitrag: WillWissen
  Daten aus zwei Tabellen zusammenführen marie906 1 320 09.06.2016, 04:30
Letzter Beitrag: shift-del
  Mehrere Excel-Dateien zusammenführen mort92 5 744 02.06.2016, 11:24
Letzter Beitrag: mort92
  Listen und Tabellen vergleichen und zusammenführen SP-Creative 7 608 27.04.2016, 13:49
Letzter Beitrag: steve1da
  Arbeitsmappen vergleichen und zusammenführen drarrr 5 699 26.04.2016, 08:24
Letzter Beitrag: drarrr

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste