Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Summenprodukt Alternative
#1
Hi zusammen,

bin sehr neu in diesem Forum.19

Hab das halbe Internet nach einer Alternative zur SUMMERNPRODUKT Formel durchsucht, finde aber nix.

In meiner Datei habe ich folgende Formel:
=SUMMENPRODUKT((Shift!$A$1:$A$100000=B3)*(Shift!$F$1:$F$100000=6)*Shift!$E$1:$E$100000)

Ich weiß, da ich so viele Zellen anspreche dass die Berechnung für die Formel genauso viel Zeit in Anspruch nimmt wie ich Zeit darauf vergoldet habe im Internet nach einer Alternative zur Summenprodukt Formel zu finden20

Das muss doch schneller gehen!?

Kann mir jemand helfen?

Vielen Dank im Voraus
to top
#2
Hallo,

ich würde über den Einsatz einer Pivottabelle nachdenken, ohne allerdings den genauen Tabellenaufbau zu kennen...

Eine andere Alternative wäre möglicheweise die Funktion Summewenns() die seit XL2007 existiert. Ohne allerdings den genauen Tabellenaufbau zu kennen...

Wenn dir diese Hinweise nicht weiterhelfen wäre eine anonymisierte abgespeckte Beispielsdatei hilfreich, damit wer den genauen Tabellenaufbau kennen.

Hier findest du eine Anleitung zum Hochladen von Dateien:

http://www.clever-excel-forum.de/Thread-...ng-stellen
Gruß
Peter
to top
#3
Hola,

ungetestet:

Code:
=SUMMEWENNS(Shift!$E$1:$E$100000;Shift!$A$1:$A$100000;B3;Shift!$F$1:$F$100000;6)

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
floridarolf
to top
#4
Vielen Dank für die schnelle Antwort.

Um Ehrlich zu sein, ist mir die SUMMEWENNS sehr unbekannt bzw hab noch nie mit ihr gearbeitet.

Ich hab jetzt mal die Datei angehängt

Die Formel ist auf dem Tabellenblatt 1 in E3


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 35,88 KB / Downloads: 9)
to top
#5
Hola,

Zitat:Um Ehrlich zu sein, ist mir die SUMMEWENNS sehr unbekannt bzw hab noch nie mit ihr gearbeitet.

jepp - seh ich. Schade das du es nicht probiert hast.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
floridarolf
to top
#6
Musste gerade einen Jahresbereicht an Daten ziehen für ca 1200 Mitarbeiter....hat ein wenig gedauert.

Hab sie gearde getestet................funktioniert einwandfrei.

VIELEN DANK !!!19

Weltklasse
to top
#7
Hallo,

mit der Pivottabelle würde das z.B. so aussehen.

Voraussetzung ist, dass das Tabellenblatt Shift eine Überschriftszeile erhält. Das Feld der Spalte F steht momentan im Berichtsfilter, man könnte es auch in die Spaltenbezeichnung ziehen, das kommt darauf an welche Darstellung ansprechender ist.


Angehängte Dateien
.xlsx   Mappe1-1.xlsx (Größe: 40,04 KB / Downloads: 3)
Gruß
Peter
to top
#8
Dir auch vielen Dank für die schnelle Antwort.

Die Formel von steve1da ist genau das was ich gesucht habe.

Hab das jetzt für meine Datei angepasst und nur zum Vergleich:

Vorher hat mein Makro ca 14 Min gebrauch um 106 Spalten zu berechnen, jetzt braucht es nur 2 min und ich habe nur die Hälfte angepasst. 232323
to top
#9
Hi,

(02.02.2015, 15:43)floridarolf schrieb: Vorher hat mein Makro ca 14 Min gebrauch um 106 Spalten zu berechnen, jetzt braucht es nur 2 min und ich habe nur die Hälfte angepasst. 232323

mit Pivot sind es nur Sekunden!
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#10
Uupppssss. Mein Fehler.

Dachte das ist das Excel-Forum.......werde das sofort ins Word-Forum setzten.

Gruß an den Prof28
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Performance-Problem Summenprodukt Klexx 6 89 24.11.2016, 14:24
Letzter Beitrag: Klexx
  Summenprodukt mit Datum derunsichere 4 51 17.11.2016, 14:27
Letzter Beitrag: BoskoBiati
  Summenprodukt aber nur in den letzten 5 Jahren marie 6 132 05.11.2016, 13:45
Letzter Beitrag: schauan
  Summenprodukt mit Bereich.verschieben exceltalent 3 69 03.11.2016, 17:06
Letzter Beitrag: Jockel
  Umkehrung von Summenprodukt exceltalent 4 116 12.10.2016, 15:40
Letzter Beitrag: exceltalent
  Statt Summenprodukt bessere (schnellere) Formel? tobisw 2 165 18.09.2016, 21:25
Letzter Beitrag: snb
  Text spalten in alternative hisid1 5 172 12.09.2016, 12:27
Letzter Beitrag: steve1da
Question SUMMENPRODUKT für Bereichsberechnung Sebasor 8 339 06.09.2016, 21:52
Letzter Beitrag: BoskoBiati
  DBMIN(?) Alternative? Travis5002 5 249 24.08.2016, 11:10
Letzter Beitrag: Travis5002
  SUMMENPRODUKT Erweiterung? Lot 4 195 17.08.2016, 13:41
Letzter Beitrag: Lot

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste