Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Formel mit wenn und oder
#1
Hallo
wer kann mir hier einen Tipp geben
Formel in C11:
wenn zwischen 47.0% bis 47.9% oder zwischen 51.1% bis 52.0% ein Zuschlag von 0.20 (D6) oder wenn zwischen 48.0% bis 51.0% ein Abschlag von 0.05 (D7), ausserhalb dieser Werte keine Berechnung.
Wie sieht die Formel für C11, C12, etc aus?

Danke für die Hilfe im Voraus
Oski

Tabelle1

ABCD
1von %bis %
2Stufe 148.051.0
3Stufe 247.047.9
4Stufe 251.152.0
5
6Zuschlag0.20
7Abschlag-0.05
8
9
10kg%Zu-/Abschlag
114'644.851.4
125'573.251.0
136'301.951.0
145'810.951.2
156'134.450.5
165'815.950.5
175'644.849.2
183'316.352.8
191'100.446.5
20etc.

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
to top
#2
Hi,

(29.01.2015, 19:25)oski schrieb: Wie sieht die Formel für C11, C12, etc aus?

so?

Tabelle1
ABCD
1von %bis %
2Stufe 14851
3Stufe 24747,9
4Stufe 251,152
5
6Zuschlag0,2
7Abschlag-0,05
8
9
10kg%Zu-/Abschlag
114'644.851,40,2
125'573.251-0,05
136'301.951-0,05
145'810.951,20,2
156'134.450,5-0,05
165'815.950,5-0,05
175'644.849,2-0,05
183'316.352,80
191'100.446,50
20etc.

verwendete Formeln
Zelle Formel Bereich N/A
C11:C19=WENN(UND(B11>=$C$2;B11<=$D$2);$D$7;0)+WENN(UND(B11>=$C$3;B11<=$D$3);$D$6;0)+WENN(UND(B11>=$C$4;B11<=$D$4);$D$6;0)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
oski
to top
#3
Hallo, oder ohne WENN()...:

=($C$3<=B11)*(B11<=$D$4)*(((($C$2<=B11)*(B11<=$D$2))*-0,25)+0,2)

Arbeitsblatt mit dem Namen 'Blatt1'
 ABCD
1  von %bis %
2 Stufe 14851
3 Stufe 24747,9
4 Stufe 251,152
5    
6 Zuschlag 0,2
7 Abschlag -0,05
8    
9    
10kg%Zu-/Abschlag 
114644,851,40,20,2
125573,251-0,05-0,05
136301,951-0,05-0,05
145810,951,20,20,2
156134,450,5-0,05-0,05
165815,950,5-0,05-0,05
175644,849,2-0,05-0,05
183316,352,800
191100,446,500

ZelleFormel
C11=WENN(UND(B11>=$C$2;B11<=$D$2);$D$7;0)+WENN(UND(B11>=$C$3;B11<=$D$3);$D$6;0)+WENN(UND(B11>=$C$4;B11<=$D$4);$D$6;0)
D11=($C$3<=B11)*(B11<=$D$4)*(((($C$2<=B11)*(B11<=$D$2))*-0,25)+0,2)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#4
Hallo,

oder so:

Code:
=VERWEIS(ABS(C11-49,5);{0;1,51;2,51};{-0,05;0,2;0})
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#5
Hallo Edgar, sicher, aber zu viel "hart geschriebenes" in der der Formel... ... Aber schön...!
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hallo,

oder so:

Code:
=VERWEIS(ABS(C11-49,5);{0;1,51;2,51};{-0,05;0,2;0})
=((ABS(C11-49,5)<2,51)*20-(ABS(C11-49,5)<1,51)*25)%
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Formel funktioniert nicht (WENN) StefanM 14 223 03.12.2016, 20:58
Letzter Beitrag: schauan
  Erweiterung Formel WENN+Zählenwenn Excelmonsta 3 84 17.11.2016, 15:39
Letzter Beitrag: BoskoBiati
  WENN ODER Verknüpfung über mehrere Bedingungen? wies1617 8 167 11.11.2016, 17:22
Letzter Beitrag: schauan
  "Wenn" Formel - ich verzweifle Dirk111 1 73 10.11.2016, 10:48
Letzter Beitrag: steve1da
  Bedingte Formatierung, wenn Zellwert(aus Formel)="" Hawkeye 4 96 27.10.2016, 16:07
Letzter Beitrag: shift-del
  Formel mit mehreren WENN prüfungen vanexel123 6 114 27.10.2016, 15:50
Letzter Beitrag: Jockel
  Wenn-Formel aber wie? MeKeMo 0 65 25.10.2016, 11:17
Letzter Beitrag: MeKeMo
  Formel oder Selbst eintippen Farulon 10 326 13.10.2016, 06:45
Letzter Beitrag: Farulon
  Wenn-dann-Formel Tukan 6 134 11.10.2016, 14:55
Letzter Beitrag: Tukan
  Makro: Wenn Zelle Wert ≠ 0, dann Wert speichern und Formel löschen TsuBasti1 6 231 01.10.2016, 06:27
Letzter Beitrag: IchBinIch

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste