Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Formel mit wenn und oder
#1
Hallo
wer kann mir hier einen Tipp geben
Formel in C11:
wenn zwischen 47.0% bis 47.9% oder zwischen 51.1% bis 52.0% ein Zuschlag von 0.20 (D6) oder wenn zwischen 48.0% bis 51.0% ein Abschlag von 0.05 (D7), ausserhalb dieser Werte keine Berechnung.
Wie sieht die Formel für C11, C12, etc aus?

Danke für die Hilfe im Voraus
Oski

Tabelle1

ABCD
1von %bis %
2Stufe 148.051.0
3Stufe 247.047.9
4Stufe 251.152.0
5
6Zuschlag0.20
7Abschlag-0.05
8
9
10kg%Zu-/Abschlag
114'644.851.4
125'573.251.0
136'301.951.0
145'810.951.2
156'134.450.5
165'815.950.5
175'644.849.2
183'316.352.8
191'100.446.5
20etc.

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
to top
#2
Hi,

(29.01.2015, 19:25)oski schrieb: Wie sieht die Formel für C11, C12, etc aus?

so?

Tabelle1
ABCD
1von %bis %
2Stufe 14851
3Stufe 24747,9
4Stufe 251,152
5
6Zuschlag0,2
7Abschlag-0,05
8
9
10kg%Zu-/Abschlag
114'644.851,40,2
125'573.251-0,05
136'301.951-0,05
145'810.951,20,2
156'134.450,5-0,05
165'815.950,5-0,05
175'644.849,2-0,05
183'316.352,80
191'100.446,50
20etc.

verwendete Formeln
Zelle Formel Bereich N/A
C11:C19=WENN(UND(B11>=$C$2;B11<=$D$2);$D$7;0)+WENN(UND(B11>=$C$3;B11<=$D$3);$D$6;0)+WENN(UND(B11>=$C$4;B11<=$D$4);$D$6;0)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
oski
to top
#3
Hallo, oder ohne WENN()...:

=($C$3<=B11)*(B11<=$D$4)*(((($C$2<=B11)*(B11<=$D$2))*-0,25)+0,2)

Arbeitsblatt mit dem Namen 'Blatt1'
 ABCD
1  von %bis %
2 Stufe 14851
3 Stufe 24747,9
4 Stufe 251,152
5    
6 Zuschlag 0,2
7 Abschlag -0,05
8    
9    
10kg%Zu-/Abschlag 
114644,851,40,20,2
125573,251-0,05-0,05
136301,951-0,05-0,05
145810,951,20,20,2
156134,450,5-0,05-0,05
165815,950,5-0,05-0,05
175644,849,2-0,05-0,05
183316,352,800
191100,446,500

ZelleFormel
C11=WENN(UND(B11>=$C$2;B11<=$D$2);$D$7;0)+WENN(UND(B11>=$C$3;B11<=$D$3);$D$6;0)+WENN(UND(B11>=$C$4;B11<=$D$4);$D$6;0)
D11=($C$3<=B11)*(B11<=$D$4)*(((($C$2<=B11)*(B11<=$D$2))*-0,25)+0,2)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#4
Hallo,

oder so:

Code:
=VERWEIS(ABS(C11-49,5);{0;1,51;2,51};{-0,05;0,2;0})
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#5
Hallo Edgar, sicher, aber zu viel "hart geschriebenes" in der der Formel... ... Aber schön...!
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hallo,

oder so:

Code:
=VERWEIS(ABS(C11-49,5);{0;1,51;2,51};{-0,05;0,2;0})
=((ABS(C11-49,5)<2,51)*20-(ABS(C11-49,5)<1,51)*25)%
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  bedingte Formatierung mit Wenn Formel psychodennis89 9 152 20.03.2017, 13:12
Letzter Beitrag: o0Julia0o
Question Formel: Wenn + Und + Suchen werwolf1989 2 55 17.03.2017, 17:03
Letzter Beitrag: BoskoBiati
  (Wenn-)Formel dynamischer gestalten und evtl. kürzen loxer 4 65 16.03.2017, 12:35
Letzter Beitrag: loxer
  WENN UND ODER Verknüpfung möglich? MarkusZ 9 171 09.03.2017, 08:20
Letzter Beitrag: MarkusZ
  Wenn dann Formel mit Daten zur berechnen Monikahelena 12 300 02.03.2017, 14:02
Letzter Beitrag: Rabe
  Anpassung WENN Formel xkurtx 19 365 02.03.2017, 11:53
Letzter Beitrag: BoskoBiati
  Excel =Wenn Formel Maurice1 4 157 01.03.2017, 13:43
Letzter Beitrag: Maurice1
  WENN-Formel rechnet falsch stoecki4 7 203 28.02.2017, 20:59
Letzter Beitrag: BoskoBiati
  Bereich für Formel ändern, wenn Text gefunden guine 13 202 26.02.2017, 12:53
Letzter Beitrag: WillWissen
  Wenn Formel cloud7 3 103 22.02.2017, 08:59
Letzter Beitrag: BoskoBiati

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste