Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


[Excel] Tipp zu SUMMEWENN (variables Suchkriterium)
#1
Das Problem ist in diesem Fall die Übergabe des Kriteriums als Zellbezug.

Liegt der Grenzwert als Konstante vor, kann die Summe problemlos mit der Funktion SUMMEWENN gebildet werden. Beispiel: alle Zellen des Bereichs A1:A20, deren Wert größer als 300 ist, sollen summiert werden

=SUMMEWENN(A1:A20;">300")

Soll der Grenzwert jedoch über eine Zelle geholt werden, akzeptiert Excel die Formel nicht. Mit folgendem Trick geht es aber doch.

Um das gewünschte Ergebnis zu erreichen, muss der Operator (im Beispiel das Größerzeichen ">") und die Grenzwertzelle mit dem Zeichen "&" verknüpft werden.

=SUMMEWENN(A1:A20;">"&C1)

Bitte generell darauf achten, dass der Operator und das Kriterium (im Falle eines konstanten Suchwertes) gemeinsam in Anführungszeichen gesetzt werden und im Falle des variablen Suchbegriffs (Bezug auf die entsprechende Zelle) nur der Operator.
Siehe ">300" bzw. ">"&C1
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste