Uhrzeit von bis auf Stundenzeiträume aufteilen
#1
Hallo zusammen,

ich muss von bis Uhrzeiten auf Stundenzeiträume aufteilen.
von 13:00
bis 14:30

Ergebnis
11:00-12:00 = 0:00
12:00-13:00 = 0:00
13:00-14:00 = 1:00
14:00-15:00 = 0:30
15:00-16:00 = 0:00

Anbei meine Beispieldatei. Für das Ergegnis in Zeile 3 benötige ich eine Formel.

Kann mir jemand eine Formel für mein Problem nennen?

Danke & Gruß
Britta


Angehängte Dateien
.xlsx   Mappe.xlsx (Größe: 11,55 KB / Downloads: 16)
to top
#2
Hallo!

Siehe hier!

http://www.herber.de/forum/messages/1405235.html

Gruß
Wilfried
to top
#3
Hallo,

so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJKLMNOPQRSTUVWXYZAA
1von00:45 00:0001:0002:0003:0004:0005:0006:0007:0008:0009:0010:0011:0012:0013:0014:0015:0016:0017:0018:0019:0020:0021:0022:0023:00
2bis11:20 01:0002:0003:0004:0005:0006:0007:0008:0009:0010:0011:0012:0013:0014:0015:0016:0017:0018:0019:0020:0021:0022:0023:0000:00
3Ergebnis  00:1501:0001:0001:0001:0001:0001:0001:0001:0001:0001:0000:20            

ZelleFormel
D3=WENN(($B$2<D1)+($B$1>D2);"";MIN(D2;$B$2)-MAX(D1;$B$1))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Formel einfach nach rechts ziehen.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • BrittaWelz
to top
#4
Hallo Wilfried,

das Ergebnis der Formeln passt aber nicht zum Wunschergebnis!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#5
Hola,

@Bosko: ihr eigenes Wunschergebnis stimmt ja auch nicht 19

Aber deine Formel ist schick!

Gruß,
steve1da
to top
#6
Hallo Britta


Dazu zwei Rückfragen.
Das von Hand eingetragene Resultat in P3 und O3 sind doch falsch oder?
Müssten die 20 Minuten nicht in P3?

Und zu Frage 2
Das rechnen mit Zeiträumen ist in Excel recht kompliziert.
Ewas einfacher wird die Berechnung, wenn die Zeitangaben nie über Mitternacht hinauslaufen.
Also nie von z. B. 22:00 bis 06:00
In deiner Tabelle mit den Zeitabschnitten denke ich, dass das nie der Fall sein wird, weil du da einfach einen ganzen Tag darstellst.
Aber wie ist das mit B1 - B2?
Könnte da eventuell eine Zeitangabe über Mittenacht hinauslaufen?

Gruss Sepp
to top
#7
Hallo Sepp,

ja die 20 Minuten müssen in P3.

Nein die Zeiten gehen nicht über Mitternacht.

Die Formel von BoskoBiati funktioniert außer z.B. 11:00 bis 11:20, dann kommt ### bei 10:00 bis 11:00.
Wenn das Problem noch behoben währe ist die Formel super.

Gruß
Britta
to top
#8
Hola,

ist die Zelle eventuell nicht breit genug?

Gruß,
steve1da
to top
#9
Hi Britta,

(29.01.2015, 11:12)BrittaWelz schrieb: Die Formel von BoskoBiati funktioniert außer z.B. 11:00 bis 11:20, dann kommt ### bei 10:00 bis 11:00.

das sehe ich anders, die Formel funktioniert doch einwandfrei:

Tabelle1
ABCDEFGHIJKLMNOPQRSTUVWXYZAA
1von00:4500:0001:0002:0003:0004:0005:0006:0007:0008:0009:0010:0011:0012:0013:0014:0015:0016:0017:0018:0019:0020:0021:0022:0023:00
2bis11:2001:0002:0003:0004:0005:0006:0007:0008:0009:0010:0011:0012:0013:0014:0015:0016:0017:0018:0019:0020:0021:0022:0023:0000:00
3Ergebnis manuell  00:1501:0001:0001:0001:0001:0001:0001:0001:0001:0001:0000:2000:0000:0000:0000:0000:0000:0000:0000:0000:0000:0000:0000:00
4Ergebnis Formel00:1501:0001:0001:0001:0001:0001:0001:0001:0001:0001:0000:20            

verwendete Formeln
Zelle Formel Bereich N/A
D4:AA4=WENN(($B$2<D1)+($B$1>D2);"";MIN(D2;$B$2)-MAX(D1;$B$1))
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste