Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Bei Problemen mit der Erreichbarkeit der Foren bitte den Link / Favoriten prüfen und ersetzen. Dazu über die Startseite ins gewünschte Forum wechseln und zu den Favoriten hinzufügen. Excel ist derzeit z.B. unter http://www.clever-excel-forum.de/forum-2.html zu erreichen.


Probleme mit einer Formel
#1
Hallo zusammen,

habe mit eurer Hilfe mein Auslöseformular super hinbekommen, doch jetzt habe Ich noch folgende Problem.
Habe die Zellen gelb markiert.
wenn wie eingegeben am 16.01.2014 nach Hause fahre zeigt es mir eine Heimfahrt an. Das ist richtig. Bin ich am nächsten Tag nur im Umkreis von 50 km (also keine Anreise und keine Übernachtung) unterwegs darf Ich keine Heimfahrt eintragen.

Jetzt müßte man die Formel in Spalte "L" so umschreiben dass wenn am Vortag die Zellen in den Spalten "G und H" leer sind keine Heimfahrt angegeben wird , also Zelle "L" leer.

siehe Datei im Anhang

Danke mal wieder im voraus.


Angehängte Dateien
.xlsm   Finanzamt 2014.xlsm (Größe: 208,45 KB / Downloads: 8)
to top
#2
Hi,

stelle bitte eine Tabelle ohne Blattschutz ein oder verrate uns dein PW. Sonst kann nicht nachgesehen werden, welche Formeln was bewirken.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#3
(25.01.2015, 09:45)WillWissen schrieb: Hi,

stelle bitte eine Tabelle ohne Blattschutz ein oder verrate uns dein PW. Sonst kann nicht nachgesehen werden, welche Formeln was bewirken.

Sorry hab es gerade gemerkt
Passwort ist 123

habe die Datei nochmal angehängt


Angehängte Dateien
.xlsm   Finanzamt 2014.xlsm (Größe: 207,6 KB / Downloads: 3)
to top
#4
Hi,

mein Vorschlag:

Code:
=WENN(UND(G22="";H22="");"";WENN(D22="";0;WENN(M22=1;0;WENN(K22=1;0;1))))
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#5
Auch Hallo,

oder so

Code:
=WENN(ODER(D23="";ANZAHLLEEREZELLEN(G22:H22)=2);0;WENN(M23=1;0;WENN(K23=1;0;1)))
Gruß Stefan
Win 7 / Office 2007
to top
#6
Hi

eventuell auch so, falls ich die Aufgabenstellung richtig verstanden habe:

Code:
=WENN(UND(G22="";H22="");"";WENN(ODER(D22="";M22=1;K22=1);0;1))
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#7
(25.01.2015, 10:03)WillWissen schrieb: Hi,

mein Vorschlag:

Code:
=WENN(UND(G22="";H22="");"";WENN(D22="";0;WENN(M22=1;0;WENN(K22=1;0;1))))

Danke soweit passt es ,
jetzt tut sich aber eine neue Kluft auf.
Wenn Ich jedoch am 14.01.2015 Anreise, dann Übernachte und am gleichen Tag heimfahre also am 15.01.2015, zeigt er keine heimfahrt an . Wäre so gesehen ja auch richtig. gibt es eine Möglichkeit wenn in der Zeile vom 16.01.2015 " Urlaub oder krank" steht das er bei der Heimfahrt und Übernachtung dann eine 1 setzt.

Blaue Zelle.


Angehängte Dateien
.xlsm   Finanzamt 2014.xlsm (Größe: 208,16 KB / Downloads: 2)
to top
#8
Hi,

Code:
=WENN(UND(G21="";H21="");0;WENN(ODER(C22="krank";C22="Urlaub");1;WENN(D22="";0;WENN(M22=1;0;WENN(K22=1;0;1)))))
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#9
(25.01.2015, 11:47)WillWissen schrieb: Hi,

Code:
=WENN(UND(G21="";H21="");0;WENN(ODER(C22="krank";C22="Urlaub");1;WENN(D22="";0;WENN(M22=1;0;WENN(K22=1;0;1)))))

Jetzt die 2te Runde, wenn Ich jetzt 2 Tage Urlaub oder krank eingebe setzt er eine Heimfahrt ein. Habe versucht noch ein 2 wenn formel dazuzusetzen geht nicht.
Vielleicht hast du noch eine Idee
to top
#10
Hi

Zitat:wenn Ich jetzt 2 Tage Urlaub oder krank eingebe setzt er eine Heimfahrt ein.

ich verstehe dieses Mal dein Problem nicht. Folgendes Scenario setze ich voraus:

1. Am 14.1. fährst du nach Ulm und übernachtest. Es wird dir korrekt die Übernachtung als 1 angezeigt.
2. Am 15.1. fährst du nach Hamburg und übernachtest. Es wird dir korrekt die Übernachtung als 1 angezeigt.
3. Am 16.1. wirst du krank und fährst zurück. Es wird deine Heimreise korrekt als 1 angezeigt.
4. Am 17.1. bist du immer noch krank und bewegst dich von zuhause überhaupt nicht weg. Es werden überall 0 Tätigkeiten angezeigt.

Was ist daran nicht richtig?

2014

ABCDEFGHIJKLM
2014.1.2014Diulm6:3018:0011:30x1001
2115.1.2014Mihamburg6:3017:0010:30x1001
2216.1.2014Dokrank0:00010
2317.1.2014Frkrank0:00000
2418.1.2014SaUrlaub0:00000
Formeln der Tabelle
ZelleFormel
B20=A20
F20=REST(E20-D20;1)
I20=WENN(F20*24=0;"";WENN((F20*24)<8;1;""))
J20=WENN(UND(F20*24>=8;F20*24<=24);1;"")
K20=WENN(H20="x";1;0)
L20=WENN(UND(G19="";H19="");0;WENN(ODER(C20="krank";C20="Urlaub");1;WENN(D20="";0;WENN(M20=1;0;WENN(K20=1;0;1)))))
M20=WENN(G20="x";1;0)
A21=A20+1
B21=A21
F21=REST(E21-D21;1)
I21=WENN(F21*24=0;"";WENN((F21*24)<8;1;""))
J21=WENN(UND(F21*24>=8;F21*24<=24);1;"")
K21=WENN(H21="x";1;0)
L21=WENN(UND(G20="";H20="");0;WENN(ODER(C21="krank";C21="Urlaub");1;WENN(D21="";0;WENN(M21=1;0;WENN(K21=1;0;1)))))
M21=WENN(G21="x";1;0)
A22=A21+1
B22=A22
F22=REST(E22-D22;1)
I22=WENN(F22*24=0;"";WENN((F22*24)<8;1;""))
J22=WENN(UND(F22*24>=8;F22*24<=24);1;"")
K22=WENN(H22="x";1;0)
L22=WENN(UND(G21="";H21="");0;WENN(ODER(C22="krank";C22="Urlaub");1;WENN(D22="";0;WENN(M22=1;0;WENN(K22=1;0;1)))))
M22=WENN(G22="x";1;0)
A23=A22+1
B23=A23
F23=REST(E23-D23;1)
I23=WENN(F23*24=0;"";WENN((F23*24)<8;1;""))
J23=WENN(UND(F23*24>=8;F23*24<=24);1;"")
K23=WENN(H23="x";1;0)
L23=WENN(UND(G22="";H22="");0;WENN(ODER(C23="krank";C23="Urlaub");1;WENN(D23="";0;WENN(M23=1;0;WENN(K23=1;0;1)))))
M23=WENN(G23="x";1;0)
A24=A23+1
B24=A24
F24=REST(E24-D24;1)
I24=WENN(F24*24=0;"";WENN((F24*24)<8;1;""))
J24=WENN(UND(F24*24>=8;F24*24<=24);1;"")
K24=WENN(H24="x";1;0)
L24=WENN(UND(G23="";H23="");0;WENN(ODER(C24="krank";C24="Urlaub");1;WENN(D24="";0;WENN(M24=1;0;WENN(K24=1;0;1)))))
M24=WENN(G24="x";1;0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste