Formel für Zeiten in Punkte umwandeln
#1
Formel für Zeiten in Punkte umwandeln
Hallo,
ich suche nach der richtige Formel, welche Zeiten in ein Punktesystem umwandelt...
und zwar gestaffelt:
+/- 0,0 bis 0,29 Sekunden 20 Punkte
+/- 0,3 bis 0,59 Sekunden 18 Punkte
+/- 0,6 bis 0,99 Sekunden 16 Punkte
+/- 1,0 bis 1,29 Sekunden 12 Punkte
+/- 1,3 bis 1,59 Sekunden 10 Punkte
+/- 1,6 bis 1,99 Sekunden 8 Punkte
+/- 2,0 bis 2,29 Sekunden 6 Punkte
+/- 2,3 bis 2,59 Sekunden 4 Punkte
+/- 2,6 bis 2,99 Sekunden 2 Punkte
Ab +/- 3 Sekunden 0 Punkte
bin zwar zu nem Ergebnis gekommen:
=VERWEIS(F43;{0;0,01;0,02;0,03;0,04;0,05;0,06;0,07;0,08;0,09;0,1;0,11;0,12;0,13;0,14;0,15;0,16;0,17;0,18;0,19;0,2;0,21;0,22;0,23;0,24;0,25;0,26;0,27;0,28;0,29;0,3;0,31;0,32;0,33;0,34;0,35;0,36;0,37;0,38;0,39;0,4;0,41;0,42;0,43;0,44;0,45;0,46;0,47;0,48;0,49;0,5;0,51;0,52;0,53;0,54;0,55;0,56;0,57;0,58;0,59;0,6;0,61;0,62;0,63;0,64;0,65;0,66;0,67;0,68;0,69;0,7;0,71;0,72;0,73;0,74;0,75;0,76;0,77;0,78;0,79;0,8;0,81;0,82;0,83;0,84;0,85;0,86;0,87;0,88;0,89;0,9;0,91;0,92;0,93;0,94;0,95;0,96;0,97;0,98;0,99;1;1,01;1,02;1,03;1,04;1,05;1,06;1,07;1,08;1,09;1,1;1,11;1,12;1,13;1,14;1,15;1,16;1,17;1,18;1,19;1,2;1,21;1;22;1,23;1,24;1,25;1,26;1,27;1,28;1,29;1,3;1,31;1,32;1,33;1,34;1,35;1,36;1,37;1,38;1,39;1,4;1,41;1,42;1,43;1,44;1,42;1,46;1,47;1,48;1,49;1,5;1,51;1,52;1,53;1,54;1,55;1,56;1;57;1,58;1,59;1;60;1,61;1,62;1,63;1,64;1,65;1,66;1,67;1,68;1,69;1,7;71;1,72;1,73;1,74;1,75;1,76;1,77;1,78;1,79;1,8;1,81;1,82;1,83;1,84;1,85;1,86187;1,88;1,89;1,9;1,91;1,92;1,93;1,94;1,95;1,96;1,97;1,98;1,99;2;2,01;2,02;2,03;2,04;2,05;2,06;2,07;2,08;2,09;2,1;2,11;2,12;2,13;2,14;2,15;2,16;2,17;2,18;2,19;2,2;2,21;2,22;2,23;2,24;2,25;2,26;2,27;2,28;2,29;2,3;2,31;2,32;2,33;2,34;2,35;2,36;2,37;2,38;2,39;2,4;2,41;2,42;2,43;2,44;2,45;2,46;2,47;2,48;2,49;2,5;2,51;2,52;2,53;2,54;2,55;2,56;2,57;2,58;2,59;2,6;2,61;2,62;2,63;2,64;2,65;2,66;2,67;2,68;2,69;2,7;2,71;2,72;2,73;2,74;2,75;2;76;2,77;2,78;2,79;2,8;2,81;2,82;2,83;2,84;2,85;2,86;2,87;2,88;2,89;2,9;2,91;2,92;2,93;2,94;2,95;2,96;2,97;2,98;2,99;3;0};{20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;20;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;18;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;16;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;12;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;10;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;8;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;6;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;4;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;2;0})

aber das kanns nicht wirklich sein...
Vielen Dank


.xlsx   Test.xlsx (Größe: 59,86 KB / Downloads: 6)

Anhang aus dem ursprünglich doppelten Post hier wieder eingefügt.
Moderator
to top
#2
Hallo,

ohne die Datei jetzt näher angesehen zu haben würde ich mal folgendes versuchen:

Baue dir eine Matrix mit deinen Werten auf und arbeite mit dem Sverweis. Hier mal ein kleines Beispiel:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFG
1vonbisPunkt  Abweichung 
200,2920  0,2320
30,30,5918  0,318
40,60,9916  0,3118
5     0,5918
6     0,616

ZelleFormel
G2=SVERWEIS(F2;A:C;3)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die Spalte B ist hier nicht unbedingt notwendig, macht das Ganze aber etwas übersichtlicher.
Gruß
Peter
to top
#3
Hallo,

einmal posten reicht vollkommen aus. Ich habe dir hier geantwortet:

http://www.clever-excel-forum.de/thread-1529.html
Gruß
Peter
to top
#4
Hallo Peter,

der erste Post stand ursprünglich in Usertreffen, was Nerv dann selber merkte und noch einmal ins richtige Forum postete!

Gruß Uwe
to top
#5
Danke Uwe.... genau so wars

Danke Peter,
aber ich steh jetzt eh voll auf dem Schlauch....
to top
#6
Hallo,

schreibe in z.B. U3 die Von-Zeiten untereinander und in V3 die Bis-Zeiten so wie ich das in meinem Beispiel mit den drei Zeiten gemacht habe. In W3 bis Wxx schreibst du die Punktzahlen.

In G4 dann folgende Formel:

=Sverweis(F4;U:W;3)

und diese Formel kopierst du nach unten.
Gruß
Peter
to top
#7
Hi,
(18.01.2015, 19:34)Nerv schrieb: aber das kanns nicht wirklich sein...

das geht so, oder per SUMMENPRODUKT()

Tabelle1
CD
140,716

Tabelle1
IJKL
2SekundenPunkte
3'+/-00,2920
4'+/-0,30,5918
5'+/-0,60,9916
6'+/-11,2912
7'+/-1,31,5910
8'+/-1,61,998
9'+/-22,296
10'+/-2,32,594
11'+/-2,62,992
12'+/-30

verwendete Formeln
Zelle Formel Bereich N/A
D14=WENN(ABS($C$14)<J4;L3;WENN(ABS($C$14)<J5;L4;WENN(ABS($C$14)<J6;L5;WENN(ABS($C$14)<J7;L6;WENN(ABS($C$14)<J8;L7;WENN(ABS($C$14)<J9;L8;WENN(ABS(C14)<J10;L9;WENN(ABS(C14)<J11;L10;WENN(ABS(C14)<J12;L11;0)))))))))
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

to top
#8
Ja okay...das hab ich.
Aber ich bekomm das nicht in meine Tabelle...
Und ich bekomm auch hier keine Datei mehr zum Anhang...

https://www.dropbox.com/s/13cpsmggjqv59l....xlsx?dl=0

Vielleicht so...

LG
to top
#9
Hallo,

Zitat:Aber ich bekomm das nicht in meine Tabelle...

das hatte ich versucht in meinem vorigen Posting zu erklären.

Schreibe die Matrix z.B. in die Spalten U bis V und verwende dann eine Sverweis-Formel die sich auf diese Spalten bezieht.

Ich habe das mal in deiner Datei gemacht und die Formel bis G13 eingetragen.


Angehängte Dateien
.xlsx   Test-3.xlsx (Größe: 60,03 KB / Downloads: 1)
Gruß
Peter
to top
#10
Hallo Peter,
vielen 1000Dank...
Hoffe dass es so einigemaßen gelöst ist....

https://www.dropbox.com/s/x19wfazfob0c1z....xlsx?dl=0

LG
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste