wenn bestimmter text dann ausweisen
#1
Hallo,
kann mir jemand helfen?
Ich möchte die einzelnen Werte aus den Spalten e f und g gerne in ein anderes Tabellenblatt übertragen wobei das Datum in Spalte d und die Kunden (Spalte D) die in der Kundenbezeichnung den Text gefr beinhalten getrennt sein müssen.
Sprich am ... hat Kunde (gefr im Text) folgende Menge der Spalte e, f bzw g bestellt.
Ich gebe das Datum ein und der Wert (Spalte E) des Kunden mit dem Textinhalt "gefr" wird ausgewiesen.
Krieg ich irgendwie nicht hin.
Mercie für eure Gedanken
heb01


Angehängte Dateien
.xlsx   excel hilfe.xlsx (Größe: 16,18 KB / Downloads: 7)
to top
#2
Hola,

kannst du das anhand deiner Beispieldatei mal genau erläutern?

Was soll genau wo als Ergebnis erscheinen?

Gruß,
steve1da
to top
#3
Hallo,
im beigefügten Tabellenblatt ist vielleicht ersichtlich was ich möchte.
Ich will ein Datum vorgeben. Hier z.b.der 5.1. dann soll excel mir die Spalten e, f ung g ausweisen von allen Kunden die ein "gefr" (gefrorene Ware) in ihrem Kundennamen haben. Hier Friesencenter.
Ergebnis Kunde mit Namenzusatz gefr hat am ... Menge an Ware Spalte E, F und G bekommen.(Spalte E, F und G stehen für versch. Artikel.
Gruß Heb
to top
#4
Hi Heb,

ist das die Lösung für dein Problem?

Bei meinem Vorschlag brauchst du eine Hilfsspalte - in diesem Fall im Tabellenblatt1, Spalte H. Die Spalte kannst du einfach ausblenden. Auf deinem Auswerteblatt musst du nur ein Datum - hier in Zelle A2 - eingeben.


.xlsx   heb01-excel hilfe.xlsx (Größe: 25,97 KB / Downloads: 6)
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#5
Hi heb,

noch ein kleiner Nachtrag. Ich hatte jetzt erst gesehen (und auch so interpretiert), dass du die Ausgabe als Satz haben willst. Das könntest du dann so bewerkstelligen:

Tabelle3

ABCDEFG
7Friesencenter  gefr05.01.15d3012Der Kunde Friesencenter  gefr hat am 05.01.15 den Artikel d 30x bestellt und 12x zurückgegeben.
Formeln der Tabelle
ZelleFormel
A7{=WENN(ZEILE($A4)>SUMME((Tabelle1!$B$4:$B$100=$A$2)*(Tabelle1!$H$4:$H$100="gefr"));"";INDEX(Tabelle1!$D$1:$D$100;KKLEINSTE(WENN((Tabelle1!$B$4:$B$100=$A$2)*(Tabelle1!$H$4:$H$100="gefr");ZEILE($4:$100));ZEILE($A4))))}
B7{=WENN(ZEILE($A4)>SUMME((Tabelle1!$B$4:$B$100=$A$2)*(Tabelle1!$H$4:$H$100="gefr"));"";INDEX(Tabelle1!$B$1:$B$100;KKLEINSTE(WENN((Tabelle1!$B$4:$B$100=$A$2)*(Tabelle1!$H$4:$H$100="gefr");ZEILE($4:$100));ZEILE($A4))))}
C7{=WENN(ZEILE($A4)>SUMME((Tabelle1!$B$4:$B$100=$A$2)*(Tabelle1!$H$4:$H$100="gefr"));"";INDEX(Tabelle1!$E$1:$E$100;KKLEINSTE(WENN((Tabelle1!$B$4:$B$100=$A$2)*(Tabelle1!$H$4:$H$100="gefr");ZEILE($4:$100));ZEILE($A4))))}
D7{=WENN(ZEILE($A4)>SUMME((Tabelle1!$B$4:$B$100=$A$2)*(Tabelle1!$H$4:$H$100="gefr"));"";INDEX(Tabelle1!$F$1:$F$100;KKLEINSTE(WENN((Tabelle1!$B$4:$B$100=$A$2)*(Tabelle1!$H$4:$H$100="gefr");ZEILE($4:$100));ZEILE($A4))))}
E7{=WENN(ZEILE($A4)>SUMME((Tabelle1!$B$4:$B$100=$A$2)*(Tabelle1!$H$4:$H$100="gefr"));"";INDEX(Tabelle1!$G$1:$G$100;KKLEINSTE(WENN((Tabelle1!$B$4:$B$100=$A$2)*(Tabelle1!$H$4:$H$100="gefr");ZEILE($4:$100));ZEILE($A4))))}
G7="Der Kunde "&A7&" hat am "&TEXT(B7;"tt.MM.jj")&" den Artikel "&C7&" "&D7&"x bestellt und" &" "& E7 & "x zurückgegeben."

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Übrigens, in meiner Beispielmappe habe ich auch noch vergessen, das geforderte Datum mit auszugeben.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste