Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Index und Vergleich mit mehreren Bedigungen
#1
Hallo, ich brauch eure Hilfe.
Folgendes Problem: Ich will in Tabelle 1 in die Spalte C die Werte aus Tabelle 2 (Matrix b2:f4) übernehmen.
Dabei sollen die Werte den entsprechenden Typen und Farben zugeordnet werden. Ich bekomme kein Lösung hin. Bin eine totale Anfängerin.
Könnt ihr mir bei dem Problem helfen?

Kasandra


Angehängte Dateien
.xlsx   beispiel1.xlsx (Größe: 8,71 KB / Downloads: 7)
to top
#2
Hallo,

so z.B:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1TypFarbeAnzahl
2VWblau45
3VWrot23
4VWschwarz67
5VWgrün12
6VWweiß98
7Audiblau23
8Audirot23
9Audischwarz43
10Audigrün22
11Audiweiß23
12KIAblau90
13KIArot23
14KIAschwarz95
15KIAgrün91
16KIAweiß86

ZelleFormel
C2=SUMMENPRODUKT((Tabelle2!$A$3:$A$5=Tabelle1!A2)*(Tabelle2!$B$2:$F$2=Tabelle1!B2)*Tabelle2!$B$3:$F$5)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Atilla

Excel 2007
[-] Folgende(r) 1 Benutzer sagt Danke an atilla für diesen Beitrag:
kasandra
to top
#3
Hallo Kassandra,

wenn nur die Werte in den Schnittpunkten wiedergegeben werden müssen, geht es natürlich mit Index und Vergleich:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
1TypFarbeAnzahlWert
2VWblau4545
3VWrot2323
4VWschwarz6767
5VWgrün1212
6VWweiß9898
7Audiblau2323
8Audirot2323
9Audischwarz4343
10Audigrün2222
11Audiweiß2323
12KIAblau9090
13KIArot2323
14KIAschwarz9595
15KIAgrün9191
16KIAweiß8686

ZelleFormel
C2=SUMMENPRODUKT((Tabelle2!$A$3:$A$5=A2)*(Tabelle2!$B$2:$F$2=B2)*Tabelle2!$B$3:$F$5)
D2=INDEX(Tabelle2!$B$3:$F$5;VERGLEICH(A2;Tabelle2!$A$3:$A$5;0);VERGLEICH(B2;Tabelle2!$B$2:$F$2;0))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Auch wenn die Formel etwas länger ist, würde ich dann diese nehmen, da sie Ressourcen schonender ist als Summenprodukt.
Gruß Atilla

Excel 2007
[-] Folgende(r) 1 Benutzer sagt Danke an atilla für diesen Beitrag:
kasandra
to top
#4
(12.01.2015, 21:58)atilla schrieb: Hallo Kassandra,
...
Auch wenn die Formel etwas länger ist, würde ich dann diese nehmen, da sie Ressourcen schonender ist als Summenprodukt.

Hallo, muss ja nicht sein... ... hier ginge auch..:

=INDEX(Tabelle2!$B$3:$F$5;VERGLEICH(A2;Tabelle2!$A$3:$A$5;0);REST(ZEILE(A1)-1;4)+1)
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hallo Jörg,

aber unter der Option, dass die Farben immer in gleicher Reihenfolge stehen, muss vielleicht erwähnt werden.
Gruß Atilla

Excel 2007
to top
#6
(12.01.2015, 22:23)atilla schrieb: Hallo Jörg,

aber unter der Option, dass die Farben immer in gleicher Reihenfolge stehen, muss vielleicht erwähnt werden.

Hallo Atilla, sicher datt. Aber das war ja hier so...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
Hallo Jörg,

je länger nachdenke, desto mehr tendiere ich zur längeren Version.
Nee, ich nehme sie, denn, stell Dir vor da kommt einer oder ich mach das irgendwann selber, ohne daran zu denken und sortiere die Tabelle mal.
Gruß Atilla

Excel 2007
to top
#8
Hallo Atilla und Jockel,

vielen dank für die Unterstützung. Atilas "=Index..." war die Lösung. Ja, ich hatte vergessen zu erwähnen, dass sich die Reihenfolge der Farben ändern kann.

Danke an euch beide100
Kasandra
to top
#9
Hallo, alles ist gut...!!!
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Schwieriges Problem | Index & Verweis Auswertung excelhexel 2 49 30.11.2016, 20:09
Letzter Beitrag: excelhexel
  VERGLEICH mit mehreren möglichen Werten JanReiff 1 59 01.11.2016, 14:23
Letzter Beitrag: shift-del
  Index (Vergleichsbefehl) mit mehreren Variablen? Franzi 79 5 100 21.10.2016, 22:31
Letzter Beitrag: Jockel
  Quote mit mehreren Bedigungen berechnen arada 1 46 19.10.2016, 18:59
Letzter Beitrag: BoskoBiati
  Index Formel nach rechts ziehen und dabei Spalte fixieren Gwendolyn 2 149 30.09.2016, 19:28
Letzter Beitrag: schauan
  Makro für INDEX VERGLEICH Funktion Felixk 6 305 03.08.2016, 11:06
Letzter Beitrag: Felixk
  Index mit mehreren Kriteien sirphilipp 1 209 30.06.2016, 14:01
Letzter Beitrag: BoskoBiati
  Excel 2010 Index Vergleich gweste 2 359 16.06.2016, 18:38
Letzter Beitrag: WillWissen
  Index eines Feldes beibehalten Elke Boese 4 394 20.05.2016, 17:59
Letzter Beitrag: schauan
  "Bezug" in der Funktion Index aus Zelle auslesen jonny.m 2 344 19.05.2016, 16:18
Letzter Beitrag: jonny.m

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste