Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Verweis mit mehreren Ergebnissen von 2 Dateien
#1
Hallo Leute,
nachdem ich nach langem googlen und probieren auf keine Lösung gekommen bin, hoff ich nun die Experten hier können mir helfen.
Folgendes Problem
Ich habe eine Datei in der Name und Vorname und eine dazugehörige Gruppe stehen.
--> Datei 1    

Und nun möchte ich in einer anderen Datei diese Namen+Vornamen zu der Gruppe zuordnen sozusagen eine Liste.
--> Datei 2    

Wenn möglich ohne VBA. ;-)

Gruß Bleame
to top
#2
Hallo,

ungetestet:

Code:
=wennfehler(kkleinste(wenn([Datei1.xlsx]Tabelle1!$C$2:$C$30=B$10;[Datei1.xlsx]Tabelle1!$A$2:$A$30&", "&[Datei1.xlsx]Tabelle1!$B$2:$B$30);Zeile(a1));"")
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#3
Hallo,

danke für die schnelle Antwort.

Hab jetz folgendes in Feld B11 in Datei 2 eingegeben:
Code:
=WENNFEHLER(KKLEINSTE(WENN('[Datei 1.xlsx]Tabelle1'!$C$2:$C$22=B10;'[Datei 1.xlsx]Tabelle1'!$A$2:$A$22&", "&'[Datei 1.xlsx]Tabelle1'!$B$2:$B$22);ZEILE(A1));"")

Leider kommt ein leeres Feld raus... also der Wert_falls_Fehler bei WENNFEHLER also ""

hab ich irg. etwas falsch eingegeben???
Gruß Bleame
to top
#4
Hallo,

öffne doch beide Dateien und gib die Formel schritt für Schritt ein, in dem Du die angegebenen Bereiche
in den Dateien markierst.

Sonst einfach mal Wennfehler rausnehmen und die Formel auswerten.
Gruß Atilla

Excel 2007
to top
#5
Hab jetz mal die Auswertung gemacht und ich denke das Problem liegt an dem Zeile(A1),
was bedeutet denn dieser Ausdruck in der Formel?... gehört ja zu KKleinste, oder?
Das ist ja logischer Weise 1...

Hier noch ein Bild von der Auswertung ohne WENNFEHLER    

Danke nochmals für eure Hilfe!
to top
#6
Hallo,

mir ist die Formeln von Edgar nicht ganz klar.

Aus Gründen der einfacheren Darstellung habe ich das mal in einem Tabellenblatt untergebracht. Stellst du dir das so vor?

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGH
2NameVornameGruppe  ABC
3KlauserKC  Better, SMayer, SKlauser, K
4BetterSA   Jahn, FHuber, M
5MayerSB     
6HuberMC     
7JahnFB     
8        

ZelleFormel
F3{=WENNFEHLER(INDEX($A$2:$A$10;KKLEINSTE(WENN($C$2:$C$10=F$2;ZEILE($1:$9));ZEILE(A1)))&", "&INDEX($B$2:$B$10;KKLEINSTE(WENN($C$2:$C$10=F$2;ZEILE($1:$9));ZEILE(A1)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
to top
#7
Erst mal guten Abend.

@ Peter: Super hat mit folgender Formel funktioniert!
Code:
=WENNFEHLER(INDEX('[Datei 1.xlsx]Tabelle1'!$A$2:$A$22;KKLEINSTE(WENN('[Datei 1.xlsx]Tabelle1'!$C$2:$C$22=$B$10;ZEILE($1:$20));ZEILE(A1)))&", "&INDEX('[Datei 1.xlsx]Tabelle1'!$B$2:$B$22;KKLEINSTE(WENN('[Datei 1.xlsx]Tabelle1'!$C$2:$C$22=$B$10;ZEILE($1:$20));ZEILE(A1)));"")

DANKE, Danke, Danke nochmal!

Gruß Bleame
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  2 Tabellen zusammenführen / S-Verweis? TomTom74 8 174 01.02.2017, 19:58
Letzter Beitrag: schauan
  S-Verweis mit 2 Suchkriterien SebGDM 11 142 30.01.2017, 13:59
Letzter Beitrag: schauan
  S-Verweis Problem BenediktS 3 132 18.01.2017, 05:00
Letzter Beitrag: Gast 123
  Wenn/Verweis Reniiii 3 130 12.01.2017, 11:03
Letzter Beitrag: Rabe
  Suchfunktion mit mehreren Ergebnissen Pelegrinoides 4 125 27.12.2016, 16:52
Letzter Beitrag: BoskoBiati
  exel verweis evera 8 239 29.11.2016, 11:11
Letzter Beitrag: evera
  Größe von Formen an Hand von Ergebnissen ändern Evident 5 210 29.10.2016, 08:53
Letzter Beitrag: schauan
  S-verweis auf gefilterte Matrix Frankie 4 292 22.10.2016, 17:55
Letzter Beitrag: Jockel
  Verweis Abfrage (Experten gesucht) PHI 8 393 06.10.2016, 19:32
Letzter Beitrag: Käpt'n Blaubär
  dynamischer Verweis exceltalent 3 232 29.09.2016, 12:44
Letzter Beitrag: Jockel

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste