Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


SUMMEWENN
#1
Hi,

ich glaube, ich habe die Funktion SUMMEWENN falsch verstanden. Warum wird nicht die Summe des gleichen Monats angezeigt?

Daten
ABCDEFGHIJK
2KWTagDatumbrofrabro+fraMA
3KW 1/2015Fr02.01.2015000Jan 15000
4KW 2/2015Mo05.01.2015000627218845
5KW 2/2015Mi07.01.2015233422754
6KW 2/2015Do08.01.2015251503014
7KW 2/2015Fr09.01.20151431262694
8KW 3/2015Mo12.01.2015#NV4

verwendete Formeln
Zelle Formel Bereich N/A
H3=C3
I3:J3=SUMMEWENN($C:$C;MONAT($H3);D: D)
K3=SUMME(I3:J3)
I4:K4=SUMME(D3: D22)
A3:A8="KW " & KALENDERWOCHE(C3;21) & "/" & JAHR(C3)
B3:B8=C3
C3:C8=ARBEITSTAG(DATUM($A$1;1;1)-1;ZEILE(A1);Feiertage!$B$59:$B$87)
F3:F8=WENN(UND(D3="";E3="");"#NV";SUMME(D3:E3))
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#2
Hallo,

ich würde hier mit Summenprodukt arbeiten:

Code:
=SUMMENPRODUKT((JAHR(C2:C7)=JAHR(H3))*(MONAT(C2:C7)=MONAT(H3))*(D2:D7))

oder mit einer Pivottabelle
Gruß
Peter
to top
#3
Hi Ralf,

Deine Formel sucht nach allen Zeilen, in denen in Spalte C eine 1 steht (Monat von C3).
Du suchst eher sowas:

=SUMMENPRODUKT((MONAT($C3:$C999)=MONAT($H$3))*D3Big Grin999)

Gruß Uwe
to top
#4
Hi ihr Zwei,

danke, habe es jetzt sowohl mit Summenprodukt, als auch mit Pivot gelöst. Mal sehen, was dem Kollegen besser gefällt.

Aber eigentlich müßte das doch auch mit der Summewenn funktionieren?

Weitere Frage: wie kann ich die Formel in Spalte H machen, daß es nur am ersten oder am letzten Arbeitstag des Monats erscheint?
Daten
ABCDEFGH
3KW 1/2015Fr02.01.2015000Jan 15
4KW 2/2015Mo05.01.2015000
5KW 2/2015Mi07.01.2015233422754
6KW 2/2015Do08.01.2015251503014
7KW 2/2015Fr09.01.20151431262694
8KW 3/2015Mo12.01.2015#NV4
9KW 3/2015Di13.01.2015#NV4
10KW 3/2015Mi14.01.2015#NV4
11KW 3/2015Do15.01.2015#NV4
12KW 3/2015Fr16.01.2015#NV4
13KW 4/2015Mo19.01.2015#NV
14KW 4/2015Di20.01.2015#NV
15KW 4/2015Mi21.01.2015#NV
16KW 4/2015Do22.01.2015#NV
17KW 4/2015Fr23.01.2015#NV
18KW 5/2015Mo26.01.2015#NV
19KW 5/2015Di27.01.2015#NV
20KW 5/2015Mi28.01.2015#NV
21KW 5/2015Do29.01.2015#NV
22KW 5/2015Fr30.01.2015#NV
23KW 6/2015Mo02.02.2015#NVFeb 15
24KW 6/2015Di03.02.2015#NV
25KW 6/2015Mi04.02.2015#NV

verwendete Formeln
Zelle Formel Bereich N/A
H3,H23=C3
A3:A25="KW " & KALENDERWOCHE(C3;21) & "/" & JAHR(C3)
B3:B25=C3
C3:C25=ARBEITSTAG(DATUM($A$1;1;1)-1;ZEILE(A1);Feiertage!$B$59:$B$87)
F3:F25=WENN(UND(D3="";E3="");"#NV";SUMME(D3:E3))
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#5
Hallo Ralf,

eine ganz primitive Lösung wäre:

=WENN(MONAT(C2)<>MONAT(C1);C1;"")
Gruß Atilla

Excel 2007
to top
#6
(12.01.2015, 14:24)Rabe schrieb: Hi ihr Zwei,

danke, habe es jetzt sowohl mit Summenprodukt, als auch mit Pivot gelöst. Mal sehen, was dem Kollegen besser gefällt.

Aber eigentlich müßte das doch auch mit der Summewenn funktionieren?
...

Hallo Ralf, nein. Und wenn ich das mit SUMMENPRODUKT() mache, würde ich das auch anders machen... das letzte Array z.b. nicht multiplizieren... aber das hatten wir ja schon... ... und ich würde auch nicht mit JAHR() und MONAT() arbeiten - ich bin ja eher faul... ... deswegen würde ich es mit TEXT() machen...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
Hi Atilla,

(12.01.2015, 14:32)atilla schrieb: eine ganz primitive Lösung wäre:

Ja, klar, so gehts.

Das war mein erster Versuch gewesen, da habe ich aber bei dieser Primitvformel was falsch getippt und da stand dann beim Monatswechsel zum Februar auch Leer.
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#8
Hi Jörg,

(12.01.2015, 14:38)Jockel schrieb:
(12.01.2015, 14:24)Rabe schrieb: Aber eigentlich müßte das doch auch mit der Summewenn funktionieren?
...

nein.

das ist doch eine klare Aussage, dann brauche ich mir darüber keine Gedanken mehr machen.
Danke!
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#9
Hallo,

im übrigen gibt es SUMMEWENNS, damit könnte man es machen:

Code:
=SUMMEWENNS($D:$D;$C:$C;">"&$H3-tag($H3);$C:$C;"<="&Monatsende($H3;0))
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Summewenn jum 1 57 03.12.2016, 21:09
Letzter Beitrag: schauan
  SummeWenn aus alle Arbeitsblätter Pean 4 68 03.12.2016, 11:55
Letzter Beitrag: shift-del
  "kumulierte" summewenn (oder sowas ähnliches) Sebinator 6 117 24.11.2016, 07:09
Letzter Beitrag: Jockel
  Summewenn mehrere Blätter Mario_Hana 7 71 21.11.2016, 16:04
Letzter Beitrag: BoskoBiati
  excel summewenn, zählenwenns Fehler MeKeMo 1 84 06.11.2016, 13:00
Letzter Beitrag: shift-del
  Summewenn ODER Alpha_2412 4 86 27.10.2016, 12:23
Letzter Beitrag: steve1da
  Summewenn mit Teilstring in Tabelle wush 3 131 21.09.2016, 18:50
Letzter Beitrag: wush
  Suche nach Name und dann SummeWenn mic48 2 187 15.09.2016, 11:22
Letzter Beitrag: mic48
  SummeWenn unter der Bedingung dass Sascha1990 3 156 12.09.2016, 14:22
Letzter Beitrag: Sascha1990
  Nullwerte bei SUMMEWENN Hinnerk 2 164 21.08.2016, 21:34
Letzter Beitrag: steve1da

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste