Häufigkeiten ohne doppelte Werte berechnen
#1
Hallo 

ich habe eine Frage zu Excel und bin Anfänger in dem Bereich. 

Im Rahmen meiner Masterarbeit Personen zu ihren Urlaubsreisen in den vergangenen drei Jahren befragen. 

Dafür sollen mir die Personen die Namen der Länder angeben in die Sie gereist sind jeweils separat für die Jahre 2015,2016 und 2017 somit drei Fragen. 

Jedes Land ist mit einem Code versehen von 1 bis circa 226. zB 1 für italien, 2 für Frankreich usw.

Jetzt möchte ich pro Person die Anzahl der bereisten Länder in den drei Jahren ermitteln, so dass mir jene Länder automatisch aus der Statistik rausgenommen werden, die mehrfach bereist wurden und gleichzeitig die Summe der bereisten Länder berechnet wird. Habe das heute mit einem Datensatz versucht. 

Im Netz habe ich auf Seiten gefunden die das Erklären (ink. Formeln). dort wird immer von Spalten geredet meine Daten befinden sich aber über Zeilen verteilt. Ich habe auch versucht die Formeln zu kopieren und mit den Zeilen einzugeben. es hat nicht funktioniert. 

Kann mir irgendwer weiterhelfen und erklären wie ich diese Formel so eingebe, dass sie über Zeilen funktioniert und doppelte Werte im Bereich zwischen 1 bis 227 nicht erfasst ? 

Danke mit freundlichen Grüßen 

Bol 
Zitieren to top
#2
Hallo,

deine Zahlencodes sind in Spalte A, ab A1

In einer Hilfsspalte, z.B. Spalte B ab B1 folgende Formel:
=ZÄHLENWENN(A$1:A1;A2)>=1
Formel bis ans Tabellenende ziehen

Folgende Formel in C1 zum Zählen ohne die Doppelten:
=ZÄHLENWENN(B:B;FALSCH)

Gruß Werner
[-] Folgende(r) 1 Benutzer sagt Danke an Werner.M für diesen Beitrag:
  • bolimbo
Zitieren to top
#3
Aber bitte was gebe ich ein wenn mein datensatz eine Zeile ist von j3 bis bq3 ? 

in diesen Zeilen (von j3 bis bq3) sind die Antwortenmgölichkeiten eines Probanden, je nach dem welche Länder er besucht hat mit einer Zahl für das jeweilige Land versehen (wenn ich excel datei runterlade von der umfrageplattform ist das so dargestellt) ....jetzt mag ich das nicht von der zeile in die spalten übertippen, weil extrem viel arbeit bei 100 bfragten personen, sondern in der zeile die werte berechnen (von j3 bis bq3) 
Wie muss diese Formel dann lauten

=ZÄHLENWENN(A$1:A1;A2)>=1 

=ZÄHLENWENN(B:B;FALSCH)

ich checks nicht 

danke 

mit freundlichen grüßen 

bol
Zitieren to top
#4
Hallo,

Hilfszeile in Zeile 4 (kannst du dann ja ausblenden)
Formel in Zelle J4: =ZÄHLENWENN($J3:J3;K3)>=1
nach rechts bis BQ ziehen

Formel in Ergebniszelle: =ZÄHLENWENN(J4:BQ4;FALSCH)

Gruß Werner
[-] Folgende(r) 1 Benutzer sagt Danke an Werner.M für diesen Beitrag:
  • bolimbo
Zitieren to top
#5
Ok ich habs jetzt versucht und es klappt noch immer nicht.

in der arbeit habe ich glückerlicherweise eine neuere Excel Version mit der habe ich meine Daten in spalten darstellen können. ich habe die Formel eingegeben wie oben beschrieben aber es geht nicht.

im anhang ist ein screenshot von dem was nicht geht...ich habe es versucht mit der spalte b2 bis b14 (alle anderen Daten die nicht passen notwendigerweise erfasst werden müssen habe ich rausgenommen von daher jetzt eine verkürzte liste). Mir ist klar, dass die Formel bei c2 bis c14 so nicht greift, da ich dabei von wert -9 ausgehen müsste.

bitte wenn ihr euch den screenshot anschaut was mache ich denn falsch? ich habe es probiert mit =ZÄHLENWENN(b$2:b2;b14)>=1 ich habs probiert mit ($b2:b2;b14) ich habs probiert mit (b$2;b2:b14)...es geht nicht 22 22 22 

weitere frage die mir in dem zusammenhang jetzt eingefallen ist, wenn ich die -9 Felder nicht mitzählen wollen würde, also als Leerfeld behandeln wollen würde, wie würde ich dann vorgehen von der Formel her?

Danke

mit freundlichen grüßen

bol


Angehängte Dateien Thumbnail(s)
   
Zitieren to top
#6
Moin,
leider werde ich aus deiner Anforderungsbeschreibung nicht so wirklich schlau ...
Wenn ich die letzten Daten (Screenshot) mit meiner Bildbearbeitung 22 auswerte, kommt das heraus:


Angehängte Dateien Thumbnail(s)
   
Beste Grüße
  Günther

Excel-ist-sexy.de
  …schau doch mal rein!
Der Sicherheit meiner Daten wegen lade ich keine *.xlsm bzw. *.xlsb- Files mehr herunter! -> So geht's ohne!
Zitieren to top
#7
Hola,

http://www.online-excel.de/fom/fo_read.p...1870#a123x

dort soll also alles noch einmal durchgegangen werden?

Gruß,
steve1da
Zitieren to top
#8
hm ok das vesrtehe ich noch weniger.....

ja ich möchte aus einer liste die Häufigkeiten ermitteln ohne die doppelten werte dabei miteinzurechnen.

wenn ich die formel  =ZÄHLENWENN(b$2:b2;b14)>=1 oder ($b2:b2;b14) oder (b$2;b2:b14) so eingebe es funktioniert nicht.

es geht um die spalten werte

bspw. b2: 12, b3: 14, b4: 12, b5: 17, b6:81 = 4 (da 12 doppelt ist) das wäre mein gewünschter Output  aber von den Formeln her geht gar nix weil immer wieder falsch kommt egal wie ich es eingebe.

mit freundlichen grüßen

bol
Zitieren to top
#9
Schau einmal hier nach.

http://www.excelformeln.de/formeln.html?welcher=42
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • bolimbo
Zitieren to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste