Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


[Excel] Verbundene Zellen - Fluch oder Segen?
#1
Immer wieder haben User Probleme beim korrekten Berechnen umfangreicher Tabellen. Beim genaueren Hinsehen auf die Original(getreue)Datei werden aber genau so oft verbundene Zellen festgestellt. Und die haben es in der Regel in sich und veranlassen die Helfer, vehement davon abzuraten. Übrigens, auch ich bin ein Liebhaber der verbundenen Zellen - allerdings ausschließlich in Überschriften. Und selbst hier benutze ich mittlerweile zu 99% die weiter unten gezeigte Alternative.

Doch nun zu einem einfachen Beispiel.

Dieser kleine Bereich soll summiert werden. Das Ergebnis ist 104 - die kummulierten Zeilen- bzw. Spaltensummen beweisen die Richtigkeit.


Tabelle1
ABCDEFGH
1Zeilen-summeSpalten-summeGesamt-summe
21123143010104
323451434
43145163818
545672242
6104104

verwendete Formeln
Zelle Formel Bereich N/A
G2=SUMME(A2:A5)
H2=SUMME(A2: D5)
G3=SUMME(B2:B5)
G4=SUMME(C2:C5)
F2:F5=SUMME(A2:E2)
G5=SUMME(D2: D5)
F6:G6=SUMME(F2:F5)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 17.06 einschl. 64 Bit



Der erste Versuch.


Tabelle1
ABCDEFGH
8jeweils einzeln verbundene Zellen
9Zeilen-summeSpalten-summeGesamt-summe
101341028
112460
1235818
1346100
142828
15
1600die verbundenen Nachbarzellen sind leer
1700
1800
1900

 verbundene Zellen
A10:B10
C10: D10
A11:B11
C11: D11
A12:B12
C12: D12
A13:B13
C13: D13

verwendete Formeln
Zelle Formel Bereich N/A
G10=SUMME(A10:A13)
H10=SUMME(A10: D13)
G11=SUMME(B10:B13)
G12=SUMME(C10:C13)
F10:F13=SUMME(A10:E10)
G13=SUMME(D10: D13)
F14:G14=SUMME(F10:F13)
B16:B19,D16: D19=B10
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 17.06 einschl. 64 Bit



Es wurden jeweils die Zellenpaare A & B sowie C & D einzeln verbunden und zentriert. Bereits beim Ausführen dieser Maßnahme wies Excel darauf hin, dass nur die Werte aus der linken Zelle berücksichtigt werden. Ergebnis: alle Werte der zweiten Zelle eines Paares sind verschwunden.

Doch ganz verrückt wird es, wenn die Zellenpaare nicht explizit einzeln verbunden werden, sondern mittels Formatpinsel ein früherer Verbund übertragen wird.

Dann sieht die ganze Sache so aus:


Tabelle1
ABCDEFGH
22jeweils mit Formatpinsel verbundene Zellen.
23Zeilen-summeSpalten-summeGesamt-summe
24133010104
25241434
26353818
27462242
28104104
291214
3035
311416
3257

 verbundene Zellen
A24:B24
C24: D24
A25:B25
C25: D25
A26:B26
C26: D26
A27:B27
C27: D27

verwendete Formeln
Zelle Formel Bereich N/A
G24=SUMME(A24:A27)
H24=SUMME(A24: D27)
G25=SUMME(B24:B27)
G26=SUMME(C24:C27)
F24:F27=SUMME(A24:E24)
G27=SUMME(D24: D27)
F28:G28=SUMME(F24:F27)
B29:B32,D29: D32=B24
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 17.06 einschl. 64 Bit



Wie von Zauberhand sind zwar nur die Werte der jeweils linken Zellen eines Verbundpaares sichtbar, in die Berechnung fließen aber die Werte der rechten Zelle mit ein.

Der eine oder andere wird jetzt wohl zu Recht sagen: ich verbinde doch keine Zellen, in denen ich Werte stehen habe.

Wirklich? Was ist mit übernommenen Tabellen, in denen die Nachbarzellen (nur scheinbar) leer sind? Seht den ganzen Beitrag nur als Hinweis, sensibler und kritischer mit verbundenen Zellen umzugehen.

Und hier die bereits angedeutete Alternative zu verbundenen Zellen:

1. die Zellenpaare (natürlich auch mehrere nebeneinander liegende) markieren
2. CTRL-1 drücken. Es öffnet sich das Menü "Zellen formatieren"
3. Bei Textausrichtung-Horizontal "Über Auswahl zentrieren" anklicken und mit OK bestätigen.

Der Nachteil dieser Alternative: es lassen sich nur Zellen einer Zeile, nicht jedoch einer Spalte auf diese Art "verbinden".


Ergänzung am 20.05.2014 durch Kl@us-M.:

Ausserdem hat das Verbinden einen weiteren bitteren Beigeschmack: Du kannst einen Zellbereich, in dem sich verbundene Zellen befinden, nicht mehr sortieren, auch lässt sich der AutoFilter nicht mehr einsetzen. Selbst beim Kopieren der Zellen kann es zu Problemen kommen. Wenn zudem Code in der Mappe vorhanden ist, der auf eine ursprünglich nicht verbundene Zelle referenziert, wirft der Code mit einer Fehlermeldung ab.
Eine Beispielmappe, in der "Sortieren" oder "Bereich kopieren" eben wegen der verbundenen Zellen nicht klappt, kannst Du Dir hier [KLICK] herunterladen ...
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [Excel] Gleichzeitige Inhaltsänderung in mehreren Zellen WillWissen 0 3.923 25.06.2014, 05:34
Letzter Beitrag: WillWissen
  [Excel] & in der Kopf- oder Fußzeile Peter 0 714 13.05.2014, 10:35
Letzter Beitrag: Peter
  [Excel] Uhrzeiten oder Stundenangaben komfortabel erfassen Kl@us-M. 0 1.881 15.04.2014, 09:32
Letzter Beitrag: Kl@us-M.
  [Excel] Zellen mit rechter Maustaste "ziehen" Kl@us-M. 0 852 14.04.2014, 13:29
Letzter Beitrag: Kl@us-M.

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste