Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Wenn Funktion
#1
Hallo,

habe wieder eine kleine Frage und komme zur Zeit nicht drauf.
In einer Tabelle soll wenn in A2 etwas drin steht in B2 rot reingeschrieben werden
A3; in B3 grün
A4;in B4 blau
A5;in B5 gelb
A6 in B6 grau
A7 in B7 weiß
A8 in B8 Violett.

Wer kann helfen?
Für Profis eine Kleinigkeit.

Gruß

Bernd
to top
#2
Hallo,

du könntest eine Bedingte Formatierung verwenden.

B2 markieren - Bedingte Formatierung - Neue Regel - Formel zur Ermittlung - =A2<>"" - Formatieren und das gewünschte Format wählen.

Das wiederholst du für B3 bis B8.
Gruß
Peter
to top
#3
Danke Peter,

soweit i.O. aber es sollte in Feld 2 das Wort rot geschrieben werden.
Und dann in der Formatierung rot ausgefüllt mit weißem Text rot
usw.

Bernd
to top
#4
Hallo,

wenn da das Wort 'Rot' in der Zelle stehen soll (das habe ich so aus dem ersten Posting nicht herausgelesen) dann könntest du in B2 zusätzlich noch die Formel

=Wenn(A2<>"";"Rot";"")

einfügen.
Gruß
Peter
to top
#5
Hallo,

ich stelle mich zu däm.... an bekomme es nicht hin.
Kannst du ein Muster posten?

Bernd
to top
#6
Hallo,

vielleicht habe ich dein Vorhaben auch noch nicht verstanden.

Bei mir sieht das so aus, wobei ich für die Bedingte Formatierung jetzt einfach eine gelbe Hintergrundfarbe genommen habe:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
2  
3TestRot

ZelleFormel
B2=WENN(A2<>"";"Rot";"")
B3=WENN(A3<>"";"Rot";"")

Zellebedingte Formatierung...Format
B21: =A2<>""abc
B31: =A3<>""abc
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
to top
#7
(06.01.2015, 17:45)Bernd schrieb: Hallo,

ich stelle mich zu däm.... an bekomme es nicht hin.
Kannst du ein Muster posten?

Bernd

Hallo Bernd, das ist der falsche Ansatz, schick Du doch bitte (d)ein Muster... ... da sähe man wo es hakt...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#8
Hallo

jetzt habe ich es hat nur ein kleiner Tritt gefehlt.

Danke und schönen Abend.

Bernd


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 9,99 KB / Downloads: 8)
to top
#9
Hallo Bernd, du verbrätst hier 5 (in Worten fünf) bedingte Formatierungen... ... Wenn Du das anders herum angehst, kommst Du mit einer aus... - die bed. Formatierung aus Spalte B wird hier nicht richtig dargestellt..., dafür meine in Spalte C

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
2xRotRot
31grüngrün
41blaublau
51gelbgelb
61graugrau
71weißweiß
81violettviolett

ZelleFormel
B2=WENN($A2<>"";"Rot";"")
C2=WENN(A2<>"";"Rot";"")

Zellebedingte Formatierung...Format
B21: Zellwert ist gleich ="grau"abc
B22: Zellwert ist gleich ="gelb"abc
B23: Zellwert ist gleich ="blau"abc
B24: Zellwert ist gleich ="grün"abc
B25: Zellwert ist gleich ="rot"abc
C21: =$A2=""abc
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#10
Hallo Danke für die weitere Idee,
aber die 7 Farben sind in der Reihenfolge vorhanden.
Trage ich in A2-A4 nichts ein bleiben B2-B4 leer und es sind nur die letzten 4 Farben
ersichtlich.
Kann sein das es anders auch geht,aber ich muss es zum Verstehen in einer Tabelle sehen.

Bernd
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Hilfe bei Wenn-Funktion benötigt MichaelaV. 2 35 06.12.2016, 07:45
Letzter Beitrag: MichaelaV.
  Wenn Dann Funktion in Komb. mit Bedingter Formatierung snoopy4000_0 9 94 21.11.2016, 16:19
Letzter Beitrag: snoopy4000_0
  "Wenn"Funktion Maik1010 2 54 11.11.2016, 14:23
Letzter Beitrag: Maik1010
  Summieren und Wenn Funktion Strong 2 70 31.10.2016, 10:20
Letzter Beitrag: coemm
  Formeln (Wenn Funktion) Kickban 4 100 25.10.2016, 13:08
Letzter Beitrag: Kickban
  Hilfe bei WENN- Funktion alnourx 8 202 17.10.2016, 13:47
Letzter Beitrag: alnourx
  Zirkelbezugwarnung bei Wenn Funktion. Thanatos 7 179 14.10.2016, 07:17
Letzter Beitrag: BoskoBiati
Video SVerweis mit Wenn Dann Sonst Funktion Verknüpfung HollyBoy 16 465 14.10.2016, 05:56
Letzter Beitrag: WillWissen
  Verschaltung der Wenn Oder Funktion thecrazykaktus 2 155 09.09.2016, 11:34
Letzter Beitrag: thecrazykaktus
  Funktion -> Nur in Spalte X zählen wenn Y in Spalte Z steht MacTop 18 535 07.09.2016, 13:59
Letzter Beitrag: MacTop

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste