Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Daten sortieren und einer skala zuordnen
#1
Hallo Community,

ich habe ein Problem mit der Zuordnung von Daten, habe schon viel probiert aber komme einfach nicht zur zufriedenstellenden Lösung. Vielleicht ist die Lösung voll einfach, aber meine Excel-Kenntnisse sind auch nicht so stark aufgeprägt.
Zur Problemstellung:

Ich habe eine Skala anhand der ich daten sortieren und zuordnen möchte mit Problemstellung und Problemlösung (siehe Anhang).

Kann mir bitte jemand helfen, wie ich die Daten automatisch sortieren kann? Das würde mir sehr viel Arbeit sparen.

Vielen Dank und Beste Grüße
fisherman


Angehängte Dateien
.xlsx   Datensortierung_Bsp.xlsx (Größe: 9,78 KB / Downloads: 11)
to top
#2
Hallo,

hier ein etwas starrer Lösungsweg:

Arbeitsblatt mit dem Namen 'Problemlösung'
 ABCDEF
1Skala Datenskala_1Datenwerte_1Datenskala_2Datenwerte_2
2      
30,1     
40,2 0,2234  
50,3     
60,4     
70,5 0,5564  
80,6     
90,7     
100,8   0,8432
110,9   0,965
121 13445  
131,1 1,1211,1786
141,2     
151,3 1,3643  
161,4     
171,5   1,5332
181,6     
191,7   1,734
201,8     
211,9     
222     

ZelleFormel
C3=WENNFEHLER(SVERWEIS($A3;Problemstellung!$C$3:$D$7;1;0);"")
D3=WENNFEHLER(SVERWEIS($A3;Problemstellung!$C$3:$D$7;2;0);"")
E3=WENNFEHLER(SVERWEIS($A3;Problemstellung!$E$3:$F$7;1;0);"")
F3=WENNFEHLER(SVERWEIS($A3;Problemstellung!$E$3:$F$7;2;0);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Atilla


...und ich gelobe Besserung...

[-] Folgende(r) 1 Benutzer sagt Danke an atilla für diesen Beitrag:
fisherman
to top
#3
(05.01.2015, 14:20)fisherman schrieb: Hallo Community,

Ich habe eine Skala anhand der ich daten sortieren und zuordnen möchte mit Problemstellung und Problemlösung (siehe Anhang).

...

Vielen Dank und Beste Grüße
fisherman

Hallo, ich finde Deine Aufgabe voll schwer zu verstehen...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#4
Hallo Atilla,

vielen Dank dir!
es Klappt fürs erste.232323
Jetzt kann ich witerwursteln :-)

Beste Grüße fisherman
to top
#5
(05.01.2015, 14:46)atilla schrieb: Hallo,

hier ein etwas starrer Lösungsweg:

Arbeitsblatt mit dem Namen 'Problemlösung'
 ABCDEF
1Skala Datenskala_1Datenwerte_1Datenskala_2Datenwerte_2
2      
30,1     
40,2 0,2234  
50,3     
60,4     
70,5 0,5564  
80,6     
90,7     
100,8   0,8432
110,9   0,965
121 13445  
131,1 1,1211,1786
141,2     
151,3 1,3643  
161,4     
171,5   1,5332
181,6     
191,7   1,734
201,8     
211,9     
222     

ZelleFormel
C3=WENNFEHLER(SVERWEIS($A3;Problemstellung!$C$3:$D$7;1;0);"")
D3=WENNFEHLER(SVERWEIS($A3;Problemstellung!$C$3:$D$7;2;0);"")
E3=WENNFEHLER(SVERWEIS($A3;Problemstellung!$E$3:$F$7;1;0);"")
F3=WENNFEHLER(SVERWEIS($A3;Problemstellung!$E$3:$F$7;2;0);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Hallo Atilla, schau mal, ob das so richtig ist..: die 0,2 aus Datenskala_1 steht doch bei Skala 0,1... ... soll das so..?


Arbeitsblatt mit dem Namen 'Problemstellung'
 ABC
1Skala Datenskala_1
2   
30,1 0,2
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hallo Jörg,

die Skala in der Tabelle Problemstellung hat keine Bedeutung.
Gruß Atilla


...und ich gelobe Besserung...

to top
#7
Hallo Jörg,

vielleicht wird es so deutlicher:

Arbeitsblatt mit dem Namen 'Problemlösung'
 ABCD
1Skala Datenskala_1Datenwerte_1
2    
30,1   
40,2 0,2234
50,3   
60,4   
70,5 0,5564
80,6   
90,7   
100,8   
110,9   
121 13445
131,1 1,121
141,2   
151,3 1,3643
161,4   
171,5   
181,6   
191,7   
201,8   
211,9   

ZelleFormel
C3=WENN(D3="";"";A3)
D3=WENNFEHLER(SVERWEIS($A3;Problemstellung!$C$3:$D$7;2;0);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Atilla


...und ich gelobe Besserung...

to top
#8
Hi,

(05.01.2015, 14:20)fisherman schrieb: Kann mir bitte jemand helfen, wie ich die Daten automatisch sortieren kann? Das würde mir sehr viel Arbeit sparen.

ich würde die Datenskala_1 und Datenskala_2 usw. in der Lösungstabelle einfach ausblenden, die wird doch dann gar nicht mehr benötigt:

Problemlösung
ABDFH
1SkalaDatenwerte_1Datenwerte_2Datenwerte_x
2
30,1
40,2234
50,3
60,4
70,5564
80,6
90,7
100,8432
110,965
1213445
131,121786
141,2
151,3643
161,4
171,5332
181,6
191,734
201,8
211,9598
222321
23

verwendete Formeln
Zelle Formel Bereich N/A
D3: D22,F3:F22,H3:H22=WENNFEHLER(SVERWEIS($A3;Problemstellung!C$3: D$9;2;0);"")
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#9
Hallo in D reicht ein einfacher VERWEIS()...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#10
Hallo,

und hie etwas flexibler:

Arbeitsblatt mit dem Namen 'Problemlösung'
 ABCDEFGH
1Skala Datenskala_1Datenwerte_1Datenskala_2Datenwerte_2Datenskala_xDatenwerte_x
2        
30,1      
40,2 0,2234  
50,3       
60,4       
70,5 0,5564    
80,6       
90,7       
100,8   0,8432  
110,9   0,965  
121 13445    
131,1 1,1211,1786  
141,2       
151,3 1,3643    
161,4       
171,5   1,5332  
181,6       
191,7   1,734  
201,8       
211,9    598  
222    321  

ZelleFormel
C3=WENN(D3="";"";A3)
D3=WENNFEHLER(INDEX(Problemstellung!D$3:D$22;VERGLEICH($A3;Problemstellung!C$3:C$22;0));"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Den Bereich C1Big Grin1 kopieren und in die anderen Bereiche einfügen.
Gruß Atilla


...und ich gelobe Besserung...

to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Gezielte Daten von einer Datei kopieren Hooorn 12 328 01.03.2017, 09:21
Letzter Beitrag: WillWissen
  Aus einer Tabelle Daten nach Datum herausfiltern, abzüglich Kündigungen menslo 1 60 28.02.2017, 16:30
Letzter Beitrag: steve1da
  Zuordnen skyline 5 92 18.02.2017, 23:15
Letzter Beitrag: Ego
  VBA: Daten von einer in andere Datei schreiben DrWahnsinn 11 215 14.02.2017, 14:09
Letzter Beitrag: tw3aker
  Kalkulation der Daten einer Abfrage in Excel excelblower 2 99 30.01.2017, 17:53
Letzter Beitrag: schauan
  Tageskurse zuordnen Leini 12 224 19.01.2017, 16:10
Letzter Beitrag: steve1da
  Sortieren von Datensätzen nach mehreren Kriterien in einer Zeile Doesie 2 200 12.01.2017, 12:01
Letzter Beitrag: Doesie
  Nach Namen sortieren - mit einer Bedingung swissbird 5 266 08.01.2017, 22:30
Letzter Beitrag: swissbird
  Daten aufbereiten / sortieren themanfrommoon 4 189 09.12.2016, 21:13
Letzter Beitrag: Jockel
Thumbs Up Daten aus einer Matrix auslesen tbuergel 1 162 25.11.2016, 21:39
Letzter Beitrag: shift-del

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste