Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Mehrfachabfragen ignorieren
#1
Hallo zusammen,

ich habe folgendes Problem, wobei ich eure Hilfe gebrauchen könnte:

Ich habe eine große Tabelle mit Anfragen von Kunden. Die Tabelle ist folgendermaßen aufgebaut.

Warenkorb----------Betrag------------Uhrzeit
1111-----------------100---------------12:31
1111-----------------101---------------12:30
1112-----------------200---------------13:30
1113-----------------300---------------13:34

Ich möchte nun Berechnungen damit anstellen, jedoch Mehrfachabfragen ignorieren. Beispielsweise soll der Warenkorb 1111 nur einmal mit in Berechnungen eingezogen werden. Das Kriterium dafür ist die späteste Anfrage, also mit der Uhrzeit 12:31.

An dem Beispiel oben sollte nun in Spalte D einem der Betrag 100 (für den Warenkorb von 12:31) und einmal 0 (für den Warenkorb um 12:3) stehen.

Ich bin soweit dass ich sage:

=SUMME(($C$13:$C$16=MAX(WENN($A$13:$A$16=H13;$C$13:$C$16)))*($A$13:$A$16=H13)*$B$13:$B$16)

Ich brauche noch den finalen Schritt dass bei dem zweiten Warenkorb 0 steht!

Habt Ihr irgendwelche Ansätze, wie ich das Problem lösen könnte?

Vielen Dank im Voraus und vielen lieben Dank!
to top
#2
Hallo,

suchst Du sowas:

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCD
1WarenkorbBetragUhrzeit 
2111110012:31100
3111110112:300
4111220013:30200
5111330013:34300

ZelleFormel
D2{=WENN(C2=MAX(WENN($A$2:$A$5=A2;$C$2:$C$5));B2;0)}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#3
Du bist ein Held! Ernsthaft.

Vielen lieben Dank für die schnelle Antwort!
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Grafik leere Spalten ignorieren meike 2 258 13.07.2016, 16:50
Letzter Beitrag: schauan
  Fehler in der Formel ignorieren (DIV/0) [2007/365] die eule 6 541 17.05.2016, 22:39
Letzter Beitrag: shift-del
  Summenprodukt und leere Zellen ignorieren VBA4Beginner 23 3.258 15.09.2015, 16:33
Letzter Beitrag: VBA4Beginner
  bedingte Formatierung Wert ignorieren Joogel 10 2.435 01.07.2015, 12:58
Letzter Beitrag: BoskoBiati

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste