Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


leere zellen im monat nach name
#1
Hallo

Habe ne Tabelle mit 2 Laschen
Änderungen werden in der Meldungen gemacht und in der Auswertung die Berechnung.

Inhalt Meldung
Spalten
Name und Tage
Name = Vor und Nachname
Tage = Leer oder Buchstabe

Inhalt Auswertung
Spalten
Namen und Monat
Name = Vor und Nachname (nicht alle aus der Meldung)
Monat = anzahl der Leerzellen im Monat abhängig vom Namen...

wie bekomme ich das hin?

Danke

.xlsx   TEST.xlsx (Größe: 92,01 KB / Downloads: 8)
to top
#2
Hi,

als erstes mal eine blöde Frage: wieso füllst du alle Spalten bereits mit Daten? Ich denke nicht, dass die Tabelle bereits bis ins Jahr 2059 reichen soll.

Dann würde ich hier mit Hilfsspalten arbeiten, die du einfach ausblendest.

1. In der Tabelle "Meldung" direkt hinter deiner Namensspalte den Namen und Vornamen zusammenschreiben. Formel:

Code:
=C3&D3

und runterziehen bzw. Doppelklick am Ausfüllkästchen.

2. Nach jedem Monat eine Hilfsspalte, in der du die leeren Zellen zählst. Formel:

Code:
=ANZAHLLEEREZELLEN(BX3:CT3)

ebenfalls soweit runterziehen wie nötig.

3. In dieser Spalte in Zeile 1 die Formel

Code:
=SPALTE()-4

Diese dient lediglich dazu, dass du für den später folgenden SVERWEIS den Spaltenindex hast.

Nun im Tabellenblatt "Auswertung" ebenfalls nach der Namensspalte eine Hilfsspalte mit zusamengefügten Vor- und Nachnamen einfügen und die Spalte ausblenden. In den Monatspalten gibst du dann die Formel

Code:
=SVERWEIS(D7;Meldung!E3:CU8;Meldung!$CU$1)

ein.

Den Spaltenindex musst du natürlich für jeden Monat anpassen. Im Anhang findest du eine Testmappe für Dezember



.xlsx   delenn-Testmappe.xlsx (Größe: 348,43 KB / Downloads: 4)
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Photo Makro zum Kopieren bis eine leere Zeile kommt ambropete 0 26 06.12.2016, 12:45
Letzter Beitrag: ambropete
  Leere Auswahlzellen in Datenüberprüfung soky001 5 65 02.12.2016, 23:45
Letzter Beitrag: soky001
  Überprüfung von Zellen nach Buchstaben in unterschiedlicher Reihenfolge Maya14 9 93 02.12.2016, 12:45
Letzter Beitrag: BoskoBiati
  summen wenn leere zelle entdeckt ist evera 7 74 30.11.2016, 15:59
Letzter Beitrag: BoskoBiati
  Leere Zeile nach gleicher Nummernfolge kosmoritz 5 76 10.11.2016, 16:41
Letzter Beitrag: kosmoritz
  Zellen nach ausfüllen dauerhaft schützen bietho 18 601 27.10.2016, 09:42
Letzter Beitrag: headloose
Wink Listen von vorne (nach gewisser Anzahl von Zellen) wiederholen JoJo2807 6 89 26.10.2016, 20:22
Letzter Beitrag: snb
  Summe pro Monat oski 4 99 22.10.2016, 12:51
Letzter Beitrag: Jockel
  Letzte Leere Zelle Auswählen und Wert eintragen (VBA) e2Ki 7 345 14.09.2016, 09:49
Letzter Beitrag: e2Ki
Sad leere Zellen zählen von der letzten Befüllten Zelle aus loga 36 1.247 13.09.2016, 15:39
Letzter Beitrag: schauan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste