Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

leere zellen im monat nach name
#1
Hallo

Habe ne Tabelle mit 2 Laschen
Änderungen werden in der Meldungen gemacht und in der Auswertung die Berechnung.

Inhalt Meldung
Spalten
Name und Tage
Name = Vor und Nachname
Tage = Leer oder Buchstabe

Inhalt Auswertung
Spalten
Namen und Monat
Name = Vor und Nachname (nicht alle aus der Meldung)
Monat = anzahl der Leerzellen im Monat abhängig vom Namen...

wie bekomme ich das hin?

Danke

.xlsx   TEST.xlsx (Größe: 92,01 KB / Downloads: 8)
to top
#2
Hi,

als erstes mal eine blöde Frage: wieso füllst du alle Spalten bereits mit Daten? Ich denke nicht, dass die Tabelle bereits bis ins Jahr 2059 reichen soll.

Dann würde ich hier mit Hilfsspalten arbeiten, die du einfach ausblendest.

1. In der Tabelle "Meldung" direkt hinter deiner Namensspalte den Namen und Vornamen zusammenschreiben. Formel:

Code:
=C3&D3

und runterziehen bzw. Doppelklick am Ausfüllkästchen.

2. Nach jedem Monat eine Hilfsspalte, in der du die leeren Zellen zählst. Formel:

Code:
=ANZAHLLEEREZELLEN(BX3:CT3)

ebenfalls soweit runterziehen wie nötig.

3. In dieser Spalte in Zeile 1 die Formel

Code:
=SPALTE()-4

Diese dient lediglich dazu, dass du für den später folgenden SVERWEIS den Spaltenindex hast.

Nun im Tabellenblatt "Auswertung" ebenfalls nach der Namensspalte eine Hilfsspalte mit zusamengefügten Vor- und Nachnamen einfügen und die Spalte ausblenden. In den Monatspalten gibst du dann die Formel

Code:
=SVERWEIS(D7;Meldung!E3:CU8;Meldung!$CU$1)

ein.

Den Spaltenindex musst du natürlich für jeden Monat anpassen. Im Anhang findest du eine Testmappe für Dezember



.xlsx   delenn-Testmappe.xlsx (Größe: 348,43 KB / Downloads: 4)
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  nur Datum im aktuellen Monat zulassen sandormiles 3 54 19.03.2017, 17:10
Letzter Beitrag: sandormiles
  Zellen für Formel nach Kategorien ordnen Askyneedsclouds 10 166 13.03.2017, 19:28
Letzter Beitrag: shift-del
Question Leere Zeilen ausblenden MartinM 5 148 02.03.2017, 16:45
Letzter Beitrag: MartinM
  Mittelwert pro Monat Holger Weber 16 347 28.02.2017, 15:44
Letzter Beitrag: Holger Weber
  Zellen je nach Farbe sperren Ralf1 1 124 17.02.2017, 20:05
Letzter Beitrag: schauan
  Tabelle, nur komplett leere Zeilen löschen iriearis 2 110 13.02.2017, 16:06
Letzter Beitrag: iriearis
  Datumsliste: Wochentage pro Monat jb013 35 851 09.02.2017, 21:57
Letzter Beitrag: shift-del
  Zellen aufwärts nach Merkmal durchsuchen UnionJack 4 140 08.02.2017, 15:47
Letzter Beitrag: Rabe
  Nettoarbeitstage im Monat berechnen freiminute 16 373 07.02.2017, 00:22
Letzter Beitrag: Palomino
  Mittelwert abhängig vom Monat bilden thyslo 7 224 06.02.2017, 17:21
Letzter Beitrag: shift-del

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste