Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Addition bei defekter Waage
#1
Hallo zusammen,

Diese Tabelle addiert ein Gewicht in den Spalten D:I durch die Differenz des Zählerstandes in Spalte C.
Je nachdem welches Maximalgewicht in der Zeile D9:I9 für die jeweilige Spalte vorgegeben ist wird die Charge mit einem X beendet. Bis hier funktioniert die abgehangenen Tabelle tadellos.

ich habe folgendes Problem.
Da eine Waage hin und wieder ausfallen kann, habe ich versucht in der Gelben Spalte das Gewicht zu schätzen, was kein Problem ist, jedoch habe ich das Problem das geschätzte Gewicht in die Spalten D:I funktionstüchtig zu integrieren.

Ich hoffe, ich habe mein Problem verständlich erklärt.
Wenn mir jemand mit einer Formelfunktion helfen kann, wäre ich sehr dankbar.

Ich wünsche allen schöne Festtage!

Vielen Dank.
Gruß,
Ralf





.xlsm   01 Januar Produktzähllist 2015.xlsm (Größe: 673,16 KB / Downloads: 13)
to top
#2
Hallo Ralf,

addiere zu der Differenz von Spalte C einfach den Betrag der zugehörigen Zelle aus Spalte B dazu.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#3
Hallo André,

es funktioniert zwar, nur wird die Maximalmenge in den Zellen D9:I9 (entsprechend der Spalte) nicht abgeglichen.
Es wird also kein X mehr in der entsprechenden Spalte gesetzt wenn die Menge in D9:I9 erreicht ist um zur nächsten Spalte zu springen.

Aber vielen Dank für Deine Hilfe.

Gruß,
Ralf
to top
#4
Hallo Ralf,

auf die Schnelle würde mir da eine Lösung mit Hilfsspalte einfallen, wo Du die Zahlen beider Spalten addierst und kumulierst.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#5
Hallo André,

das mit der Hilfsspalte bzw. Zelle habe ich gerade probiert, so wie ich es mir vorstelle, aber bei mir funktioniert es leider nicht.
Wie würdest Du denn die Hilfsspalte in die Formel einbauen?

Gruß,
Ralf
to top
#6
Hallo Ralf,

im Prinzip so. Die Formel in D10 eingeben und runter ziehen.
Arbeitsblatt mit dem Namen '1'
 BCD
10 30083008
11 30113011
12 30183018
13 30233023
14 30313031
15 30373037
16 30433043
17 30483048
18 30533053
19530533058
20630533064
216 3070
225 3075
235 3080
24 30853085

ZelleFormel
D10=WENN(B10=0;C10;MAX($D$9:D9)+B10)
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#7
Hallo André,

nochmals vielen Dank, aber mein beschriebenes Problem ist nicht verstanden worden.

Ich wollte den Zusatz der Zählerstand Differenz und nicht den Ersatz alles anderen.

VIELEN DANK!

Gruß,
Ralf
to top
#8
Hallo Ralf,

dann ist meine Antwort auch nicht verstanden worden. Dodgy
Du beziehst anschließend Deine Differenzberechnung nicht mehr auf die Spalte C, sondern auf die Hilfsspalte D.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#9
Hallo Ralf,
Ohne Hilfsspalte würde wahrscheinlich auch gehen, wenn Du als Ergebnis das Maximum von Differenz und manuellem Eintrag nimmst. Bin nur gerade am Smartphone und kann es nicht testen.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#10
Hallöchen,

ja, das mit dem max geht auch. Bei der Prüfung der Tonnage muss dann noch die Summe des entsprechenden Bereichs aus Spalte B dazugerechnet werden. Deine Formel in Spalte F funktioniert aber nicht korrekt, oder? Die hört bei 40 nicht auf. Ich habe dazu in Spalte C Zahlen eingetragen bis 3093, = 40 Tonnen und drunter dann noch 3095.

Die Tonnage triffst Du aber immer genau? Ansonsten würde in der betreffenden Spalte D oder E auch kein x eingetragen.

Arbeitsblatt mit dem Namen '1'
 BCD
10330053
11 3011X
12 3018 

ZelleFormel
D10=WENN(C10="";"";WENN(ZÄHLENWENN(D$9:D9;"X");"";WENN(C9-$C$9+SUMME(B$9:B9)=$D$9;"X";MAX($C10-$C9;B10))))
D11=WENN(C11="";"";WENN(ZÄHLENWENN(D$9:D10;"X");"";WENN(C10-$C$9+SUMME(B$9:B10)=$D$9;"X";MAX($C11-$C10;B11))))
D12=WENN(C12="";"";WENN(ZÄHLENWENN(D$9:D11;"X");"";WENN(C11-$C$9+SUMME(B$9:B11)=$D$9;"X";MAX($C12-$C11;B12))))

Zellebedingte Formatierung...Format
D101: Zellwert ist gleich ="X"abc
D111: Zellwert ist gleich ="X"abc
D121: Zellwert ist gleich ="X"abc
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Noch immer Addition Ernst Hart 5 139 17.10.2016, 22:08
Letzter Beitrag: shift-del
  Stringaddition - Addition einer Zahl zu einem String Schülerin 6 615 03.03.2016, 18:11
Letzter Beitrag: snb
  Wenn Text dann Addition mehrerer Zellen Silvan 7 716 09.12.2015, 15:12
Letzter Beitrag: Jockel

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste