Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Bedingte Formatierung mit leeren Zeilen und Spalten
#1
Hallo zusammen

Bei meiner Excel Testerei mit einem Kalender, bin ich auf ein neues Problem gestoßen.

Hier mal eine Auszug aus dem Kalender.

Kalender1

ABCDEFGHIJKLMN
12007
2JanuarFebruar
3Mo. 01Do. 01
4
5Di. 02Fr. 02
6
7Mi. 03Sa. 03
8
Formeln der Tabelle
ZelleFormel
A2=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-1))=SPALTE();DATUM($A$1;SPALTE();ZEILE()-1);"")
H2=H3
A3=DATUM(A1;SPALTE();ZEILE()-2)
H3=DATUM(A1;SPALTE()-6;ZEILE()-2)
A5=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-3))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-3))
H5=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-3))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-3))
A7=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-4))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-4))
H7=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-4))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-4))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Ich möchte wie bei meinen anderen erfolgreichen Versuchen auch hier die Wochenenden farblich unterlegen mit einer bedingten Formatierung.

Ausprobiert habe ich schon einige Formeln wie:

=Wochentag(A3;2;)>5
=Wochentag(A3;2;)>=5
=Wochentag(A3;2)>=6
=Oder(Wochentag($A3;2)=6;Wochentag($A3;2)=7)

und andere.

Leider greift keine der Formatierungen.
Bei einer wurde mir dann das ganze Blatt formatiert.
Was mache ich falsch?
Gruß

Lümmel
to top
#2
Hi, in den Formeln =Wochentag(A3;2;)>5 usw. ist das letzte Semikolon zu viel... ... ich würde so tun...

=(A3<>"")*(WOCHENTAG(A3;2)>5)
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
(17.12.2014, 22:53)Jockel schrieb: Hi, in den Formeln =Wochentag(A3;2Wink>5 usw. ist das letzte Semikolon zu viel... ... ich würde so tun...

=(A3<>"")*(WOCHENTAG(A3;2)>5)

Hallo Jockel

vielen Dank für die schnelle Antwort.

Leider keinerlei Veränderung mit deiner Formel.

Es wird nichts formatiert.
Gruß

Lümmel
to top
#4
Hi,

dann poste doch mal deine Formatierungsformel, denke da ist was falsch definiert.
Mit freundlichen Grüßen  Smile
Michael

Win 7 64 bit / Excel 2007/2016
to top
#5
Hola,

eine Beispieldatei, an der man das Problem nachvollziehen kann, könnte Wunder wirken Smile

Gruß,
steve1da
to top
#6
(17.12.2014, 23:22)Zwergel schrieb: Hi,

dann poste doch mal deine Formatierungsformel, denke da ist was falsch definiert.

Hallo Zwergel

Meine Formeln die ich genommen habe sind oben in meinem Post angegeben.
Gruß

Lümmel
to top
#7
Hallo, bei mir schon...

Arbeitsblatt mit dem Namen 'Kalender1'
 ABCDEFGH
3Mo. 01      Do. 01
4        
5Di. 02      Fr. 02
6        
7Mi. 03      Sa. 03
8        

ZelleFormel
A3=DATUM(A1;SPALTE();ZEILE()-2)
H3=DATUM(A1;SPALTE()-6;ZEILE()-2)
A5=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-3))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-3))
H5=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-3))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-3))
A7=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-4))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-4))
H7=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-4))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-4))

Zellebedingte Formatierung...Format
A31: =(A3<>"")*(WOCHENTAG(A3;2)>5)abc
B31: =(B3<>"")*(WOCHENTAG(B3;2)>5)abc
C31: =(C3<>"")*(WOCHENTAG(C3;2)>5)abc
D31: =(D3<>"")*(WOCHENTAG(D3;2)>5)abc
E31: =(E3<>"")*(WOCHENTAG(E3;2)>5)abc
F31: =(F3<>"")*(WOCHENTAG(F3;2)>5)abc
G31: =(G3<>"")*(WOCHENTAG(G3;2)>5)abc
H31: =(H3<>"")*(WOCHENTAG(H3;2)>5)abc
A41: =(A4<>"")*(WOCHENTAG(A4;2)>5)abc
B41: =(B4<>"")*(WOCHENTAG(B4;2)>5)abc
C41: =(C4<>"")*(WOCHENTAG(C4;2)>5)abc
D41: =(D4<>"")*(WOCHENTAG(D4;2)>5)abc
E41: =(E4<>"")*(WOCHENTAG(E4;2)>5)abc
F41: =(F4<>"")*(WOCHENTAG(F4;2)>5)abc
G41: =(G4<>"")*(WOCHENTAG(G4;2)>5)abc
H41: =(H4<>"")*(WOCHENTAG(H4;2)>5)abc
A51: =(A5<>"")*(WOCHENTAG(A5;2)>5)abc
B51: =(B5<>"")*(WOCHENTAG(B5;2)>5)abc
C51: =(C5<>"")*(WOCHENTAG(C5;2)>5)abc
D51: =(D5<>"")*(WOCHENTAG(D5;2)>5)abc
E51: =(E5<>"")*(WOCHENTAG(E5;2)>5)abc
F51: =(F5<>"")*(WOCHENTAG(F5;2)>5)abc
G51: =(G5<>"")*(WOCHENTAG(G5;2)>5)abc
H51: =(H5<>"")*(WOCHENTAG(H5;2)>5)abc
A61: =(A6<>"")*(WOCHENTAG(A6;2)>5)abc
B61: =(B6<>"")*(WOCHENTAG(B6;2)>5)abc
C61: =(C6<>"")*(WOCHENTAG(C6;2)>5)abc
D61: =(D6<>"")*(WOCHENTAG(D6;2)>5)abc
E61: =(E6<>"")*(WOCHENTAG(E6;2)>5)abc
F61: =(F6<>"")*(WOCHENTAG(F6;2)>5)abc
G61: =(G6<>"")*(WOCHENTAG(G6;2)>5)abc
H61: =(H6<>"")*(WOCHENTAG(H6;2)>5)abc
A71: =(A7<>"")*(WOCHENTAG(A7;2)>5)abc
B71: =(B7<>"")*(WOCHENTAG(B7;2)>5)abc
C71: =(C7<>"")*(WOCHENTAG(C7;2)>5)abc
D71: =(D7<>"")*(WOCHENTAG(D7;2)>5)abc
E71: =(E7<>"")*(WOCHENTAG(E7;2)>5)abc
F71: =(F7<>"")*(WOCHENTAG(F7;2)>5)abc
G71: =(G7<>"")*(WOCHENTAG(G7;2)>5)abc
H71: =(H7<>"")*(WOCHENTAG(H7;2)>5)abc
A81: =(A8<>"")*(WOCHENTAG(A8;2)>5)abc
B81: =(B8<>"")*(WOCHENTAG(B8;2)>5)abc
C81: =(C8<>"")*(WOCHENTAG(C8;2)>5)abc
D81: =(D8<>"")*(WOCHENTAG(D8;2)>5)abc
E81: =(E8<>"")*(WOCHENTAG(E8;2)>5)abc
F81: =(F8<>"")*(WOCHENTAG(F8;2)>5)abc
G81: =(G8<>"")*(WOCHENTAG(G8;2)>5)abc
H81: =(H8<>"")*(WOCHENTAG(H8;2)>5)abc
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#8
Hier mal die Datei


Angehängte Dateien
.xlsx   Kalender1.xlsx (Größe: 35,61 KB / Downloads: 4)
Gruß

Lümmel
to top
#9
Hallo, du musst schon den ganzen Bereich markieren...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#10
Hi,

(17.12.2014, 23:24)Lümmel schrieb: Meine Formeln die ich genommen habe sind oben in meinem Post angegeben.

wieso? Geht doch:

Kalender1
ABCDEFGHIJKLMN
12007
23908339114
3Mo, 01.01.Do, 01.02.
4
5Di, 02.01.Fr, 02.02.
6
7Mi, 03.01.Sa, 03.02.
8
9Do, 04.01.So, 04.02.
10
11Fr, 05.01.Mo, 05.02.
12
13Sa, 06.01.Di, 06.02.
14
15So, 07.01.Mi, 07.02.
16
Bedingte Formatierung Fülleffekte, Symbole, Farbskalen
werden in dieser Tabelle nicht dargestellt

 verbundene Zellen
A2:G2
H2:N2

verwendete Formeln
Zelle Formel Bereich N/A
A2=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-1))=SPALTE();DATUM($A$1;SPALTE();ZEILE()-1);"")
H2=H3
A3=DATUM(A1;SPALTE();ZEILE()-2)
H3=DATUM(A1;SPALTE()-6;ZEILE()-2)
A5=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-3))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-3))
H5=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-3))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-3))
A7=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-4))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-4))
H7=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-4))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-4))
A9=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-5))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-5))
H9=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-5))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-5))
A11=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-6))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-6))
H11=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-6))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-6))
A13=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-7))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-7))
H13=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-7))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-7))
A15=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-8))=MONAT(A$2);DATUM($A$1;SPALTE();ZEILE()-8))
H15=WENN(MONAT(DATUM($A$1;SPALTE()-6;ZEILE()-8))=MONAT(H$2);DATUM($A$1;SPALTE()-6;ZEILE()-8))

Bedingte Formatierung Haupttabelle 1
Zelle   Nr. Bed.  Regeltyp  Operator   Formel1   Formel2   Format Schrift Füllfarbe   Unterstrichen   Schrift- farbe Muster   Musterfarbe Typ Bereich
$A$11:$A$1201.Bed.: Formel ist=(A11<>"")*(WOCHENTAG(A11;2)>5)5296274       2A11:A12
$A$13:$A$1401.Bed.: Formel ist=(A13<>"")*(WOCHENTAG(A13;2)>5)5296274       2A13:A14
$A$15:$A$1601.Bed.: Formel ist=(A15<>"")*(WOCHENTAG(A15;2)>5)5296274       2A15:A16
$A$3:$A$801.Bed.: Formel ist=(A3<>"")*(WOCHENTAG(A3;2)>5)5296274       2A3:A8
$A$9:$A$1001.Bed.: Formel ist=(A9<>"")*(WOCHENTAG(A9;2)>5)5296274       2A9:A10
$H$3:$H$1601.Bed.: Formel ist=(H3<>"")*(WOCHENTAG(H3;2)>5)5296274       2H3:H16

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Bedingte Formatierung - Telefonnummer promenade 1 65 02.12.2016, 19:53
Letzter Beitrag: WillWissen
  Bedingte Formatierung offen / erledigt cuba 9 69 02.12.2016, 14:40
Letzter Beitrag: cuba
  bedingte Formatierung: wenn Zellwert>anderer Zellwert Stefan Link 6 70 02.12.2016, 07:23
Letzter Beitrag: BoskoBiati
Shocked Bedingte Formatierung funktioniert nicht Osccon 6 78 01.12.2016, 21:21
Letzter Beitrag: WillWissen
  Bestellung/Spalten: nur bestimmte Spalten kopieren teufelchenbs 14 300 25.11.2016, 20:55
Letzter Beitrag: schauan
  Spalten in Zeilen umwanden mit gleicher Überschrift fabian1994 2 68 23.11.2016, 17:50
Letzter Beitrag: schauan
  Bedingte Formatierung zum hervorheben ob Termine eingehalten werden Annette 1 72 20.11.2016, 14:59
Letzter Beitrag: BoskoBiati
  Datumsüberprüfung/Bedingte Formatierung keineahnungvonnix 2 56 17.11.2016, 10:34
Letzter Beitrag: keineahnungvonnix
  Bedingte Formatierung: Wert zwischen zwei Datumsfelder anzeigen Sunny2000N 2 51 15.11.2016, 16:06
Letzter Beitrag: Sunny2000N
  Bedingte Formatierung mit 3 Bedingungen Wulfgar 4 60 10.11.2016, 12:44
Letzter Beitrag: Wulfgar

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste