Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Frage rechnen mit Zeiten
#1
Guten morgen zusammen,

ich sitze derzeit an einer kleiner Tabelle zur Berechnung der Arbeitszeit dran und wollte zum Schluss meine Gleitzeit ausrechnen lassen. Erst für jeden Tag und dann Gesamt.
Das mit der Gleitzeit für jeden Tag klappt inzwsichen, hier habe ich mich an den folgenden Link gehalten und das Problem bei Gesamt ist natürlich das man mit Text versucht zu rechnen, was logischerweise nicht geht. http://www.excelformeln.de/formeln.html?welcher=240
Für Gesamt habe ich erstmal eine Übergangslösung, da ich eigentlich nie im negativen Bereich bin, aber trotzdem möchte ich für den Fall der Fälle dass das trotzdem funktioniert.
Die Uhrzeiten in der unteren Tabelle sind für Testzwecke ausgedacht und stimmen so natürlich nicht. ^^


Tabelle1
ABCDEF
21MontagDienstagMittwochDonnerstagFreitag
22Start8:008:008:008:008:00
23Ende16:1116:5516:4517:1517:25
24Arbeitszeit8:458:458:458:458:45
25Gleitzeit'-00:340:100:000:300:40
26Gesamt:0:46

verwendete Formeln
Zelle Formel Bereich N/A
B25:F25=WENN(B23-(B22+B24)<0;TEXT((B22+B24)-B23;"-[hh]:mm");B23-(B22+B24))
B26=(B23-(B22+B24)+C23-(C22+C24)+D23-(D22+D24)+E23-(E22+E24)+F23-(F22+F24))
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit



Ich hoffe mir kann jemand weiterhelfen und bedanke mich schonmal im voraus für Eure Antworten. Big Grin
to top
#2
Hi,

wenn ich Deine Frage richtig interpretiere, möchtest Du die Formel in B26 vereinfachen?

Ich würde hier mit einer Hilfszeile (im Beispiel Zeile 26) arbeiten, die Du ja ausblenden kannst ...

 ABCDEF
21 MontagDienstagMittwochDonnerstagFreitag
22Start08:0008:0008:0008:0008:00
23Ende16:1116:5516:4517:1517:25
24Arbeitszeit08:4508:4508:4508:4508:45
25Gleitzeit-00:3400:1000:0000:3000:40
26 ##########00:1000:0000:3000:40
27Gesamt:00:46    

ZelleFormel
B25=WENN(B23-(B22+B24)<0;TEXT((B22+B24)-B23;"-[hh]:mm");B23-(B22+B24))
C25=WENN(C23-(C22+C24)<0;TEXT((C22+C24)-C23;"-[hh]:mm");C23-(C22+C24))
D25=WENN(D23-(D22+D24)<0;TEXT((D22+D24)-D23;"-[hh]:mm");D23-(D22+D24))
E25=WENN(E23-(E22+E24)<0;TEXT((E22+E24)-E23;"-[hh]:mm");E23-(E22+E24))
F25=WENN(F23-(F22+F24)<0;TEXT((F22+F24)-F23;"-[hh]:mm");F23-(F22+F24))
B26=B23-B22-B24
C26=C23-C22-C24
D26=D23-D22-D24
E26=E23-E22-E24
F26=F23-F22-F24
B27=SUMME(B26:F26)
to top
#3
Hi,

danke für die Antwort. Stimmt ich habe mich da ein bisschen blöd ausgedrückt. ^^
Ich habe dein Vorschlag mal ausprobiert und danach für Montag anstatt 8Uhr 10Uhr eingetragen und das Problem ist, das im negativen Bereich lauter Rauten angezeigt werden, wenn ich eine einfache SUMME-Funktion benutze.
Kann ich das irgendwie, wie mit der WENN-Funktion von B25 bis F25 regeln? Hab das nämlich mal probiert aber dann steht da nur #WERT!, aber denk mal das bei mir ein Denkfehler drin ist. Habe den Befehl dann eingetragen =WENN(SUMME(B26:F26)<0;TEXT(SUMME(B26:F26);"-[hh]:mm");SUMME(B26:F26)) und für mich logisch würde er jetzt alle Zahlen, wie in deiner angegebenen Tabelle, zusammenfassen.
to top
#4
Hallo,

ich würde es so machen:

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDEFG
1 MontagDienstagMittwochDonnerstagFreitag
2Start08:0008:0008:0008:0008:00
3Ende16:1116:5516:4517:1517:25
4Arbeitszeit08:4508:4508:4508:4508:45
5Gleitzeit-00:34+00:10+00:00+00:30+00:40
6Gesamt:+00:46    

ZelleFormel
C5=WENN(REST(C3-C2;1)<C4;"-";"+")&TEXT(ABS(REST(C3-C2;1)-C4);"hh:mm")
C6=WENN(SUMMENPRODUKT((C3:G3-C2:G2)-(C4:G4))<0;"-";"+")&TEXT(ABS(SUMMENPRODUKT((C3:G3-C2:G2)-(C4:G4)));"hh:mm")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
Cpt. Obvious
to top
#5
Ah vielen dank, nu klappt alles.
Vielen vielen dank für die Hilfe Big Grin
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Tabelle mit mehreren Variablen rechnen fuzzy 10 104 Vor 4 Stunden
Letzter Beitrag: fuzzy
  Rechnen mit hh:mm:ss,000 punktum 11 118 Vor 5 Stunden
Letzter Beitrag: schauan
  Kombination aus Rechnen mit Zeitangaben + bedingter Formatierung 1Selection 4 108 19.02.2017, 22:45
Letzter Beitrag: 1Selection
  Prozent rechnen tommy10_13 5 111 09.02.2017, 17:04
Letzter Beitrag: Palomino
  Rechnen in VBA Mario 2 104 08.02.2017, 19:56
Letzter Beitrag: Mario
  Zeiten Trennen in Verschiedene Spalten AKGUSTI 2 84 01.02.2017, 19:41
Letzter Beitrag: AKGUSTI
  Mit Hintergrundfarbe rechnen merlin-rainbow 2 89 20.01.2017, 12:12
Letzter Beitrag: schauan
  zusammen rechnen Harald 13 267 03.01.2017, 09:55
Letzter Beitrag: lupo1
  Mitarbeiter Zeiten MaMe 5 186 07.12.2016, 18:14
Letzter Beitrag: MaMe
  Mit Zeit rechnen fhares 4 147 07.11.2016, 16:37
Letzter Beitrag: Jockel

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste