SVerweis plus nächste Zeile
#1
Hallo zusammen,

irgendwie seh ich den Wald vor lauter Bäumen nicht.


Depot
ABCDE
2IndizesAktienwertBrancheKürzelWKN / ISIN
3MDaxAareal BankFinanzsektorARL.DEDE0005408116
4MDaxFinanzsektorARL.DEDE0005408116#BEZUG!

verwendete Formeln
Zelle Formel Bereich N/A
A4=WENN(A3="Dow Jones";"Dow Jones";WENN(A3="Dax";"Dax";WENN(A3="TecDax";"TecDax";WENN(A3="Mdax";"MDax";""))))
B3:B4=SVERWEIS($A$3;Kürzel!$A:$E;ZEILE(B2);0)
C3:C4=SVERWEIS($A3;Kürzel!$A:$E;ZEILE(C3);0)
D3: D4=SVERWEIS($A3;Kürzel!$A:$E;ZEILE(D4);0)
E3:E4=SVERWEIS($A3;Kürzel!$A:$E;ZEILE(E5);0)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit


Eigentlich dachte ich, dass wenn ich die Zeile ansteuere, die beim runterkopieren der Formel die Zeile plus 1 erhöht wird. In meiner Tabelle verrutscht das Ergebnis.

Wo mache ich den Fehler?
Grüße aus Bremen
Bernie

"Wenn du jemanden triffst ohne lächeln, schenke ihm deins !!!"

MS Office 2016 Pro  32bit - Win 10 Pro 64 bit
Haftungshinweis: Trotz sorgfältiger inhaltlicher Kontrolle übernehmen ich keine Haftung für die Inhalte externer Links. Für den Inhalt der verlinkten Seiten sind ausschließlich deren Betreiber verantwortlich.
to top
#2
Hallo,

was willst Du erreichen? Mit Deiner Formel wandert der SVERWEIS pro Zeile nach unten immer um eine Spalte nach rechts

C3 entspricht =SVERWEIS($A3;Kürzel!$A:$E;3;0)
C4 ist aber =SVERWEIS($A3;Kürzel!$A:$E;4;0)

Für A4 reicht auch das: =A3
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#3
Hallo Bernie,

Du möchtest sicher so etwas:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDE
1IndizesAktienwertBrancheKürzelWKN / ISIN
2MDax0000

ZelleFormel
B2=SVERWEIS($A$3;Kürzel!$A:$E;SPALTE();0)
C2=SVERWEIS($A$3;Kürzel!$A:$E;SPALTE();0)
D2=SVERWEIS($A$3;Kürzel!$A:$E;SPALTE();0)
E2=SVERWEIS($A$3;Kürzel!$A:$E;SPALTE();0)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Du hast in Der Matrix 5 Spalten. Da Zeile(B2) aber mit jeder weiteren Ziele um eins erhöht wird,
hast Du in Zelle E4 diese Formel stehen:
=SVERWEIS($A3;Kürzel!$A:$E;ZEILE(E6);0)

ZEILE(E6) = 6

Deine Formel sucht dann in Spalte 6. Da es diese nicht gibt, kommt es zum Bezug Fehler.
Dann kommt noch hinzu, das was Edgar schreibt, Du verrutschst in den Spalten.
Gruß Atilla
to top
#4
Hallo Edgar,

Zitat:Für A4 reicht auch das: =A3

das wollte ich auch schreiben, aber es könnten ja noch andere Werte als die Aufgeführten auftauchen,
dann würde ich so etwas nehmen:

=WENN(ODER(A3="Dow Jones";A3="Dax";A3="TecDax";A3="Mdax");A3;"")
Gruß Atilla
to top
#5
Hallo Atilla,

ich fürchte, das wird hier mit SVERWEIS nicht funktionieren, da immer nur die erste Zeile gefunden wird. Wenn, wie es aussieht, eine Auflistung aller Zeilen mit Dax etc. erfolgen soll, dann hilft evtl ein Filter, VBA oder eine Sammlung von, im schlimmsten Fall, Matrixformeln.

Ich würde folgende Formel verwenden:

Code:
=index(B:B;vergleich($A3;Kürzel!$A:$A;0)+Zeile($a1)-1)

Die dann nach rechts und unten ziehen!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#6
Hallo Ihr Beiden,

Danke für die schnelle Hilfe.

@Atilla

Ich glaube, dass ich deine Erklärung ...
Zitat:Du hast in Der Matrix 5 Spalten. Da Zeile(B2) aber mit jeder weiteren Ziele um eins erhöht wird,
hast Du in Zelle E4 diese Formel stehen:
=SVERWEIS($A3;Kürzel!$A:$E;ZEILE(E6);0)
... verstanden habe. Wo ich noch Problem habe ist, wenn ich deine Formel waagerecht auf Spalte 5 ziehe passt alles, wenn ich sie senkrecht ziehe passiert das, alles die selben Werte ...
Depot
ABCDE
2IndizesAktienwertBrancheKürzelWKN / ISIN
3Dow Jones3M CompanyKonsumgüterMMMUS88579Y1010
4Dow Jones3M CompanyKonsumgüterMMMUS88579Y1010
5Dow Jones3M CompanyKonsumgüterMMMUS88579Y1010

verwendete Formeln
Zelle Formel Bereich N/A
A4:A5=WENN(ODER(A3="Dow Jones";A3="Dax";A3="TecDax";A3="Mdax");A3;"")
B3:E5=SVERWEIS($A$3;Kürzel!$A:$E;SPALTE();0)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit



D.h. in Zelle B4 sollte der nächste Wert der Tabelle Kürzel erscheinen. Wo muss ich den Code ändern???
Grüße aus Bremen
Bernie

"Wenn du jemanden triffst ohne lächeln, schenke ihm deins !!!"

MS Office 2016 Pro  32bit - Win 10 Pro 64 bit
Haftungshinweis: Trotz sorgfältiger inhaltlicher Kontrolle übernehmen ich keine Haftung für die Inhalte externer Links. Für den Inhalt der verlinkten Seiten sind ausschließlich deren Betreiber verantwortlich.
to top
#7
Hallo Edgar,

deine Formel liefert mir wieder die Überschriften der Tabelle Depot und wenn ich sie runterziehe bleibt es gleich ...
Depot
ABCDE
2IndizesAktienwertBrancheKürzelWKN / ISIN
3Dow JonesAktienwertBrancheKürzelWKN / ISIN
4Dow JonesAktienwertBrancheKürzelWKN / ISIN
5Dow JonesAktienwertBrancheKürzelWKN / ISIN

verwendete Formeln
Zelle Formel Bereich N/A
A4:A5=WENN(ODER(A3="Dow Jones";A3="Dax";A3="TecDax";A3="Mdax");A3;"")
B3:E5=INDEX(B:B;VERGLEICH($A3;Kürzel!$A:$A;0)+ZEILE($A1)-1)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Grüße aus Bremen
Bernie

"Wenn du jemanden triffst ohne lächeln, schenke ihm deins !!!"

MS Office 2016 Pro  32bit - Win 10 Pro 64 bit
Haftungshinweis: Trotz sorgfältiger inhaltlicher Kontrolle übernehmen ich keine Haftung für die Inhalte externer Links. Für den Inhalt der verlinkten Seiten sind ausschließlich deren Betreiber verantwortlich.
to top
#8
Hallo,

genau das habe ich vermutet. Dann passt ja meine Formel.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Bernie
to top
#9
Hallo Bernie,

ich habe mich mehr auf die Funktionalität von SVERWEIS() versteift, deshalb habe ich nicht wirklich bemerkt, was Du ereichen möchtest.

Aber Edgar hat Dir ja jetz etwas passendes gezeigt. SVERWEIS() geht für Dein Vorhaben auf jeden Fall nicht.

Sonst wie Edgar schon bemerkt hat, bei vielen Daten, käme vielleicht VBA in Frage.
Gruß Atilla
to top
#10
Hallo Bernie,

Edgars Formel muss so aussehen:

=INDEX(Kürzel!B:B;VERGLEICH($A3;Kürzel!$A:$A;0)+ZEILE($A1)-1)
Gruß Atilla
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste