Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Verknüpfung in aus anderer Arbeitsmappe
#1
Guten Morgen,

ich versuche eine Finanzplanung zu erstellen. Zu diesem Zweck sollen mehrere Arbeitsmappen für die unterschiedlichen Abteilungen erstellt werden. Diese sollen dann später in einem einzelen Dashboard zusammengefasst werden.

In den Quellarbeitsmappen möchte ich gerne mit Tabellen arbeiten, welche als 'Tabellenbereiche' formatiert sind, da so vorab einige Berechnungen automatisch durchgeführte werden (aus einem Datum wird autamatisch die Kalenderwoche ermittelt, welche später als Auswertungsstufe dienen soll.)

In der Quelldatei gibt der Einkaufsleiter also die getätigten Bestellungen ein und verzeichnet das Zahlungsziel, wann der dazugehörige Wechsel eingelöst wird - hieraus leitet sich die KW ab, unter der dann diese Ausgabe absummiert werden soll. Die Tabelle, in der diese Eingabe erfolgt, hat den Namen 'Wechsel'.

Im Dashboard versuche ich nun, mit folgender Formel, auf diese Inhalte zuzugreifen:

=SUMMEWENNS('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[RG-Betrag]];'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[Status]];"Offen";'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[Währung]];$B$6;'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[KW]];C4)

Es sollen also alle Beträge der Spalte RG-Betrag zusammenaddiert werden, in denen der Status= Offen und die KW= dem Inhalt C4 entspricht.

Sind beide (Quelle und Dashboard) offen, funktioniert das auch problemlos. Sind aber beide geschlossen, und man öffnet nur das Dasboard und läßt die Tabelle entsprechend der Aufforderung aktualisieren, erhalte ich eine Fehlermeldung #BEZUG!.

Warum?

Viele Grüße

Oliver Pohl
to top
#2
Hallo Oliver,

da schon Summewenn nicht bei geschlossenen Mappen funktioniert hat, wird das wohl auch für Summewenns gelten.
Abhilfe war eine Matrix zu erzeugen .. .siehe http://support.microsoft.com/kb/507757/de
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 ?mage

to top
#3
Das war mir nicht bewußt.... Ich werde mir den Artikel aus der KB mal anschauen.
Bei Rückfragen komme ich nochmal durch....

Danke bis hierhin

Oliver
to top
#4
Hallo

{=SUMME(WENN('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[Status]]="Offen";WENN('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[Währung]]="USD";WENN('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[KW]]=C$4;'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[RG-Betrag]];0))))}

Das als Matrixformel hat nicht geklapt :-(
to top
#5
Hallo,

ich habe es bei mir auch getestet, und es klappt hier auch nicht, wenn die Bezüge auf ein "Tabellenbereich" verweisen.

Wenn ich aber Zellbezüge nehme, dann klappt es.

Es sieht so aus, das ein als Tabelle formatierter Bereich nicht erkannt wird, wenn die Datei geschlossen ist.
Gruß Atilla

Excel 2007
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Excel Arbeitsmappe per Makro als .pdf Datei davincy81 4 81 09.12.2016, 13:13
Letzter Beitrag: Rabe
Question CheckBox in freigegebener Arbeitsmappe vici 3 73 22.11.2016, 20:06
Letzter Beitrag: shift-del
  Durchsuchen einer gesamten Arbeitsmappe schadre 11 220 14.11.2016, 08:33
Letzter Beitrag: Kuwer
  WENN ODER Verknüpfung über mehrere Bedingungen? wies1617 8 167 11.11.2016, 17:22
Letzter Beitrag: schauan
  Hyperlink Text aus anderer Worksheet Spike87 4 59 11.11.2016, 12:39
Letzter Beitrag: snb
  Daten aus anderer Datei KarlimannIII 21 397 04.11.2016, 16:14
Letzter Beitrag: KarlimannIII
  Verknüpfung mehrerer Tabellen APfeiffer 12 211 27.10.2016, 13:28
Letzter Beitrag: APfeiffer
Smile Verknüpfung mehrerer Tabellen APfeiffer 11 209 25.10.2016, 09:33
Letzter Beitrag: APfeiffer
  Verknüpfung funktioniert nicht mehr (Nach Neu-Installation) Thomas der Xte 5 87 24.10.2016, 10:33
Letzter Beitrag: neopa
  Externer Bezug bei geschlossener Arbeitsmappe DocMarley 14 188 22.10.2016, 12:55
Letzter Beitrag: Peter

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste