Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Verknüpfung in aus anderer Arbeitsmappe
#1
Guten Morgen,

ich versuche eine Finanzplanung zu erstellen. Zu diesem Zweck sollen mehrere Arbeitsmappen für die unterschiedlichen Abteilungen erstellt werden. Diese sollen dann später in einem einzelen Dashboard zusammengefasst werden.

In den Quellarbeitsmappen möchte ich gerne mit Tabellen arbeiten, welche als 'Tabellenbereiche' formatiert sind, da so vorab einige Berechnungen automatisch durchgeführte werden (aus einem Datum wird autamatisch die Kalenderwoche ermittelt, welche später als Auswertungsstufe dienen soll.)

In der Quelldatei gibt der Einkaufsleiter also die getätigten Bestellungen ein und verzeichnet das Zahlungsziel, wann der dazugehörige Wechsel eingelöst wird - hieraus leitet sich die KW ab, unter der dann diese Ausgabe absummiert werden soll. Die Tabelle, in der diese Eingabe erfolgt, hat den Namen 'Wechsel'.

Im Dashboard versuche ich nun, mit folgender Formel, auf diese Inhalte zuzugreifen:

=SUMMEWENNS('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[RG-Betrag]];'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[Status]];"Offen";'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[Währung]];$B$6;'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[KW]];C4)

Es sollen also alle Beträge der Spalte RG-Betrag zusammenaddiert werden, in denen der Status= Offen und die KW= dem Inhalt C4 entspricht.

Sind beide (Quelle und Dashboard) offen, funktioniert das auch problemlos. Sind aber beide geschlossen, und man öffnet nur das Dasboard und läßt die Tabelle entsprechend der Aufforderung aktualisieren, erhalte ich eine Fehlermeldung #BEZUG!.

Warum?

Viele Grüße

Oliver Pohl
to top
#2
Hallo Oliver,

da schon Summewenn nicht bei geschlossenen Mappen funktioniert hat, wird das wohl auch für Summewenns gelten.
Abhilfe war eine Matrix zu erzeugen .. .siehe http://support.microsoft.com/kb/507757/de
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 ?mage

to top
#3
Das war mir nicht bewußt.... Ich werde mir den Artikel aus der KB mal anschauen.
Bei Rückfragen komme ich nochmal durch....

Danke bis hierhin

Oliver
to top
#4
Hallo

{=SUMME(WENN('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[Status]]="Offen";WENN('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[Währung]]="USD";WENN('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[KW]]=C$4;'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[RG-Betrag]];0))))}

Das als Matrixformel hat nicht geklapt :-(
to top
#5
Hallo,

ich habe es bei mir auch getestet, und es klappt hier auch nicht, wenn die Bezüge auf ein "Tabellenbereich" verweisen.

Wenn ich aber Zellbezüge nehme, dann klappt es.

Es sieht so aus, das ein als Tabelle formatierter Bereich nicht erkannt wird, wenn die Datei geschlossen ist.
Gruß Atilla


...und ich gelobe Besserung...

to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  wert aus anderer tabelle auslesen Rjinxil 6 67 22.03.2017, 14:43
Letzter Beitrag: Rjinxil
Sad Dropdownliste mit Verknüpfung Gutzuwissen 1 29 21.03.2017, 15:09
Letzter Beitrag: steve1da
  Fehlermeldung - Verknüpfung kann nicht aktualisiert werden. Tuempeltaucher 2 39 21.03.2017, 08:28
Letzter Beitrag: WillWissen
  Oder Verknüpfung bei "If Not Intersect" möglich? o0Julia0o 2 52 16.03.2017, 17:41
Letzter Beitrag: Crazy Tom
  Die Verknüpfung zu einer externen Excel-Dateigeht verloren Michael999 3 84 14.03.2017, 19:41
Letzter Beitrag: schauan
  WENN UND ODER Verknüpfung möglich? MarkusZ 9 171 09.03.2017, 08:20
Letzter Beitrag: MarkusZ
  Rückgängig aktueller Arbeitsmappe Lissy_ok 6 134 06.03.2017, 06:43
Letzter Beitrag: RPP63
  Mehrere Inventurlisten einer Arbeitsmappe auf ein Gesamtblatt zusammenfügen Nigges 8 148 28.02.2017, 10:09
Letzter Beitrag: Nigges
Question Zellwert zu Formel in anderer Zelle machen -> 4x4 zu =4x4 o0Julia0o 38 959 23.02.2017, 11:26
Letzter Beitrag: Rabe
Question Wert aus anderer Datei per Feldnamen übernehmen o0Julia0o 12 240 16.02.2017, 12:44
Letzter Beitrag: Peter

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste