Excel, SVerweis + Liste + Wenn
#1
Soo, ich weiß nicht wie viel euch der Titel verrät, aber es ist glaube ich etwas Kompliziert =D:

Und zwaaaaaar....:

Ich möchte aus einer Kundenliste die Nachnamen in eine Zelle schreiben, so dass der Vorname Automatisch ausgefüllt wird.
Das ist bisher ja noch gut umzusetzen mit ner einfach sverweis Funktion...
Mein jetziges Problem ist, wenn der Nachname öfters als ein mal auftaucht was bei vielen Namen ja nicht unüblich ist da es ja viele viele Maiers etc gibt, soll entweder eine Liste angezeigt werden, mit allen Vornamen die auch den Nachnamen entahlten.
Oder eben das dann automatisch wenn z.B. 5 Leute den gleichen Nachnamen haben, dass dann 5 Zellen ausgefüllt werden mit den verfügbaren Vornamen.

Leider leider habe ich keine Ahnung wie ich das verwirklichen soll....
Deswegen hoffe ich auf eure Hilfe =)

Um alles etwa verständlicher zu machen, hier ein kleines Beispiel:
Namen:
Andreas Maier
Peter Maier
Wolfgang Maier
Ich gebe in Zelle A1 Maier ein
In Zelle B1 soll jetzt entweder in einer Auswahliste Wolfgang, Peter und Andreas stehen,
oder in den Zellen B1-B3 Wolfgang, Peter und Andreas.

Ich hoffe das es irhengwie möglich ist.

Vielen Dank schon mal!!!!!

Mfg: iLegal
to top
#2
Hola,

dann schau mal hier:

http://www.excelformeln.de/formeln.html?welcher=28

Bei vielen Datensätzen empfiehlt sich:

http://www.excelformeln.de/formeln.html?welcher=224

Gruß,
steve1da
to top
#3
Das ist aber nicht genau das was ich suche fürchte ich, ich möchte ja, wenn in der ersten Zeile Fischer steht, das in der 2. Zeile in einer DropDown liste die Vornamen von allen Fischern aus der Kompletten Liste angezeigt werden, genauso wenn ich Maier schreibe nur die Vornamen von Maiers.....
to top
#4
Hola,

dann lass dir mit den Formeln die Vornamen von allen Fischers in einer Hilfsspalte ausgeben. Das Dropdown beziehst du dann auf diese Liste.

Gruß,
steve1da
to top
#5
Ich komm mit dem Link nicht klar e.e
Mensch mensch mensch ist das alles Kompliziert...
Vor allem, weiß ich nichtmal ob mann KKLEINSTE etc. auch bei Buchstaben verwenden kann :c
to top
#6
Hola,

kann man, im Link wird ja auch nach X gesucht.

Versuch es doch mal nach zu bauen, in A1 bis Axy die Nachnamen, in B1 bis Bxy die Vornamen und in E1 den gesuchten Nachnamen.

Code:
{=WENNFEHLER(INDEX(B:B;KKLEINSTE(WENN(A$1:A$99=$E$1;ZEILE($1:$99));ZEILE(A1)));"")}

Diese Formel nach unten ziehen.

Achtung: die {} nicht mit eingeben, sondern die Formel mit Strg-Shift Enter abschließen.

Gruß,
steve1da
to top
#7
Dein Code verwirrt mich jetzt richtig
to top
#8
Hola,

schade dass du es nicht wenigstens versucht hast (das schließe ich jetzt einfach mal daraus).

Viel Glück noch!

Gruß,
steve1da
to top
#9
Wenn du wüsstest was ich versucht habe, natürlich ahbe ich versucht dein Link und deine Formel umzusetzen, aber es hat eben nicht hingehauen
to top
#10
Hola,

mit "es hat nicht hingehauen" kann hier niemand etwas anfangen.

Wo stehen deine Namen, wo deine Vornamen? Wo sollen die Daten erscheinen?

Gruß,
steve1da
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste