Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


In Abhängigkeit von Zellwerten die Formatierung einer Zelle Bestimmen
#1
Hallo,
ich habe die tolle Aufgabe einen Dienstplan zu entwerfen. Der Plan sollte in Abhängigkeit der an einem bestimmten Tag anwesenden Mitarbeiter und unter Beachtung des Wochentages die Formatierung in einem Summenfeld ändern.

Zur Erklärung:

In der vordersten Spalte stehen die Namen der MA untereinander.
In der Obersten Zeile steht der Wochentag Also Mo, Di, MI usw, Darunter das Datum, jedoch nur der Tag als Zahl
Direkt darunter in einer Zeile die Dienste, also Frühdienst, Spätdienst, Nachtidenst
unter den Namen in einer Zeile steht der Summenwert der oben anwesenden MA (wenn ein MA an einem bestimmten Tag da ist, beträgt der Zellwert "1"
So nun soll Excel erkennen, dass ich an einem Spätdienst von Montag bis Sonntag 8 MA benötige, an einem Frühdienst von Montag bis Samstag 7 MA, an einem Frühdienst am Sonntag 6 MA.
Weiterhin ist bei uns der Nachtdienst geteilt in 1. Hälfte und 2. Hälfte. DH. Excel muss erkennen, dass ich die ERste Nachtdiensthälfte unabhängig vom Wochentag 8 MA benötige und von Montag bis Donnerstag und am Sonntag die 2. Hälfte nur 6 MA brauche. Freitag und Samstag brauche ich auch in der 2. Hälfte 8 MA.
Wenn die Werte unterschritten werden sollen sie Rot werden, wenn sie größer oder gleich sind , dann in grüner Formatierung ausgegeben werden.
Ich mach da schon ne Woche dran rum, weiß aber nicht wie das geht-ich habe Probleme mit den verschachtelten Formeln wenn dann und oder, ich blick nix mehr !!!1
to top
#2
Hallo,

die wenigsten User haben Lust eine Tabelle nachzubauen. Es wäre sinnvoller wenn du eine anonymisierte Beispielsdatei hier hochladen würdest:

http://www.clever-excel-forum.de/Thread-...ng-stellen
Gruß
Peter
to top
#3
(15.11.2014, 13:37)Peter schrieb: Hallo,

die wenigsten User haben Lust eine Tabelle nachzubauen. Es wäre sinnvoller wenn du eine anonymisierte Beispielsdatei hier hochladen würdest:

http://www.clever-excel-forum.de/Thread-...ng-stellen

Hallo,

Danke und Sorry, neu hier. anbei eine Beispieltabelle-hoffe das klappt
.xlsx   Dienstplan.xlsx (Größe: 21,83 KB / Downloads: 16)
to top
#4
Hallo bushi,

hier mal ein erster Ansatz. Ich habe unter der Tabelle versucht, die von Dir genannten Bedingungen für die verschiedenen Schichten in Formeln zu packen und die Sollstärke einzeln zu ermitteln. Nur bei der ersten Formel habe ich mal zwei Bedingungen zusammengenommen, weil dafür an jedem Tag 8 das Soll ist.

Man kann nun zwei Wege gehen. Zuerst einmal kann man die Formeln zusammenfassen. Dann kann man überlegen, ob man die Formel direkt in eine bedingte Formatierung eingibt, oder ob man mit der zusammengefassten Formel unter der Tabelle die Sollstärke angibt und in der bedingten Formatierung nur noch die Sollstärke mit der Summe AZ ... vergleicht.

Hier die Formeln, ich habe sie nur in der Spalte D dargestellt, brauchst sie einfach nur nach rechts ziehen ...

Arbeitsblatt mit dem Namen 'Tabelle1'
 DEFG
25  88
266   
27    
28 7  
29    

ZelleFormel
D25=WENN(ODER(D4="N1";D4="S");8;"")
D26=WENN(UND(D4="N2";ODER(D1="Mo";D1="Di";D1="Mi";D1="Do";D1="So"));6;"")
D27=WENN(UND(D4="N2";ODER(D1="Fr";D1="Sa"));8;"")
D28=WENN(UND(D4="F";D1<>"So");7;"")
D29=WENN(UND(D4="F";D1="So");6;"")
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
bushi1971
to top
#5
Hallo schauan,

vielen Dank für die schnelle Beantwortung. Ich hoffe ich bekomm das hin mit dem Zusammenfassen.
Ich meld mich weider.

Grüße
bushi 1971
to top
#6
So schauan,

ich hab das mal unter die Tagelle gemacht. Die Vorgaben sind schon mal erfüllt. Das Problem ich habe nicht nur die A- Schicht, sondern auch noch eine B, C, D, und E-Schicht, die wollte ich darunter im gleichen Schema anfügen. Wie mach ich das jetzt, dass ich die Formeln in die bed. Formatierung packe? Denn so müsste ich ja immer unterhalb der Tabelle die Sollstärkeformen abbilden!

Grüße
bushi1971


Angehängte Dateien Thumbnail(s)
   
to top
#7
Hallo bushi,

du musst dann in der bedingten Formatierung die komplexe Formel um den Vergleich mit der Iststärke erweitern. Also im Prinzip und z.B. in D24 =d24=komplexeformel und als Farbe dann grün. Dann kannst Du das Format mit dem Pinsel in alle beteiligten Zellen übertragen.

Wenn Du den Wert der Sollstärke in der Tabelle ausgibst, würdest Du oder der Anwender gleich selbige sehen und die fehlende Anzahl Mitarbeiter ausrechnen können - was die bedingte Formatierung Dir nicht zeigt.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#8
... ein Zusatz noch. Wenn die Excel-Zellen rot sein sollen, wenn die Sollstärke nicht erreicht ist, dann kannst Du sie auch gleich rot färben und brauchst nur die Bedingung für Grün.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
bushi1971
to top
#9
...ich bin zu doof, sitze auf dem Schlauch, aber ich bekomms nicht hin.... leider
to top
#10
Hallo bushi,

kein Problem. Kannst Du die zusammengefasste Formel mal hier posten?
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Text in einer Zelle automatisch eintragen, abhängig von anderen Zellen Willhelm82 25 264 01.12.2016, 14:24
Letzter Beitrag: Willhelm82
  Zellenausgabe in Abhängigkeit einer anderen Zelle tobisw 6 73 29.11.2016, 13:54
Letzter Beitrag: BoskoBiati
  Berechnungsfelder bestimmen Cirango 2 52 24.11.2016, 11:00
Letzter Beitrag: Cirango
  Zählenwenn in Abhängigkeit von bestimmten Wörtern in einer Zelle Olivenbaum2013 11 165 16.11.2016, 00:36
Letzter Beitrag: Olivenbaum2013
  Ganze Zeile in Abhängigkeit von Formelergebnis per VBA ausblenden AngelJdF 2 65 13.11.2016, 20:45
Letzter Beitrag: AngelJdF
  Bestimmte Zeile aus einer Zelle ausgeben Julian22 7 156 09.11.2016, 09:17
Letzter Beitrag: Julian22
  Suchen und Ersetzen innerhalb einer Zelle Nelson 4 109 04.11.2016, 14:16
Letzter Beitrag: Kuwer
  Bei bedingter Formatierung die Formatierung der Zelle berücksichtigen SGMP 7 125 04.11.2016, 13:50
Letzter Beitrag: SGMP
  Zelle wird nicht eingefärbt trotz bedingter Formatierung rincewind 6 116 03.11.2016, 16:33
Letzter Beitrag: Käpt'n Blaubär
  7 Stellen in einer Zelle zulassen stefanberg 2 104 28.10.2016, 10:15
Letzter Beitrag: schauan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste