Auslesen einer Tabelle + Übersichtserstellung
#1
Hallo zusammen,
ich bin mir relativ sicher, dass ich gerade auf dem Schlauch stehe, aber ich finde keine passende Lösung zu meinem Problem.
Ich arbeite für einen Dienstleister und habe eine Tabelle, in der alle möglichen Details zu einer Kundengruppe aufgeführt sind. Nun möchte ich diese um bestimmte Preismarken erweitern. Diese werden jedoch nur bei ausgewählten Kunden ergänzt. Dafür habe ich eine Spalte mit dem Namen "Übersicht" ergänzt, in welche ich ein "X" eintragen, falls für dieses Kunde Preise hinterlegt sind. 

Die Tabelle ist mehrere hundert Zeilen lang und ich suche eine Möglichkeit, die für die Preisübersicht relevanten Kunden in einem seperaten Reiter in Form einer extra Tabelle aufzuführen. Ich weiß, dass ich auch in der eigentlichen Tabelle einfach nach "X" filtern kann und dadurch die ausgewählten Kunden angezeigt bekomme, ich hätte es aber gerne seperat. Geht das irgendwie über eine Wennfunktion? Bei meinem ersten versuch wurden die leeren Spalten auch in die seperaten Tabelle übertragen, was das ganze nicht vereinfacht hat.

Lange Rede, kurzer Sinn... anbei eine Beispieldatei. 

.xlsx   Beispieldatei Preisvergleich.xlsx (Größe: 9,87 KB / Downloads: 9)

Danke für eure Hilfe!   20
Zitieren to top
#2
Hola,

als Matrixformel (mit Strg-Shift-Enter abschließen):



Code:
=WENNFEHLER(INDEX(Tabelle!A$2:A$100;KKLEINSTE(WENN(Tabelle!$F$2:$F$100="x";ZEILE($A$2:$A$100)-1);ZEILE(A1)));"")

Die Formel nach rechts und nach unten ziehen.

Gruß,
steve1da
Zitieren to top
#3
Hi,

ohne Matrixformel:


Code:
=WENNFEHLER(INDEX(Tabelle!A:A;AGGREGAT(15;6;ZEILE(Tabelle!$A$2:$A$6)/(Tabelle!$F$2:$F$6="x");ZEILE(A1)));"")
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Zitieren to top
#4
Hallo Edgar, deine Formel passt aber nicht zur Version vom TE...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Zitieren to top
#5
Hi Jörg,

die Datei passt eher nicht zur Beschreibung.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Zitieren to top
#6
Shocked 
Danke für die vielen Antworten und sorry dass ich mich etwas umständlich ausgedrückt habe! Ich glaube aber, dass ich mit den vorgeschlagenen Formeln arbeiten kann.  19
Zitieren to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste