Sverweis + Eine Zeile runter
#1
Hallo Zusammen

Kleine Frage zu meinem Vorhaben:

Ein Schlüssel kann mehrere Kategorien haben. Ich habe diese in Spalten, muss Sie aber auf Zeilen verteilen.

Ich dachte an folgendes: =WENN(SVERWEIS(G2;Tabelle4!$A:$D;3;FALSCH)='export kat'!I2;SVERWEIS('export kat'!G2;Tabelle4!$A:$D;3;FALSCH)+1;"NICHTS")

BSPW:

1x Sverweis um in jedenfall die erste Kategorie ab zugreifen.

Nächste Spalte:
1x Sverweis in Verbindung mit der wenn Formel um: Wenn die Prüfung der wenn-Formel zum Ergebnis des ersten Sverweis führt, dann sverweis zur ersten Kat + 1 Zeile nach unten. Aber iwie kriege ich es nicht hin Sad

Ich bin leider eine Katastrophe im Bezug auf Index ( ich kapiers einfach nicht.. Bezug, Matrix ect.) 

Hat jemand eine Idee?


.xlsx   Excel fürs Forum - Spalten auf Zeilen verteilen.xlsx (Größe: 32,99 KB / Downloads: 4)

Liebe Grüsse
Gino
Zitieren to top
#2
Hallöchen,

INDEX ist gar nicht so schwer.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
1NameVorname  
2IchIcherVorname Position 
3DuDuer2 
4SieSieerDuer 
5  A2:B4Matrix
6  C3Zeile
7  2Spalte

ZelleFormel
C4=INDEX(A2:B4;C3;2)
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg

Bezug wird seltener benötigt.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Zitieren to top
#3
Hallo, ich habe das so verstanden..:

Arbeitsblatt mit dem Namen 'Tabelle1 (3)'
ABCDEF
1Schlüssel 1Schlüssel 2Kategorie
2E1012501000FOTOVOLTAIKANLAGE000781/#/10PHOTO09SgK330------09
3E1012501000FOTOVOLTAIKANLAGE000781/#/EV09/01-1SgK3341-----09
4E1012501000FOTOVOLTAIKANLAGE000781/#/RV09/01-1SgK3342-----09
5E1012501000FOTOVOLTAIKANLAGE000791/#/10PHOTO09SgK330------09
6E1012501000FOTOVOLTAIKANLAGE000801/#/10PHOTO09SgK330------09
7E1012501000FOTOVOLTAIKANLAGE000801/#/10PHOTO09>SgK331------09
8E1012501000FOTOVOLTAIKANLAGE000811/#/10PHOTO09SgK330------09
9
10
11
12
13
14
15
16
17Schlüssel 1KAT 1KAT 2KAT 3KAT 4KAT 5
18E1012501000FOTOVOLTAIKANLAGE00078SgK330------09SgK3341-----09SgK3342-----09
19E1012501000FOTOVOLTAIKANLAGE00079SgK330------09
20E1012501000FOTOVOLTAIKANLAGE00080SgK330------09SgK331------09
21E1012501000FOTOVOLTAIKANLAGE00081SgK330------09

ZelleFormel
A18=WENNFEHLER(INDEX($A$2:$A$8;AGGREGAT(15;6;ZEILE($A$2:$A$8)-1/(ZÄHLENWENN($A$17:A17;$A$2:$A$8)=0);1));"")
B18=WENNFEHLER(INDEX($C$2:$C$8;AGGREGAT(15;6;ZEILE($A$2:$A$8)-1/($A$2:$A$8=$A18);SPALTE(A$1)));"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • RKVE
Zitieren to top
#4
Jockel, super! Ein klares Votum hier für AGGREGAT, betr. Kürze und ohne {}.
Zitieren to top
#5
(28.07.2017, 16:05)Jockel schrieb: Hallo, ich habe das so verstanden..:

Arbeitsblatt mit dem Namen 'Tabelle1 (3)'
ABCDEF
1Schlüssel 1Schlüssel 2Kategorie
2E1012501000FOTOVOLTAIKANLAGE000781/#/10PHOTO09SgK330------09
3E1012501000FOTOVOLTAIKANLAGE000781/#/EV09/01-1SgK3341-----09
4E1012501000FOTOVOLTAIKANLAGE000781/#/RV09/01-1SgK3342-----09
5E1012501000FOTOVOLTAIKANLAGE000791/#/10PHOTO09SgK330------09
6E1012501000FOTOVOLTAIKANLAGE000801/#/10PHOTO09SgK330------09
7E1012501000FOTOVOLTAIKANLAGE000801/#/10PHOTO09>SgK331------09
8E1012501000FOTOVOLTAIKANLAGE000811/#/10PHOTO09SgK330------09
9
10
11
12
13
14
15
16
17Schlüssel 1KAT 1KAT 2KAT 3KAT 4KAT 5
18E1012501000FOTOVOLTAIKANLAGE00078SgK330------09SgK3341-----09SgK3342-----09
19E1012501000FOTOVOLTAIKANLAGE00079SgK330------09
20E1012501000FOTOVOLTAIKANLAGE00080SgK330------09SgK331------09
21E1012501000FOTOVOLTAIKANLAGE00081SgK330------09

ZelleFormel
A18=WENNFEHLER(INDEX($A$2:$A$8;AGGREGAT(15;6;ZEILE($A$2:$A$8)-1/(ZÄHLENWENN($A$17:A17;$A$2:$A$8)=0);1));"")
B18=WENNFEHLER(INDEX($C$2:$C$8;AGGREGAT(15;6;ZEILE($A$2:$A$8)-1/($A$2:$A$8=$A18);SPALTE(A$1)));"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Hi und Danke Jockel Smile

Optisch gesehen passts. Wenn ich die Formel kopiere und einfüge funktioniert etwas nicht aber das passt. Ich versuche lieber verstehen zu wollen, was alles passiert 


Hättest du evtl. noch lust dich meiner Fragen anzunehmen?

Du benutzt:

Wennfehler
Index
Aggregat
Zeile
und Zählenwenn

Sinn vom Wennfehler -> ?
Sinn vom Index -> Suchen des Schlüssel 1.
Sinn des Aggregats -> ?
Sinn der Zeile -> ?
Sinn vom Zählenwenn -> ?

LG Gino
Zitieren to top
#6
(31.07.2017, 15:05)RKVE schrieb: Hi und Danke Jockel Smile

... Ich versuche lieber verstehen zu wollen, was alles passiert 


Hättest du evtl. noch lust dich meiner Fragen anzunehmen?
...
Sinn vom Wennfehler -> ?
Sinn vom Index -> Suchen des Schlüssel 1.
Sinn des Aggregats -> ?
Sinn der Zeile -> ?
Sinn vom Zählenwenn -> ?

LG Gino

Hallo, der Sinn liegt darin, möglichst das richtige Ergebnis je Aufgabenstellung ausgegeben zu lassen. Alle Formeln haben eine dokumentierte Hilfe. Hilfe zur Selbsthilfe findet man in der Formelauswertung oder/und durch den Funktionsassistent... Wo hast du denn hin kopiert..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Zitieren to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste