VBA: Index einer Gültigkeitsprüfungs-Liste ermitteln
#1
Hallo zusammen,

ich habe in "B1" eine Gültigkeitsprüfung definiert mit einer Liste, auf die ich per Namen ("Termine") verweise. Der Bereich "Termine" besteht aus 7 Datumswerten, die in 7 Zellen untereinander notiert sind.

Wie kann ich per VBA feststellen, welcher "Index" in der Gültigkeitsliste ausgewählt wurde? Beispiel: ich wähle in der Gültigkeitsliste das 3. Datum aus. Nun möchte ich per VBA nicht das Datum, sondern die "3" ermitteln. Hoffentlich habe ich das verständlich genug beschrieben.

Ich könnte natürlich den Bereich der "Termine" in einer Schleife durchlaufen und mit dem ausgewählten Datum in "B1" vergleichen; dann finde ich den "Index" durch den Schleifenzähler, aber gibt es da nicht eine einfachere Funktion ohne Schleife?

Danke im Voraus.
Jörg
Zitieren to top
#2
Hola,

warum VBA?


Code:
=VERGLEICH(B1;Termine2;0)

Gruß,
steve1da
Zitieren to top
#3
Moin!
Ja, die gibt es.
Worksheetfunction.Match(ActiveCell, Range("Termine"), 1)

Falls die Termine nicht aufsteigend sortiert sein sollten, muss das dritte Argument 0 lauten.

Gruß Ralf
Zitieren to top
#4
Hallo Ralf,

danke - genau das habe ich gesucht :-))

@steve1da: Danke für die Formel, aber VBA deswegen, weil die Frage Teil eines etwas größeren VBA-Projektes ist.

Viele Grüße
Jörg
Zitieren to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste