Datum automatisch einfügen, laufende Nummer vergeben
#1
Hallo liebe Excelaner Wink
Ich brauche dringend Eure Hilfe.

Ich habe eine Tabelle
Spalte A = Laufende Nummer
Spalte B = Datum
Spalte C = Text

Wird in Spalte "C" nun ein beliebiger Text eingegeben, soll automatisch in Spalte A eine Laufende Nummer, beginnend mit 0001 und in Spalte B das Tagesdatum eingegeben werden.
Das Tagesdatum darf sich Tags drauf nicht verändern haben. Sprich, am 01.08.17 wird der 01.08.17 eingetragen, das Datum vom 31.07.17, bleibt am Vortag erhalten.
Spalte A sollte die Möglichkeit bieten, mit einer beliebigen 4-stelligen Nummer zu beginnen.

Kann mir hier bitte irgendjemand helfen. Ich beherrsche VBA nicht und bräuchte das ziemlich dringend.

Vielen lieben Dank sage ich bereits im voraus.

Beste Grüße, Peter
Zitieren to top
#2
(24.07.2017, 14:35)BPOL-PP schrieb: Ich brauche dringen Eure Hilfe.
Ich beherrsche VBA nicht und bräuchte das ziemlich dringend.

Peter, das Anspruchsdenken nimmt zu ...

Dass du kein VBA beherrscht, ist nicht das Thema! Das geht vielen so.
Beste Grüße
  Günther

Excel-ist-sexy.de
  …schau doch mal rein!
Der Sicherheit meiner Daten wegen lade ich keine *.xlsm bzw. *.xlsb- Files mehr herunter! -> So geht's ohne!
Zitieren to top
#3
Forlaufende Nr geht ohne VBA
Datum ohne VBA fällt mir nichts ein
Zitieren to top
#4
Datum kann man auch per Formel fixieren, ist aber IMHO nicht ganz sauber
http://www.howtoexcelatexcel.com/excel-t...-formulas/
Für JETZT() funktioniert es, müsste damit auch für HEUTE() gehen
Zitieren to top
#5
Hallo Peter,

zur laufenden Nummer mein Vorschlag:

Tabelle1

ABC
1LfdNr. 1Text
2
3
4
Formeln der Tabelle
ZelleFormel
A1=WENN(C1<>"";"LfdNr. "&ZEILE();"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Was den Zeitstempel anbelangt, lies dir doch bitte diesen Tipp durch:  http://www.clever-excel-forum.de/Thread-...eglichkeit
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Zitieren to top
#6
(24.07.2017, 22:00)WillWissen schrieb: Hallo Peter,

zur laufenden Nummer mein Vorschlag:

Tabelle1

ABC
1LfdNr. 1Text
2
3
4
Formeln der Tabelle
ZelleFormel
A1=WENN(C1<>"";"LfdNr. "&ZEILE();"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Was den Zeitstempel anbelangt, lies dir doch bitte diesen Tipp durch:  http://www.clever-excel-forum.de/Thread-...eglichkeit

Besten Dank für den Vorschlag. Wenn die Tabelle in Zeile 15 beginnt, beginnt auch die fortlaufende Nummer mit 15. Das Nummernformat soll 0001 sein. Ich bin auch für eine VBA-Lösung dankbar. Für beide Anfragen.
Besten Dank an dieser Stelle allen die sich der Problematik angenommen haben und vielleicht noch werden. Danke vielmals.
Zitieren to top
#7
Moin Peter,


Zitat:Wenn die Tabelle in Zeile 15 beginnt, beginnt auch die fortlaufende Nummer mit 15. Das Nummernformat soll 0001 sein.

dann so

Code:
=WENN(C15<>"";ZEILE(A1);"")

und benutzerdefiniertes Zahlenformat 0000 einstellen.

Mit VBA kann ich dir leider mangels Wissen nicht weiterhelfen. Hier gibt's aber genügend Spezies.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • BPOL-PP
Zitieren to top
#8
Hi,

am einfachsten ist es wohl, mit STRG + . das Datum fest einzutragen!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Zitieren to top
#9
Vielen Dank an alle. Ich war nun ein paar Tage erkrankt und konnte mich nicht kümmern.
Leider ist nicht wirklich eine Lösung dabei wie ich das Datum automatisiert und vor allem fixiert einfügen kann.

Angel Keiner weiter einen Lösungsvorschlag? Angel
Zitieren to top
#10
Moin!
Zum Datum:
Mit Strg+. hat Dir Edgar ja bereits den allseits bekannten Shortcut genannt.
Wenn Du es per VBA lösen willst, solltest Du mal nach VBA Zeitstempel suchen.
Dies ergibt bei mir 31.200 Fundstellen, die alle korrekt sind.

Am einfachsten dürfte dies zu verstehen sein.
Statt Now() gehört dann Date in den Code.

Wenn Du dann immer noch Fragen hast, dann stelle Deinen Versuch anhand einer Datei hier ein.

Ein klitzekleines bisschen Eigeninitiative wäre wünschenswert.

Gruß Ralf
[-] Folgende(r) 1 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • BPOL-PP
Zitieren to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste