Stundenzahl berechnen nur, wenn Felder leer sind
#1
Guten Tag,
ich habe in meiner Excel Tabelle zur Berechnung meiner Arbeitsstunden in einem Kalender ein Problem.
Und zwar kann man in dem Kalender eintragen Von Wann bis Wann ist gearbeitet habe und dort die Differenz berechnen abzüglich 30 Minuten Pause. Das Problem ist, dass ich es nur berechnet haben will, wenn diese zwei Felder "Von" "Bis" belegt sind.

Meine Anweisung lautet:

Code:
=WENN(G6-H6<>"";ABS(((H6-G6)-ZEIT(0;30;0)));"")

Dieses ABS habe ich eingeführt, weil er die 30 Minuten immer abzieht, was er ja nicht soll, nur wenn die Felder belegt sind. Im Anhang habe ich meine Excel Tabelle zur Verfügung gestellt zur Veranschaulichung.


Angehängte Dateien
.xlsx   Arbeitsplan.xlsx (Größe: 50,83 KB / Downloads: 10)
to top
#2
Hallo Asura,

ich hab jetzt nicht in die Exceldatei geschaut. Wenn Du was tun willst, wenn zwei Felder nicht leer sind, dann im Prinzip so
=WENN(UND(A1<>"";B1<>"");...;...)
oder auch
=WENN(A1&B1<>"";...;...)
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • Asura
to top
#3
Hi Asura,

was hältst du von der Version?

Code:
=WENN(UND(H6<>"";G6<>"");REST(H6-G6;1)-ZEIT(0;30;0);"")

Diese Formel eignet sich auch für Zeitberechnungen über Mitternacht hinaus.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste