Korrektur an Summewenn
#1
Guten Tag,

im Anhang findet ihr eine verfremdete Version meines Problems.
Und zwar muss ich den Gesamtgewinn für jedes Teil in einer Zeile haben, jedoch sind die damit verbundenen Dienstleistungen immer extra aufgeführt.
Die einzige Verbindung, die zeigt welche Dienstleistung zu welchem Teil gehört ist der Code.

Mein bisheriger Stand ist 

=WENN(ISTZAHL(L2);0;SUMMEWENN($F$2:$F$2619;F2;$R$2:$R$2619))


Jedoch stimmt die Summe der einzelnen Gewinne nicht mit meinen Zusammengefassten überein.

Ein Grund den ich dafür gefunden habe ist, dass ich davon ausgegangen bin das jeder Code nur ein Teil und eine unbestimmte Anzahl Dienstleistungen besitzt, jedoch gibt es auch Fälle wo ein Code mehrere Teile besitzt. In meinem Ausschnitt ist das z.B. in Zeile 21/22 der Fall. 

Außerdem ist es auch möglich, dass ein Code mehrmals vorkommen kann, deshalb muss auch ausgeschlossen werden, dass die Summen auch zusammengerechnet werden. Das ist glaub ich einfach über Summewenns möglich mit Kriterien für das Merkmal, welches dann unterschiedlich ist und dem Datum.

Ich hoffe ich konnte mein Problem einigermaßen verständlich erklären. 

Kann mir jemand bei der Lösung helfen? Ich verbringe jetzt schon einen ganzen Tag damit und verliere langsam den Faden  Huh

Danke im Voraus Angel
Zitieren to top
#2
(20.07.2017, 14:12)MaJoLoPro schrieb: Guten Tag,

im Anhang findet ihr eine verfremdete Version meines Problems...

Hallo, du bist ein Scherzkeks, gell..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Zitieren to top
#3
Hallo Jörg

Wegen des Anhangs oder wegen des verfremdeten Problems?
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Zitieren to top
#4
Hallo Detlef, jedes für sich ist schon speziell...!!!
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Zitieren to top
#5
Ups sorry mal wieder typisch den Anhang vergessen


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 12,81 KB / Downloads: 3)
Zitieren to top
#6
Hi,

trag doch bitte einmal bei den relevanten Bereichen händisch in der Nachbarzelle dein erwartetes Ergebnis ein. Aus deiner Beschreibungalleine werde ich nicht schlau.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Zitieren to top
#7
Mein Problem ist, dass das Ziel ist die Gewinne für jede Teilenummer pro Code zusammenzufassen, aber durch meine Formel das Endergebnis falsch ist. das sieht man ganz unten. Normalerweise sollten 414,8 herauskommen und mit meiner Formel komme ich auf ein höheres Ergebnis. Der Fehler der mir aufgefallen ist ist, dass meine Formel nur alle Gewinne pro Code zusammenrechnet und dann das in jeder Zeile wiedergibt in der eine Teilenummer steht. Das hab ich in diesem Fall gelb markiert. Eigentlich sollte wenn ein Code mehrere Teilenummern beinhaltet jede Teilenummer einzeln aufgezählt werden und nicht doppelt zusammengefasst werden.


Angehängte Dateien
.xlsx   Mappe 1.xlsx (Größe: 12,92 KB / Downloads: 6)
Zitieren to top
#8
Hi,

ich würde es mit einer Hilfsspalte (die du einfach ausblenden kannst) lösen:

Tabelle1

FGLRSTU
1CodeMerkmalDL/PNGewinnDatumGewinn 2HS
2MBJJF015231084150000010,35 €1_1628,53 €0
3MBJJF0152310845Ö0807 18,18 €1_16
4RMBJG1E017254643692419504,28 €1_1622,13 €0
5RMBJG1E0172546437201190012,83 €1_16
6RMBJG1E0172546435W3855B 5,02 €1_16
7FMBAEF0092149126914190034,50 €1_1643,46 €0
8FMBAEF0092149125Ä5847 8,96 €1_16
9GMBHE6D2116779811L1872C 1,49 €1_161,49 €0
10QMBJE4E0227210785B4856E 4,70 €1_164,70 €0
11MMBAG5F017748692150000010,37 €1_1671,25 €0
12MMBAG5F0177486926912190030,50 €1_16
13MMBAG5F0177486926925190012,20 €1_16
Formeln der Tabelle
ZelleFormel
T2=WENN(U2=0;SUMMEWENN($F$2:$F$2619;F2;$R$2:$R$43);" ")
U2=WENN(ZÄHLENWENN($F$2:F2;F2)>1;"";0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Zitieren to top
#9
Hallo, oder beides g'samm ohne Hilfsspalte..:


Code:
=WENN(ZÄHLENWENN($F$2:F2;F2)>1;"";SUMMEWENN($F$2:$F$43;F2;$R$2:$R$43))


oder anders herum..:


Code:
=WENN(ZÄHLENWENN(F2:$F$43;F2)>1;"";SUMMEWENN($F$2:$F$43;F2;$R$2:$R$43))
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Zitieren to top
#10
Jetzt besteht wieder das Problem, dass die Summe in der Falschen Zeile erzeugt wird.

Ziel der ganzen Sache ist das ich für jede Teilenummer (5Ä587;3C0807 usw. ) den Gesamtpreis pro Code habe und bei den Dienstleistungen( 69121900, 15000000, usw.) entweder 0€ oder gar nichts steht.
Zitieren to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste