Modalwert mit Bedingung und über mehrere Spalten (+ Tabellen)
#1
Question 
Hey, ich habe eine recht unfangreiche Excel-Datei (2017) erstellt und stehe nun vor folgendem Problem:
Meine Excel Tabelle umfasst 10 symmetrisch aufgebaute Tabellen, bei denen jeweils eingetragene Zahlenwerte neben einem Bezugswort stehen (Werte von 1-7).


?mage

Ich habe mir in einer seperaten "Analyse-Tabelle" den häufigsten Wert von allen 10 Tabellen (aus Spalte H) anzeigen lassen. Dies funktioniert wunderbar mittels Modalwert-Funktion:

[=MODALWERT('Tabelle 1'!H3:H27;'Tabelle 1'!Y3:Y27;'Tabelle 2'!H3:H27;'Tabelle 2'!Y3:Y27;'Tabelle 3'!H3:H27;'Tabelle 3'!Y3:Y27;'Tabelle 4'!H3:H27;'Tabelle 4'!Y3:Y27;'Tabelle 5'!H3:H27;'Tabelle 5'!Y3:Y27;'Tabelle 6'!H3:H27;'Tabelle 6'!Y3:Y27;'Tabelle 7'!H3:H27;'Tabelle 7'!Y3:Y27;'Tabelle 8'!H3:H27;'Tabelle 8'!Y3:Y27;'Tabelle 9'!H3:H27;'Tabelle 9'!Y3:Y27;'Tabelle 10'!H3:H27;'Tabelle 10'!Y3:Y27)]


Nun würde ich mir gerne den häufigsten Wert nur von den Werten anzeigen lassen, deren Bezugswort daneben in Spalte F beispielsweise "Nuke" ist. In dem vereinfachten Beispielsbild, wäre das der Wert 1. Der Wert 3 kommt zwar häufiger vor, aber bezieht sich nicht auf das Bezugswort "Nuke". Ich bräuchte also theoretisch eine "MODALWERTWENN-Funktion", welche leider nicht existiert. Eine Matrix-Funktion ist leider auch keine Lösung, da ich ja den häufigsten Wert aus allen 10 Tabellen (insgesamt 20 Spalten) erhalten will und ich meines Wissens nach damit nur eine Spalte anschauen kann.

Kann man das eventuell mit einer schlichten WENN-Funktion lösen, die in etwa lauten könnte:
[=WENN('Tabelle 1'!F3:F27="Nuke";MODALWERT('Tabelle 1'!H3:H27)]

So kann ich glaub ich ebenfalls nur eine Spalte anschauen und außerdem klappt das mit dem richtigen Bezug so nicht. Ich bin auf jeden fall langsam mit meinem Latein am Ende und würde mich wirklich sehr freuen, wenn mir jemand weiterhelfen könnte.
Zitieren to top
#2
Hallo

Code:
=WENNFEHLER(INDEX(MODUS.VIELF(WENN(XMLFILTERN("<a><b>"&TEXTVERKETTEN("</b><b>";0;Tabelle1:Tabelle10!$F$3:$F$27)&"</b></a>";"//b")=$A1;XMLFILTERN("<a><b>"&TEXTVERKETTEN("</b><b>";0;Tabelle1:Tabelle10!$H$3:$H$27)&"</b></a>";"//b")));SPALTE(A1));"")

Credit an David Hager, Bill Jelen und lori.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • hams123
Zitieren to top
#3
(20.07.2017, 18:00)shift-del schrieb: Hallo

Code:
=WENNFEHLER(INDEX(MODUS.VIELF(WENN(XMLFILTERN("<a><b>"&TEXTVERKETTEN("</b><b>";0;Tabelle1:Tabelle10!$F$3:$F$27)&"</b></a>";"//b")=$A1;XMLFILTERN("<a><b>"&TEXTVERKETTEN("</b><b>";0;Tabelle1:Tabelle10!$H$3:$H$27)&"</b></a>";"//b")));SPALTE(A1));"")

Credit an David Hager, Bill Jelen und lori.

Hey, danke für Ihre Hilfe. Ich versteh nur leider grad nicht so ganz wie genau ich den Code in meine Tabelle einbinde. Mit bloßem Copy&Paste sind die jeweiligen Tabellen nicht verknüpft obwohl sie genauso heißen wie in der Formel. Soll ich Ihnen eventuell die Excel-Tabelle einmal schicken?

?mage
Zitieren to top
#4
[attachment=12385]
Zitieren to top
#5
Jeder Fragesteller hat die Möglichkeit bereits im ersten Beitrag einen aussagekräftige Beispielmappe bei zu stellen. Dazu gehört auch das gewünschte Ergebnis.
Falls das nicht gemacht wird dann gehe ich davon dass der Fragesteller in der Lage ist die vorgeschlagenen Lösungen anzupassen.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Zitieren to top
#6
(20.07.2017, 19:26)shift-del schrieb: Jeder Fragesteller hat die Möglichkeit bereits im ersten Beitrag einen aussagekräftige Beispielmappe bei zu stellen. Dazu gehört auch das gewünschte Ergebnis.
Falls das nicht gemacht wird dann gehe ich davon dass der Fragesteller in der Lage ist die vorgeschlagenen Lösungen anzupassen.

Stimmt tut mir Leid, dem war ich mir leider nicht bewusst, ich bin neu in dem Forum. Können Sie mir vielleicht trotzdem noch weiterhelfen? Smile
Zitieren to top
#7
Hallöchen,

Zitat:Mit bloßem Copy&Paste sind die jeweiligen Tabellen nicht verknüpft obwohl sie genauso heißen wie in der Formel.
Stimmt nicht ganz. In der Frage haben die Tabellennamen Leerzeichen. Wird doch in der Datei genau so sein? Im Lösungsansatz fehlen die. Ich habe jetzt aber erst mal nicht geschaut, ob es bei Übereinstimmung passt.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • hams123
Zitieren to top
#8
Mit Leerzeichen im Blattnamen sieht es dann so aus:
Code:
{=WENNFEHLER(INDEX(MODUS.VIELF(WENN(XMLFILTERN("<a><b>"&TEXTVERKETTEN("</b><b>";0;'Tabelle 1:Tabelle 10'!$F$3:$F$27)&"</b></a>";"//b")=$A1;XMLFILTERN("<a><b>"&TEXTVERKETTEN("</b><b>";0;'Tabelle 1:Tabelle 10'!$H$3:$H$27)&"</b></a>";"//b")));SPALTE(A1));"")}
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • hams123
Zitieren to top
#9
?mage

Danke für den Hinweis mit den Leerzeichen! So ganz passt die Formel aber leider immer noch nicht. Muss ich veilleicht die beiden Bezugswerte $B3 und B1 anpassen? Ich versteh leider die Formel selber nicht wirklich und weiß daher nicht was hier nicht stimmt..

Im Endeffekt soll der häufigste vorkommende Wert der Zellen $H$3:$H$27 aus Tabelle 1 bis Tabelle 10 in Q3 angezeigt werden, aber nur wenn $F$3:$F$27 aus Tabelle 1 bis Tabelle 10 dem Wert "Dust 2", also $B3 entspricht.
Zitieren to top
#10
Hallöchen,

ich kann da leider nichts testen, da mein Excel 2016 die Funktion TEXTVERKETTEN nicht hat. Die gibt es nur unter 365 :-(
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Zitieren to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste