Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Monatsauswahl - Jeden Monat einen anderen Betrag ermitteln
#1
Hallo an alle Excel-Experten.

Ich brauche eure Hilfe.

Ich habe ein Tabelle mit Monaten (Januar bis Dezember) und eine Spalte Gesamt.
Über der Spalte Gesamt, möchte ich ein Drop-Down-Menü haben wo man die 12 Monate auswählen kann.
Wählt man jetzt z.B. März aus, sollen alle Zahlen bis einschließlich März zusammenaddiert und angezeigt werden.

Am besten Ihr schaut euch mal die Excel-Tabelle an. Ich hoffe Sie ist verständlich!

Danke für eure Hilfe.


.xlsx   Test-Problemlösung.xlsx (Größe: 13,05 KB / Downloads: 12)
to top
#2
Hallo, ich würde das aus verschiedensten Gründen mit Daten --> Gültigkeit machen und dann so..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJKLM
3(Errechnet bei "Gesamt" nur einschließlich bis Monat Juni!!!)           Februar
4             
5GesamtJanuarFebruarMärzAprilMaiJuniJuliAugustSeptemberOktoberNovemberDezember
620101010101010101010101010
740202020202020202020202020
860303030303030303030303030
980404040404040404040404040
10100505050505050505050505050

ZelleFormel
A6=SUMME(B6:INDEX(B6:M6;;MONAT($M$3&0)))
A7=SUMME(B7:INDEX(B7:M7;;MONAT($M$3&0)))
A8=SUMME(B8:INDEX(B8:M8;;MONAT($M$3&0)))
A9=SUMME(B9:INDEX(B9:M9;;MONAT($M$3&0)))
A10=SUMME(B10:INDEX(B10:M10;;MONAT($M$3&0)))

ZelleGültigkeitstypOperatorWert1Wert2
M3Liste =$B$5:$M$5 
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
thab1985
to top
#3
Hallo,

hier eine andere Lösung:



Tabelle1
ABCDEFGHIJKLMNOP
1Dropdown für J3
2Monat:Oktober
3Januar
4Februar
5XXXXXXXXXXMärz
6GesamtJanuarFebruarMärzAprilMaiJuniJuliAugustSeptemberOktoberNovemberDezemberApril
7100101010101010101010101010Mai
8200202020202020202020202020Juni
9300303030303030303030303030Juli
10400404040404040404040404040August
11500505050505050505050505050September
12Oktober
131500GesamtNovember
14Dezember

verwendete Formeln
Zelle Formel Bereich N/A
B5:M5=WENN(VERGLEICH(B6;$P$3:$P$14;0)<=VERGLEICH($J$2;$P$3:$P$14;0);"X";"")
A7:A11=SUMMEWENN($B$5:$M$5;"X";B7:M7)
A13=SUMME(A7:A11)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.24 einschl. 64 Bit

Es ist nicht genug, zu wissen. Man muss es auch anwenden.
Es ist nicht genug, zu wollen. Man muss es auch tun.
[-] Folgende(r) 1 Benutzer sagt Danke an Heinz Ulm für diesen Beitrag:
thab1985
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Wochenzahl ermitteln dindu 5 89 19.11.2016, 11:41
Letzter Beitrag: dindu
Lightbulb Turnierplan für 6 Mannschaften Jeder gegen Jeden digitops 13 271 05.11.2016, 20:40
Letzter Beitrag: digitops
  Aus Kreuztabelle einen bestimmten Wert auslesen Nuling 3 129 31.10.2016, 15:11
Letzter Beitrag: snb
  Summe pro Monat oski 4 103 22.10.2016, 12:51
Letzter Beitrag: Jockel
  Probleme einen Tageskalender zu erstellen MarcusDerKleine 3 115 17.10.2016, 09:48
Letzter Beitrag: IchBinIch
  Anzahl der Tage ermitteln abhängig vom Inhalt einer anderen Spalte Hopfenmeile 4 205 06.10.2016, 19:10
Letzter Beitrag: schauan
  Alter des Hundes ermitteln Gurch 5 171 28.09.2016, 19:45
Letzter Beitrag: Gurch
  Mittelwert Indirekt ermitteln Norcoc 10 417 04.09.2016, 22:01
Letzter Beitrag: Norcoc
  Ermitteln von Max und Min Werte für Quartal, Monat und Kalenderwoche, adamelsheimer 7 253 27.08.2016, 09:28
Letzter Beitrag: adamelsheimer
  einen Feldwert automatisch vervollständigen Leinberger 4 239 01.08.2016, 11:29
Letzter Beitrag: Leinberger

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste