Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Monatsauswahl - Jeden Monat einen anderen Betrag ermitteln
#1
Hallo an alle Excel-Experten.

Ich brauche eure Hilfe.

Ich habe ein Tabelle mit Monaten (Januar bis Dezember) und eine Spalte Gesamt.
Über der Spalte Gesamt, möchte ich ein Drop-Down-Menü haben wo man die 12 Monate auswählen kann.
Wählt man jetzt z.B. März aus, sollen alle Zahlen bis einschließlich März zusammenaddiert und angezeigt werden.

Am besten Ihr schaut euch mal die Excel-Tabelle an. Ich hoffe Sie ist verständlich!

Danke für eure Hilfe.


.xlsx   Test-Problemlösung.xlsx (Größe: 13,05 KB / Downloads: 12)
to top
#2
Hallo, ich würde das aus verschiedensten Gründen mit Daten --> Gültigkeit machen und dann so..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJKLM
3(Errechnet bei "Gesamt" nur einschließlich bis Monat Juni!!!)           Februar
4             
5GesamtJanuarFebruarMärzAprilMaiJuniJuliAugustSeptemberOktoberNovemberDezember
620101010101010101010101010
740202020202020202020202020
860303030303030303030303030
980404040404040404040404040
10100505050505050505050505050

ZelleFormel
A6=SUMME(B6:INDEX(B6:M6;;MONAT($M$3&0)))
A7=SUMME(B7:INDEX(B7:M7;;MONAT($M$3&0)))
A8=SUMME(B8:INDEX(B8:M8;;MONAT($M$3&0)))
A9=SUMME(B9:INDEX(B9:M9;;MONAT($M$3&0)))
A10=SUMME(B10:INDEX(B10:M10;;MONAT($M$3&0)))

ZelleGültigkeitstypOperatorWert1Wert2
M3Liste =$B$5:$M$5 
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
thab1985
to top
#3
Hallo,

hier eine andere Lösung:



Tabelle1
ABCDEFGHIJKLMNOP
1Dropdown für J3
2Monat:Oktober
3Januar
4Februar
5XXXXXXXXXXMärz
6GesamtJanuarFebruarMärzAprilMaiJuniJuliAugustSeptemberOktoberNovemberDezemberApril
7100101010101010101010101010Mai
8200202020202020202020202020Juni
9300303030303030303030303030Juli
10400404040404040404040404040August
11500505050505050505050505050September
12Oktober
131500GesamtNovember
14Dezember

verwendete Formeln
Zelle Formel Bereich N/A
B5:M5=WENN(VERGLEICH(B6;$P$3:$P$14;0)<=VERGLEICH($J$2;$P$3:$P$14;0);"X";"")
A7:A11=SUMMEWENN($B$5:$M$5;"X";B7:M7)
A13=SUMME(A7:A11)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.24 einschl. 64 Bit

Es ist nicht genug, zu wissen. Man muss es auch anwenden.
Es ist nicht genug, zu wollen. Man muss es auch tun.
[-] Folgende(r) 1 Benutzer sagt Danke an Heinz Ulm für diesen Beitrag:
thab1985
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Zellen hervorheben durch einen Tricker Kilran 24 231 Vor 1 Stunde
Letzter Beitrag: schauan
  Datumsliste: Wochentage pro Monat jb013 35 622 09.02.2017, 21:57
Letzter Beitrag: shift-del
  Nettoarbeitstage im Monat berechnen freiminute 16 192 07.02.2017, 00:22
Letzter Beitrag: Palomino
  Mittelwert abhängig vom Monat bilden thyslo 7 131 06.02.2017, 17:21
Letzter Beitrag: shift-del
  Alter berchnen nach Monat/Jahr brave78 9 161 02.02.2017, 19:04
Letzter Beitrag: Ego
  Zählen wenn mit zwei Bedinungen ( Monat und Ja/Nein) DBSB 6 141 31.01.2017, 12:55
Letzter Beitrag: RPP63
  betrag im Monat zusammenzählen Lorbse 7 176 02.01.2017, 09:14
Letzter Beitrag: Lorbse
  Letzte Kolonne ermitteln PaulB 2 120 31.12.2016, 13:26
Letzter Beitrag: schauan
  Zellenwert aus Tabelle ermitteln einmalrund 5 136 28.12.2016, 19:15
Letzter Beitrag: Jockel
  Zahlenkombinationen ausrechnen die einen gewünschten Gesamtwert nicht überschreiten hans_meiser 10 348 27.12.2016, 18:27
Letzter Beitrag: Ego

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste