Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Excel 2010 - Zwei Spalten vergleichen lassen (Namensliste)
#1
Question 
Guten Tag zusammen,

ich möchte euch gerne Fragen und um hilfe bitten:

ich habe eine Namensliste welche sich ständig aktualisiert und diese soll dann auf dem aktuellens Stand gehalten werden.

Ich stelle mir das so vor:

Code:
Spalte A    Spalte B:    Spalte C:
ABC                        ABC
AAA            AAA         ACC
ACC                        DDD
DDD                        CFD
CFD

sorry sieht ein wenig verrutscht aus

so in etwa. Also er soll Spalte A mit Spalte C vergleichen und wenn ein Name nicht drin steht unter Spalte B den Fehlenden Namen anzeigen. Problem ist, dass die Namen in verschiedener Reihenfolge stehen können. Ich kann die zwar nach Alphabet sortieren, aber wenn einer Falsch ist, dann sind ja quasi alle folgenden auch falsch. Deshalb geht ein Direkter Vergleich mit Spalte A1 zu C1 z.B. nicht.

Habt ihr einen Tipp ?

Vielen Dank
to top
#2
Hola,

mit einer Hilfsspalte könnte man das so lösen:

schreib z.B. in D1:

Code:
=wenn(zählenwenn(C:C;A1);"";"x")

Ziehe diese Formel runter. Jetzt hast du überall ein X stehen, wo der Name aus Spalte A nicht in der Spalte C vorkommt. Mit diesen Xen kannst du dir die fehlenden wie folgt ausgeben lassen:

http://www.excelformeln.de/formeln.html?welcher=224

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
Tigerking
to top
#3
Hallo,

mein Vorschlag:
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1Spalte ASpalte BSpalte C
2ABC ABC
3AAAAAAACC
4Acc DDD
5DDD CFD
6CFD  

ZelleFormel
B2=WENNFEHLER(WENN(VERGLEICH(A2;C:C;0)>0;"");A2)
B3=WENNFEHLER(WENN(VERGLEICH(A3;C:C;0)>0;"");A3)
B4=WENNFEHLER(WENN(VERGLEICH(A4;C:C;0)>0;"");A4)
B5=WENNFEHLER(WENN(VERGLEICH(A5;C:C;0)>0;"");A5)
B6=WENNFEHLER(WENN(VERGLEICH(A6;C:C;0)>0;"");A6)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Aloys
Win 7, Office 2010
[-] Folgende(r) 1 Benutzer sagt Danke an aloys78 für diesen Beitrag:
Tigerking
to top
#4
Wow, echte Excel Profis hier Smile Das ging ja schnell und hat mir schon unheimlich geholfen. Sonst hätte ich noch ewig gesucht.

Hallo steve1da,

danke. Das funktioniert soweit, nur komm ich mit dem Link nicht weiter. Das wurde mir zu kompliziert, da blicke ich kaum durch. Aber man könnte das doch dann mit einer einfachen Wenn dann Formel lösen oder nicht ?

Code:
=WENN(D5="x";A5)
Das hat zumindest bei mir auch funktioniert.


@Aloys,

hey danke. Das sagt mir sogar mehr zu, denn damit lässt sich dann alles ja in einer Formel lösen.

Danke euch beiden ! Top
to top
#5
Hola,

im Link wird quasi beschrieben, wie man eine Liste der Xe untereinander auflistet - wenn dir die Formel von Aloys reicht, umso besser Thumps_up

Gruß,
steve1da
to top
#6
Hallo zusammen,

ich melde mich nochmal Smile

um das ganze nun noch zu verfeinern suche ich die ganze zeit nach einer Lösung um zwei Spalten miteinander zu verschmelzen.

Allerdings klappt das nicht so wie ich mir das vorstelle, im Internet wurde ich auch nicht fündig.

Ich habe nun Spalte A mit B vergleichen lassen und unter C die abweichungen auflisten lassen. Nun wäre es cool wenn man die Ergebnisse aus B und C zusammenführen kann. Allerdings pro Zelle nur einen Namen. Also soll quasi in einer neuen Spalte die liste weitergeführt werden nach unten hin.

Also z.B so: , ich hoffe ihr versteht wie ich das meine:

Code:
A1:  Arnold   B1:   "leere Zelle"   C1: Arnold
A2: Julia     B2: "Lea"             C2: Julia
A3: Sven      B3: "leere Zelle"     C3: Lea
                                    C4: Sven



Habt ihr eine Idee ?
to top
#7
Hi,

(08.11.2014, 18:03)Tigerking schrieb: Ich habe nun Spalte A mit B vergleichen lassen und unter C die abweichungen auflisten lassen. Nun wäre es cool wenn man die Ergebnisse aus B und C zusammenführen kann. Allerdings pro Zelle nur einen Namen. Also soll quasi in einer neuen Spalte die liste weitergeführt werden nach unten hin.

Warum willst Du B und C zusammenführen, in C sind doch schon Namen von B enthalten?

Also ich würde einfach die Spalten A und B untereinander kopieren und dann mit "Duplikate entfernen" im Ribbon "Daten" die Doppelten rauslöschen.
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#8
Hallo,


nein es sind unterschiedliche Namen, da auch eventuell neue Namen hinzugekommen sind zwischen der ersten Liste und der neuen Liste. Daher soll alles nochmal zusammengefasst werden.

A: Ursprüngliche Namensliste , B: Differenzen, C: Vergleichsliste, D: Zusammenfassung.


Okay dein Vorschlag würde funktionieren. Geht sowas vielleicht auch mit einer Formel automatisch ?
to top
#9
Hallo,

mit Excel läßt sich manches realisieren, wenn man die Basisdaten kennt. Deine Anfrage:

Zitat:ich habe eine Namensliste welche sich ständig aktualisiert
1. Ist diese Namensliste auf einem separaten Blatt?
2. Wie aktualisert sie sich?

Zitat:diese soll dann auf dem aktuellens Stand gehalten werden

1. Wenn sie sich ständig aktualisiert, warum dann noch eingreifen?

Zitat:Also er soll Spalte A mit Spalte C vergleichen und wenn ein Name nicht drin steht unter Spalte B den Fehlenden Namen anzeigen

1. Welche Spalte ist die aktuellere?
2. Sind die Spalten auf einem Blatt?

Warum diesen Zwischenschritt mit einer Auflistung der neuen Namen?

Hier mal zwei Ideen:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFG
1ABC ABC ABC ABC
2AAAAAAACC AAA1ACC
3ACC DDD ACC DDD
4DDD CFD DDD CFD
5CFD AAA CFD AAA
6    XXX2XXX

ZelleFormel
B1=WENN(ZÄHLENWENN($C$1:$C$4;A1);"";A1)
C5{=INDEX(B:B;KKLEINSTE(WENN(B:B<>"";ZEILE(B:B));ZEILE(A1)))}
F1=WENN(ZÄHLENWENN($G$1:$G$4;E1);"";1)
F2=WENN((ZÄHLENWENN($G$1:$G$4;E2)>0)+(E2="");"";ANZAHL($F$1:F1)+1)
G5=WENN(ZEILE(A1)>MAX(F:F);"";INDEX(E:E;VERGLEICH(ZEILE(A1);F:F;0)))
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#10
Hi,

(09.11.2014, 10:26)Tigerking schrieb: nein es sind unterschiedliche Namen, da auch eventuell neue Namen hinzugekommen sind zwischen der ersten Liste und der neuen Liste. Daher soll alles nochmal zusammengefasst werden.

A: Ursprüngliche Namensliste , B: Differenzen, C: Vergleichsliste, D: Zusammenfassung.

aber auch dann kannst Du die erste und die neue Liste untereinander kopieren und die Duplikate entfernen.
Du benötigst die Differenzen doch dann gar nicht.
Oder Du fügst alle drei Listen [Spalte A, B und C) in D untereinander und entfernst die Duplikate. Das machst Du ein Mal und zeichnest es als Makro auf, dann kannst Du das immer wieder verwenden.

(Matrix-)Formeln machen eine Datei langsamer. Makro ist schneller.
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  MsgBox bei bestimmten Kriterien nicht ausgeben lassen Basti5 2 46 Gestern, 11:35
Letzter Beitrag: Basti5
  Unterschiede W7/2010/13 zu W10/2016 schauan 5 102 24.02.2017, 15:39
Letzter Beitrag: maninweb
  zwei Zwei Zellen synchronisieren in beide Richtungen ohne VBA nuberr 2 46 24.02.2017, 10:07
Letzter Beitrag: BoskoBiati
  Bereich berechnen lassen Basti5 5 74 22.02.2017, 15:22
Letzter Beitrag: Basti5
  Jeweils zwei Spalten unabhängig voneinander sortieren Denz 4 65 21.02.2017, 21:53
Letzter Beitrag: Denz
Question Webseite in Excel anzeigen lassen o0Julia0o 14 207 20.02.2017, 16:38
Letzter Beitrag: GMG-CC
  Doppelte Werte aus zwei Spalten anzeigen JulyVienna 7 83 19.02.2017, 20:14
Letzter Beitrag: JulyVienna
Question Doppelte PLZ in verschiedenen Zellen suchen und anzeigen lassen KarinG 17 182 08.02.2017, 15:28
Letzter Beitrag: atilla
  Personenliste nach Datum filtern und Name anzeigen lassen menslo 5 82 07.02.2017, 19:12
Letzter Beitrag: GMG-CC
  Excel Abfrage - Wie können einzelne Spalten auf einem Blatt dargestellt werden?? excelblower 5 167 30.01.2017, 17:29
Letzter Beitrag: schauan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste