Fortlaufende Zählung wenn "Ja"
#1
Einen schönen guten Tag an alle EXEL-Freunde,
ich habe in einer Tabelle in der Zelle "B5" über die Datenprüfung Liste das Wort "Ja" eingetragen.
Mein großer Wunsch wäre: Wenn ich das Wort "Ja" B5 bis Bx sollte in der freien Zelle z.B. "B4" eine Zahl erscheinen, wie oft ich "Ja" ausgewählt habe.
Wie im Beispiel am 01.09.2014 das erste mal "Ja" ( 1), dann am 06.09.2014 das zweite mal "Ja"(2) usw. immer fortlaufend.
Das "Ja" wird je nach Tagesereignis ausgewählt.
Ich habe die Datei hinzugefügt.
Gruß
Günther


Angehängte Dateien
.xls   Anwendung Ja.xls (Größe: 58 KB / Downloads: 8)
to top
#2
hi Günther, der Aufbau ist nicht optimal, aber eine Formel (nicht zum ziehen sondern) zum kopieren könnte ich anbieten..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
401.09.20141
5Ja
602.09.2014 
7 
803.09.2014 
9 
1004.09.2014 
11 
1205.09.2014 
13 
1406.09.20142
15Ja
1607.09.2014 
17 
1808.09.20143
19Ja

ZelleFormel
B6=WENN(B7="ja";MAX($B$4:B5)+1;"")
B8=WENN(B9="ja";MAX($B$4:B7)+1;"")
B10=WENN(B11="ja";MAX($B$4:B9)+1;"")
B12=WENN(B13="ja";MAX($B$4:B11)+1;"")
B14=WENN(B15="ja";MAX($B$4:B13)+1;"")
B16=WENN(B17="ja";MAX($B$4:B15)+1;"")
B18=WENN(B19="ja";MAX($B$4:B17)+1;"")

ZelleGültigkeitstypOperatorWert1Wert2
B5Liste =$F$4:$F$5 
B7Liste =$F$4:$F$5 
B9Liste =$F$4:$F$5 
B11Liste =$F$4:$F$5 
B13Liste =$F$4:$F$5 
B15Liste =$F$4:$F$5 
B17Liste =$F$4:$F$5 
B19Liste =$F$4:$F$5 
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Guenther52
to top
#3
Hallo Guenther,

mein Vorschlag basiert auf VBA. Folgender Code kommt in
das schon vorhandene VBA-Modul der Tabelle1:

Code:
Private Sub Worksheet_Change(ByVal Target As Range)
  If Target.Column = 2 Then
    If Not Application.Intersect(Target.EntireColumn.SpecialCells(xlCellTypeAllValidation), Target) Is Nothing Then
      If Target.Value = "Ja" Then
        With Target.Offset(-1)
          .Value = .Value + 1
        End With
      End If
    End If
  End If
End Sub

Gruß Uwe
to top
#4
Hallo Jockel, deine Formeln habe ich kopiert, es funktioniert Super!
Danke Günther!
to top
#5
Hallo Uwe, ich habe den Code kopiert und eingefügt. Aber es erscheint immer nur die Zahl "1"
Egal wie oft ich "Ja" auswähle, also nicht fortlaufend.
Gruß
Günther
to top
#6
Hallo Günther,

ja, leider hatte ich die Frage falsch verstanden.

Gruß Uwe
[-] Folgende(r) 1 Benutzer sagt Danke an Kuwer für diesen Beitrag:
  • Guenther52
to top
#7
Hi,

(23.10.2014, 13:51)Jockel schrieb: der Aufbau ist nicht optimal, aber eine Formel (nicht zum ziehen sondern) zum kopieren könnte ich anbieten..:

ich würde es so machen, dann kann die Formel auch gezogen werden. Das ist viel einfacher und schneller als kopieren.

Tabelle1
ABC
401.09.20141Ja
502.09.2014
603.09.2014
704.09.2014
805.09.2014
906.09.20142Ja
1007.09.2014
1108.09.20143Ja
1209.09.2014
Schriftart wird in dieser Tabelle nicht dargestellt

verwendete Formeln
Zelle Formel Bereich N/A
B5:B12=WENN(C5="Ja";MAX($B$4:B4)+1;"")

Zahlenformate
Zelle Format Wert
A4 'TT.MM.JJJJ 41883
A5 'TT.MM.JJJJ 41884
A6 'TT.MM.JJJJ 41885
A7 'TT.MM.JJJJ 41886
A8 'TT.MM.JJJJ 41887
A9 'TT.MM.JJJJ 41888
A10 'TT.MM.JJJJ 41889
A11 'TT.MM.JJJJ 41890
A12 'TT.MM.JJJJ 41891
Zellen mit Format Standard werden nicht dargestellt
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
  • Guenther52
to top
#8
Zunächst möchte ich mich für meine späte Reaktion entschuldigen. Meine Tochter hatte einen Verkehrsunfall, somit hatte ich mein Kopf mit anderen Dingen voll. Aber vielen Dank für Eure Bemühungen.
Meine Tabelle habe ich den neuen Bedingungen angepaßt.
Dabei kam mir aber noch eine Idee. Die Tabelle habe ich erweitert, in den Zeilen wo ich das "Ja" auswähle errechne ich Differenzen zwischen den einzelnen Zeilen mit "Ja". Das klingt jetzt verworren, aber ich lade die NEUE Tabelle noch einmal hoch, ich denke die Erläuterungen in der Tabelle erklären genau worum es mir geht.
Vielleicht gibt es eine Lösung!
Gruß
Günther


Angehängte Dateien
.xls   Anwendung Ja.xls (Größe: 74 KB / Downloads: 6)
to top
#9
Hallo,

in K5:
Code:
=WENN(J5="";"";J5-VERWEIS(9;1/($J$4:J4<>"");($J$4:J4)))

und nach unten ziehen.

Ach ja, statt der Formel von Jörg könnte man es auch so machen:

Code:
=WENN(F4="ja";ZÄHLENWENN($F$4:F4;"JA");"")
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Guenther52
to top
#10
(27.10.2014, 13:44)BoskoBiati schrieb: Hallo,
...
Ach ja, statt der Formel von Jörg könnte man es auch so machen:

Code:
=WENN(F4="ja";ZÄHLENWENN($F$4:F4;"JA");"")

Hallo Edgar, sicher, sicher, mein Vorschlag ist aber alternativ und kürzer... 05
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Guenther52
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste