Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

zwei Abfragen
#1
Hallo,
ich möchte in dem Tabellenblatt Packauftrag ein Ergebnis aus dem Tabellenblatt Bestellungen ziehen.
Und zwar Eingabe in den Feldern im Packauftrag "Datum & Kundennr.Smile Suche mir in den Bestellungen
in der Spalte a das betreffende Datum und in der Spalte b die entsprechende Kdr.: aus und weise mir
das entsprechende Produkt aus der Spalte F aus.
Das sollte eigentlich mit einer sverweisformel funktionieren. Sind allerdings zwei Abfragen.
Suche 02 aus Packauftrag in Bestellungen Spalte A und
04 aus Packauftrag in Bestellungen Spalte B
und werfe mir den Wert aus Spalte F in B7 Packauftrag aus. Dasselbe muss ich dann auch natürlich in den Zeilen C bis 0 machen.
Kann mir jemand helfen??
Gruß Heb
to top
#2
Hallo,

ich habe mir deine Datei kurz angesehen, komme aber mit deiner Beschreibung nicht ganz klar:

Zitat:Suche 02 aus Packauftrag in Bestellungen Spalte A

In Spalte A vom Tabellenblatt Bestellungen steht ein Datum.

Schau mal ob du mit der Funktion Verweis zum Ziel kommst.
Gruß
Peter
to top
#3
Hallo Peter,
habe ich schon versucht hat irgendwie aber nicht funktioniert.
Habe trotz mehreren Versuchen die Abfragem nicht hinbekommen. Ist aber eigentlich ganz einfach.
Man muss es nur wissen. Ich gebe im Tabellenblatt Packauftrag im Feld 02 das Datum und im Feld 04 die Kundennummer ein, und er soll mir alle Produkte die mit dem eingegeben Datum und die dazugehörige eingegeben Kundennummer aus den Bestellungen ausweisen.
Ziel ist es den Packauftrag auszudrucken, damit die Mitarbeiter erkennen wann muss welche Ware für den Kunden x gepackt werden.
Glaube das dieses vielleicht besser verstanden wird.
Gruß Heb
to top
#4
Hola,

meinst du das so?

Code:
{=WENN(ZEILE(Z1)>SUMME((Bestellungen!$A$4:$A$23=$O$2)*(Bestellungen!$B$4:$B$23=$O$4));"";INDEX(Bestellungen!$F$4:$F$23;KKLEINSTE(WENN((Bestellungen!$A$4:$A$23=$O$2)*(Bestellungen!$B$4:$B$23=$O$4);ZEILE($1:$20));ZEILE(Z1))))}

Die {} nicht mit eingeben, sondern die Formel mit Strg-Shift-Enter abschließen.

Gruß,
steve1da
to top
#5
Hallo steve1da, der TE arbeitet offenbar mit XL2007 oder höher...

(27.11.2014, 12:20)steve1da schrieb: Hola,

meinst du das so?

Code:
{=WENN(ZEILE(Z1)>SUMME((Bestellungen!$A$4:$A$23=$O$2)*(Bestellungen!$B$4:$B$23=$O$4));"";INDEX(Bestellungen!$F$4:$F$23;KKLEINSTE(WENN((Bestellungen!$A$4:$A$23=$O$2)*(Bestellungen!$B$4:$B$23=$O$4);ZEILE($1:$20));ZEILE(Z1))))}

Die {} nicht mit eingeben, sondern die Formel mit Strg-Shift-Enter abschließen.

Gruß,
steve1da
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hola,

du hast natürlich Recht Jockel 29

Code:
{=WENNFEHLER(INDEX(Bestellungen!$F$4:$F$23;KKLEINSTE(WENN((Bestellungen!$A$4:$A$23=$O$2)*(Bestellungen!$B$4:$B$23=$O$4);ZEILE($1:$20));ZEILE(Z1)));"")}

Gruß,
steve1da
to top
#7
Hallo,
habe die Formel so eingebastelt, funktioniert merkwürdiger Weise aber nur für den 7.11. (steht in der ersten Zelle in den Bestellungen. Frage kann man diese zwei Abfragen (Datum & Kdr.nrSmile nicht viel einfacher mit einem SVerweis abfragen??
Gruß Heb
to top
#8
(27.11.2014, 15:29)heb01 schrieb: Hallo,
habe die Formel so eingebastelt, funktioniert merkwürdiger Weise aber nur für den 7.11. (steht in der ersten Zelle in den Bestellungen. Frage kann man diese zwei Abfragen (Datum & Kdr.nrSmile nicht viel einfacher mit einem SVerweis abfragen??
Gruß Heb

Hallo, kanppe Antwort: Nein...!!!
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#9
Hola,

auch für andere Daten funktioniert die Formel. Sollte #NV bei dir ausgegeben werden, so liegt das an den #NVs die in der Tabelle "Bestellungen" stehen.

Ansonsten kann man nur mutmaßen, was nicht funktioniert.

Gruß,
steve1da
to top
#10
Hallo,
juchee funktioniert zumindest die ersten zwei Zeilen,

Ist zwar eine Megaformel, brauche noch etwas bis ich sie, wenn überhaupt, verstehe.

=WENN(ZEILE(Z1)>SUMME((Bestellungen!$A$4:$A$23=$O$2)*(Bestellungen!$B$4:$B$23=$O$4));"";INDEX(Bestellungen!$F$4:$F$23;KKLEINSTE(WENN((Bestellungen!$A$4:$A$23=$O$2)*([Be​stellungen]Bestellungen!$B$4:$B$23=$O$4);ZEILE($1:$20));ZEILE(Z1))))
Ich habe versucht die Bereiche A B und F von 23 auf 1000 zu erweitern (23Zeilen reichen mit Sicherheit nicht), dann funktioniert die Formel aber nicht mehr. Habe ich vielleicht irgendetwas in der Megaformel übersehen??
Verrate mit bitte wo ich in der Formel den Bezug auf die Spalte B(Produkte) im Tabellenblatt Bestelliste finde.
Ich muss die anderen Angaben die Mengen der unterschiedlichen Verpackungsgrößen nämlich auch noch übertragen. Was hat es sich mit der Zeile Z1 und Zeile 1:20 auf sich??
im Packauftrag habe ich sie einmal gelb hinterlegt ebenso die Quelle in den Bestellungen.
Gruß Heb
Habe die Datei noch einmal angehängt
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste