Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

wenn index vergleich
#1
Schönen guten Abend euch allen,

ich sitze seit stunden an einer Formel die fast fertig ist, nur fehlt mir das letzte stück.

die Funktion gibt mir sauber zurück ob etwas lieferbar ist, doch sobald etwas nicht vorhanden ist(Bestellmenge = größer Bestand) bekomme ich jedesmal einen NV Fehler.

Formel lautet wie folgt:

=WENN(INDEX($B$9:$H$17;VERGLEICH($F$3;F9:F17;-1);7);"Lieferbar";"nicht Lieferbar")

ich weiß im Moment echt nicht weiter wie ich diesen Fehler ausmerzen kann. Anbei die Beispielmappe... Formel steht in J3

Und ja, diese Problem habe ich anders lösen können(zu sehen in der mappe), doch möchte ich es unbedingt so machen weil es sauberer ist als Daten zur Berechnung in Zellen zu verstecken.

Ich sag schon mal Danke im Voraus

Gruss Oliver


Angehängte Dateien
.xlsx   Sverweis_Index_Vergleich.xlsx (Größe: 11,15 KB / Downloads: 8)
to top
#2
Hallo Oliver

Zitat:VERGLEICH($F$3;F9:F17;-1)
Aus der Online-Hilfe:

Vergleichstyp
-1 VERGLEICH sucht nach dem kleinsten Wert, der größer oder gleich dem Wert für Suchkriterium ist. Die Werte im Argument Suchmatrix müssen in absteigender Reihenfolge angeordnet sein, z. B. WAHR, FALSCH, Z-A,...2, 1, 0, -1, -2,... usw.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
Hallo,

ich würde das so angehen:

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDEFGH
2Suche   Best. Menge kgEinzelpreis kgLieferbar
3NormalLieferantABHDAepfel32,740 kg0,39Lieferbar
4RekursivObstAepfelABHD32,740 kg0,39Lieferbar
5       
6       
7       
8IDLieferantProduktEinzelpreis KGMenge KGGesamtpreis KGauf Lager
91ABHDAepfel0,39 €32,740 kg12,77 €2.000,000 kg
102CPOFBirnen0,28 €28,933 kg8,10 €3.856,000 kg
113GTELKirschen0,42 €44,475 kg18,68 €43,900 kg
124HGDTErdbeeren0,18 €21,740 kg3,91 €19,756 kg
135OKGTMangos0,74 €53,931 kg39,91 €874,870 kg
146IUTGPapayas0,51 €47,650 kg24,30 €875,986 kg
157IUZHBananen0,22 €67,794 kg14,91 €8.845,987 kg
168OIZHMandarinen0,17 €55,550 kg9,44 €34,900 kg
179IUIOApfelsinen0,33 €33,874 kg11,18 €2.354,970 kg

ZelleFormel
E3=SVERWEIS($D$3;$C$9:$H$17;2;FALSCH)
F3=SVERWEIS($D$3;$C$9:$H$17;4;FALSCH)
G3=SVERWEIS($D3;$C$9:$H$17;3;FALSCH)
H3=WENN(SVERWEIS(D3;$C$9:$H$17;6;0)>=F3;"";"Nicht ")&"Lieferbar"
E4=INDEX($C$9:$C$17;VERGLEICH($D$4;$D$9:$D$17;0))
F4=SVERWEIS(E4;$C$9:$H$17;4;0)
G4=SVERWEIS($D4;$D$9:$H$17;2;FALSCH)
H4=WENN(SVERWEIS(D4;$D$9:$H$17;5;0)>=F4;"";"Nicht ")&"Lieferbar"
G9=WENN(E9;F9*E9;"")

ZelleGültigkeitstypOperatorWert1Wert2
D3Liste =$C$9:$C$17 
D4Liste =$D$9:$D$17 
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • oliver
to top
#4
Super, ich danke Dir für das Beispiel. Falls mir die Lösung zu meinem Versuch noch in den Sinn kommen sollte werde ich diese noch posten, bis dahin werde ich mich mit Deinem Ansatz begnügen, vielen Dank nochmals & schönen Abend noch ...

Gruss Oliver
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste