Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

weiterziehen/transponieren einer Formel
#1
Hallo alle miteinander,

bräuchte mal wieder Hilfe

ich habe folgende Matrix:

Mitarbeiter Projekt
655064 655066 655075 655088 655130    .......
MA A X X X
MA B X
MA C
MA D


Folgende Formel habe ich angewandt, um zu überprüfen welcher Mitarbeiter an welchem Projekt arbeitet:

=WENN(ODER('MA A'!$A$5 ="655064";'MA A'!$A$6 ="655064";'MA A'!$A$7 ="655064";'MA A'!$A$8 ="655064";'MA A'!$A$9 ="655064";'MA A'!$A$10 ="655064";'MA A'!$A$11 ="655064";'MA A'!$A$12 ="655064"; 'MA A'!$A$13 ="655064";'MA A'!$A$14 ="655064";'MA A'!$A$15 ="BI655064";'MA A'!$A$16 ="BI 655064";'MA A'!$A$17 ="BI 655064";'MA A'!$A$18 ="655064";'MA A'!$A$19 ="BI 655064";'MA A'!$A$20 = "655064");"X";"")


Dies will ich nun für jeden Mitarbeiter für jedes Projekt machen, allerdings ist es mir viel zu aufwendig händisch alles zu machen.


Habe bei der ersten Formel dann statt der Projektnummer das B$2 eingegeben, sprich:
(in B2, C2-.. stehen die projektnummern....)

=WENN(ODER('MA A'!$A$5 ="B$2";'MA A'!$A$6 ="B$2"........

und dann rüberziehen.


Allerdings funktioniert das nicht  22



Gibt es da einen Trick? wie macht man das am Besten?

VG
Twobbi
Antwortento top
#2
Hola,

eine kleine Beispieldatei würde enorm weiterhelfen ;)

Gruß,
steve1da
Antwortento top
#3
Hat sich erledigt. hab grad über mein geschriebemnes selbst drüber geschaut und gesehen, dass das B$2 in "" gesetzt war  16

Manchmal hilft es eben schon ein Problem darzustellen ^^
Antwortento top
#4
Hallo, 

die ist per se schon daneben.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
Hallo,

ich meinte die Formel. Mein Handy hat da nicht richtig mitgemacht.
Eine Aneinanderreihung solcher Vergleiche ist nicht sinnig! Das ginge einfacher so:


Code:
=WENN(Zählenwenn('MA A'!$A$5:A$14;"655064")+Zählenwenn('MA A'!$A$15:$A$17;"BI 655064")+('MA A'!$A$18 ="655064")+('MA A'!$A$19 ="BI 655064")+('MA A'!$A$20 = "655064");"X";"")
Im einfachsten Fall, wenn nur 655064 und BI 655064 vorkommen (Zahlen als Text formatiert!):

Code:
=WENN(Zählenwenn('MA A'!$A$5:A$20;B$2);"X";"")
=WENN(Zählenwenn('MA A'!$A$5:A$20;"*655064");"X";"")
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • twobbelix
Antwortento top
#6
(01.07.2015, 07:35)BoskoBiati schrieb: Hallo,

ich meinte die Formel. Mein Handy hat da nicht richtig mitgemacht.
Eine Aneinanderreihung solcher Vergleiche ist nicht sinnig! Das ginge einfacher so:


Code:
=WENN(Zählenwenn('MA A'!$A$5:A$20;B$2);"X";"")
=WENN(Zählenwenn('MA A'!$A$5:A$20;"*655064");"X";"")

Hallo Bosko,

Die Formel funktioniert aber einwandfrei  19    auch wenns sehr aufwendig war  05

danke für den Tip mit dem Zählenwenn, werd ich nächstes mal probieren  21
Ist halt ne dropdownliste, wo von den xprojekten vielleicht das eine vorkommt......



twobbi
Antwortento top
#7
@Bosko,

funktioniert top.

Danke nochmals 17

Erspart mir jetzt ne Menge arbeit

VG
twobbi
Antwortento top
#8
Hallo Bosko und Co,

es hat einwandfrei funktioniert. Jetzt wo ich es wieder geöffnet habe, ercheint bei allen #Wert  22

meine Formel:

=WENN(ZÄHLENWENN('\\x\x\x\x\x\[Labor_I.xlsx]MA A'!$A$5:$A$20;$A4);"X";"")

Es geht darum zu überprüfen ob der MA in einem Projekt arbeitet oder nicht. ich ziehe die Formel von oben nach unten bei jedem MA


die matrix sieht so aus:

Projekte Labor 1
........MA A......MA B.....MA C.....MA D
A 1 #WERT! #WERT! #WERT! #WERT!
A 2 #NAME? #WERT! #WERT! #WERT!
A 3 #WERT! #WERT! #WERT! #WERT!
DF #WERT! #WERT! #WERT! #WERT!
XB #WERT! #WERT! #WERT! #WERT!
A 5 #WERT! #WERT! #WERT! #WERT!
CD30L/OX40L #WERT! #WERT! #WERT!
projekt xy #WERT! #WERT! #WERT!
BI 695501 #WERT! #WERT! #WERT!

woran liegt es? wie behebe ich den Fehler?

danke mal wieder

Eure
twobbi
Antwortento top
#9
Hallo,

das ist klar, Zählenwenn kann nicht mit geschlossenen Dateien arbeiten. Da muß dann SUMMENPRODUKT ran:


Code:
WENN(Summenprodukt(('\\x\x\x\x\x\[Labor_I.xlsx]MA A'!$A$5:$A$20=$A4)*1);"X";"")
ungetestet!

Ist aber rechenintensiver.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#10
(06.07.2015, 10:20)BoskoBiati schrieb: Hallo,

das ist klar, Zählenwenn kann nicht mit geschlossenen Dateien arbeiten. Da muß dann SUMMENPRODUKT ran:


Code:
WENN(Summenprodukt(('\\x\x\x\x\x\[Labor_I.xlsx]MA A'!$A$5:$A$20=$A4)*1);"X";"")
ungetestet!

Ist aber rechenintensiver.

Hallo Bosko,

war schon interessant, dasses wieder funktioniert hat, als die andere Datei geöffnet wurde. Wusste nicht, dass es da unterschiede in den Formeln gibt.

Mit Summenprodukt funktioniert es so leider auch nicht. Probiere / teste dann mal weiter.......

@all,

weiss einer wie man so etwas gut Dateiübergreifend machen kann? Undecided


Vielen Dank

Eure twobbi
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste