Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

verschachtelte wenn Formel mit größer gleich
#1
Hallo zusammen,

ich komme bei meiner wenn-größer-gleich-kleiner-Formel nicht weiter, ich hoffe ihr könnt mir helfen.

Wenn der Wert aus Spalte D in einer vorher definierten Preisspanne liegt soll ein vorher bestimmter Aufschlag in eine neue Spalte eingetragen werden, also in meinem Beispiel D2=14 also größer 10 aber kleiner gleich 20, somit sollte der Faktor 1,55 in die Spalte F2 eingetragen werden, es wird allerdings immer 1,43 eingetragen obwohl das die Definition für <=10 ist

Wo ist mein Fehler? Habe bereits die ganze Nacht rumprobiert aber konnte ihn nicht finden.

(Die Formel wird leider zum Schluss abgeschnitten, hier komplett: =WENN(D2<=10;WENN(D2>10<=20;1,55;WENN(D2>20<=30;"1,28";WENN(D2>30<=40;"1,21";WENN(D2>40<=50;"1,16";WENN(D2>50<=60;"1,14";WENN(D2>60<=70;"1,12";WENN(D2>70<=80;"1,10";WENN(D2>80<=90;"1,09";WENN(D2>90<=100;"1,08";WENN(D2>100<=110;"1,08";WENN(D2>110<=120;"1,07";WENN(D2>130<=140;"1,06";WENN(D2>140<=150;"1,06";WENN(D2>150<=160;"1,055";WENN(D2>160<=170;"1,052";WENN(D2>170<=180;"1,049";WENN(D2>180<=190;"1,046";WENN(D2>190<=200;"1,043";WENN(D2>200<=210;"1,041";WENN(D2>210<=220;"1,039";WENN(D2>220<=230;"1,037";WENN(D2>230<=240;"1,036";WENN(D2>240<=250;"1,034";WENN(D2>250<=260;"1,033";WENN(D2>260<=270;"1,032";WENN(D2>270<=280;"1,031";WENN(D2>280<=290;"1,029";WENN(D2>290<=300;"1,029";WENN(D2>300<=400;"1,026";WENN(D2>400<=500;"1,021";WENN(D2>500<=600;"1,017";WENN(D2>600<=700;"1,014";WENN(D2>700<=800;"1,012";WENN(D2>800<=900;"1,010";WENN(D2>900<=1000;"1,009")))))))))))))))))))))))))))))))))));1,43)

Tabelle1

ABCDEFGHIJKLMNOPQ
1ArtikelNr.BezeichnungIhr PreisVK eBaymindest VKAufschlagSA PreisDifferenzVersandMwSteBay VerkaufsgebührVmtBPaypal GebührFF-KostenGewinn 10%VersandkostenGewinn
2STR-065.08/BLLenkergriffe STR8 CNC, transparent / blau6,0814,0011,351,4313,910,093,92,661,26-0,3150,560,50,6080ja
3STR-065.08/BKLenkergriffe STR8 CNC, transparent / schwarz6,081411,351,4313,910,093,92,661,26-0,3150,560,50,6080ja
4STR-065.06/BKLenkergriffe STR8 CNC, schwarz / schwarz6,741412,081,4313,910,093,92,661,26-0,3150,560,50,6740ja
5STR-065.06/BLLenkergriffe STR8 CNC, schwarz /  blau7,061412,431,4313,910,093,92,661,26-0,3150,560,50,7060ja
6STR-065.06/ALLenkergriffe STR8 CNC, schwarz / Aluminium7,061412,431,4313,90,13,92,661,26-0,3150,560,50,7060ja
7STR-065.06/WHLenkergriffe STR8 CNC, schwarz / weiß7,061412,431,4313,90,13,92,661,26-0,3150,560,50,7060ja
8STR-065.06/RELenkergriffe STR8 CNC, schwarz / rot7,061412,431,4313,90,13,92,661,26-0,3150,560,50,7060ja
9MF16.30030Benzintank Motoforce RACING, inkl. Benzinleitung / Benzinhahn, 1.5L10,121,917,931,4321,903,94,1611,971-0,492750,67850,51,010ja
Formeln der Tabelle
ZelleFormel
E2=SUMME(J2;K2;L2;M2;N2;O2;P2;C2)
F2=WENN(D2<=10;WENN(D2>10<=20;1,55;WENN(D2>20<=30;"1,28";WENN(D2>30<=40;"1,21";WENN(D2>40<=50;"1,16";WENN(D2>50<=60;"1,14";WENN(D2>60<=70;"1,12";WENN(D2>70<=80;"1,10";WENN(D2>80<=90;"1,09";WENN(D2>90<=100;"1,08";WENN(D2>100<=110;"1,08";WENN(D2>110<=120;"1,07";WENN(D2>130<=140;"1,06";WENN(D2>140<=150;"1,06";WENN(D2>150<=160;"1,055";WENN(D2>160<=170;"1,052";WENN(D2>170<=180;"1,049";WENN(D2>180<=190;"1,046";WENN(D2>190<=200;"1,043";WENN(D2>200<=210;"1,041";WENN(D2>210<=220;"1,039";WENN(D2>220<=230;"1,037";WENN(D2>230<=240;"1,036";WENN(D2>240<=250;"1,034";WENN(D2>250<=260;"1,033";WENN(D2>260<=270;"1,032";WENN(D2>270<=280;"1,031";WENN(D2>280<=290;"1,029";WENN(D2>290<=300;"1,029";WENN(D2>300<=400;"1,026";WENN(D2>400<=500;"1,021";WENN(D2>500<=600;"1,017";WENN(D2>600<=700;"1,014";WENN(D2>700<=800;"1,012";WENN(D2>800<=900;"1,010";WENN(D2>900<=1000;"1,009")))))))))))))))))))))))))))))))))));1,43)
J2=SUMME(D2)*19/100
K2=SUMME(D2)*9/100
L2=SUMME(K2)/-4*1
M2=SUMME(D2)*1,5/100+0,35
O2=SUMME(C2)*10/100
Q2=WENN(D2>=E2;"ja";"nein")
E3=SUMME(J3;K3;L3;M3;N3;O3;P3;C3)
F3=WENN(D3<=10;"1,81";WENN(D3>10<=20;WENN(D3>20<=30;"1,28";WENN(D3>30<=40;"1,21";WENN(D3>40<=50;"1,16";WENN(D3>50<=60;"1,14";WENN(D3>60<=70;"1,12";WENN(D3>70<=80;"1,10";WENN(D3>80<=90;"1,09";WENN(D3>90<=100;"1,08";WENN(D3>100<=110;"1,08";WENN(D3>110<=120;"1,07";WENN(D3>130<=140;"1,06";WENN(D3>140<=150;"1,06";WENN(D3>150<=160;"1,055";WENN(D3>160<=170;"1,052";WENN(D3>170<=180;"1,049";WENN(D3>180<=190;"1,046";WENN(D3>190<=200;"1,043";WENN(D3>200<=210;"1,041";WENN(D3>210<=220;"1,039";WENN(D3>220<=230;"1,037";WENN(D3>230<=240;"1,036";WENN(D3>240<=250;"1,034";WENN(D3>250<=260;"1,033";WENN(D3>260<=270;"1,032";WENN(D3>270<=280;"1,031";WENN(D3>280<=290;"1,029";WENN(D3>290<=300;"1,029";WENN(D3>300<=400;"1,026";WENN(D3>400<=500;"1,021";WENN(D3>500<=600;"1,017";WENN(D3>600<=700;"1,014";WENN(D3>700<=800;"1,012";WENN(D3>800<=900;"1,010";WENN(D3>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
J3=SUMME(D3)*19/100
K3=SUMME(D3)*9/100
L3=SUMME(K3)/-4*1
M3=SUMME(D3)*1,5/100+0,35
O3=SUMME(C3)*10/100
Q3=WENN(D3>=E3;"ja";"nein")
E4=SUMME(J4;K4;L4;M4;N4;O4;P4;C4)
F4=WENN(D4<=10;"1,81";WENN(D4>10<=20;WENN(D4>20<=30;"1,28";WENN(D4>30<=40;"1,21";WENN(D4>40<=50;"1,16";WENN(D4>50<=60;"1,14";WENN(D4>60<=70;"1,12";WENN(D4>70<=80;"1,10";WENN(D4>80<=90;"1,09";WENN(D4>90<=100;"1,08";WENN(D4>100<=110;"1,08";WENN(D4>110<=120;"1,07";WENN(D4>130<=140;"1,06";WENN(D4>140<=150;"1,06";WENN(D4>150<=160;"1,055";WENN(D4>160<=170;"1,052";WENN(D4>170<=180;"1,049";WENN(D4>180<=190;"1,046";WENN(D4>190<=200;"1,043";WENN(D4>200<=210;"1,041";WENN(D4>210<=220;"1,039";WENN(D4>220<=230;"1,037";WENN(D4>230<=240;"1,036";WENN(D4>240<=250;"1,034";WENN(D4>250<=260;"1,033";WENN(D4>260<=270;"1,032";WENN(D4>270<=280;"1,031";WENN(D4>280<=290;"1,029";WENN(D4>290<=300;"1,029";WENN(D4>300<=400;"1,026";WENN(D4>400<=500;"1,021";WENN(D4>500<=600;"1,017";WENN(D4>600<=700;"1,014";WENN(D4>700<=800;"1,012";WENN(D4>800<=900;"1,010";WENN(D4>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
J4=SUMME(D4)*19/100
K4=SUMME(D4)*9/100
L4=SUMME(K4)/-4*1
M4=SUMME(D4)*1,5/100+0,35
O4=SUMME(C4)*10/100
Q4=WENN(D4>=E4;"ja";"nein")
E5=SUMME(J5;K5;L5;M5;N5;O5;P5;C5)
F5=WENN(D5<=10;"1,81";WENN(D5>10<=20;WENN(D5>20<=30;"1,28";WENN(D5>30<=40;"1,21";WENN(D5>40<=50;"1,16";WENN(D5>50<=60;"1,14";WENN(D5>60<=70;"1,12";WENN(D5>70<=80;"1,10";WENN(D5>80<=90;"1,09";WENN(D5>90<=100;"1,08";WENN(D5>100<=110;"1,08";WENN(D5>110<=120;"1,07";WENN(D5>130<=140;"1,06";WENN(D5>140<=150;"1,06";WENN(D5>150<=160;"1,055";WENN(D5>160<=170;"1,052";WENN(D5>170<=180;"1,049";WENN(D5>180<=190;"1,046";WENN(D5>190<=200;"1,043";WENN(D5>200<=210;"1,041";WENN(D5>210<=220;"1,039";WENN(D5>220<=230;"1,037";WENN(D5>230<=240;"1,036";WENN(D5>240<=250;"1,034";WENN(D5>250<=260;"1,033";WENN(D5>260<=270;"1,032";WENN(D5>270<=280;"1,031";WENN(D5>280<=290;"1,029";WENN(D5>290<=300;"1,029";WENN(D5>300<=400;"1,026";WENN(D5>400<=500;"1,021";WENN(D5>500<=600;"1,017";WENN(D5>600<=700;"1,014";WENN(D5>700<=800;"1,012";WENN(D5>800<=900;"1,010";WENN(D5>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
J5=SUMME(D5)*19/100
K5=SUMME(D5)*9/100
L5=SUMME(K5)/-4*1
M5=SUMME(D5)*1,5/100+0,35
O5=SUMME(C5)*10/100
Q5=WENN(D5>=E5;"ja";"nein")
E6=SUMME(J6;K6;L6;M6;N6;O6;P6;C6)
F6=WENN(D6<=10;"1,81";WENN(D6>10<=20;WENN(D6>20<=30;"1,28";WENN(D6>30<=40;"1,21";WENN(D6>40<=50;"1,16";WENN(D6>50<=60;"1,14";WENN(D6>60<=70;"1,12";WENN(D6>70<=80;"1,10";WENN(D6>80<=90;"1,09";WENN(D6>90<=100;"1,08";WENN(D6>100<=110;"1,08";WENN(D6>110<=120;"1,07";WENN(D6>130<=140;"1,06";WENN(D6>140<=150;"1,06";WENN(D6>150<=160;"1,055";WENN(D6>160<=170;"1,052";WENN(D6>170<=180;"1,049";WENN(D6>180<=190;"1,046";WENN(D6>190<=200;"1,043";WENN(D6>200<=210;"1,041";WENN(D6>210<=220;"1,039";WENN(D6>220<=230;"1,037";WENN(D6>230<=240;"1,036";WENN(D6>240<=250;"1,034";WENN(D6>250<=260;"1,033";WENN(D6>260<=270;"1,032";WENN(D6>270<=280;"1,031";WENN(D6>280<=290;"1,029";WENN(D6>290<=300;"1,029";WENN(D6>300<=400;"1,026";WENN(D6>400<=500;"1,021";WENN(D6>500<=600;"1,017";WENN(D6>600<=700;"1,014";WENN(D6>700<=800;"1,012";WENN(D6>800<=900;"1,010";WENN(D6>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
J6=SUMME(D6)*19/100
K6=SUMME(D6)*9/100
L6=SUMME(K6)/-4*1
M6=SUMME(D6)*1,5/100+0,35
O6=SUMME(C6)*10/100
Q6=WENN(D6>=E6;"ja";"nein")
E7=SUMME(J7;K7;L7;M7;N7;O7;P7;C7)
F7=WENN(D7<=10;"1,81";WENN(D7>10<=20;WENN(D7>20<=30;"1,28";WENN(D7>30<=40;"1,21";WENN(D7>40<=50;"1,16";WENN(D7>50<=60;"1,14";WENN(D7>60<=70;"1,12";WENN(D7>70<=80;"1,10";WENN(D7>80<=90;"1,09";WENN(D7>90<=100;"1,08";WENN(D7>100<=110;"1,08";WENN(D7>110<=120;"1,07";WENN(D7>130<=140;"1,06";WENN(D7>140<=150;"1,06";WENN(D7>150<=160;"1,055";WENN(D7>160<=170;"1,052";WENN(D7>170<=180;"1,049";WENN(D7>180<=190;"1,046";WENN(D7>190<=200;"1,043";WENN(D7>200<=210;"1,041";WENN(D7>210<=220;"1,039";WENN(D7>220<=230;"1,037";WENN(D7>230<=240;"1,036";WENN(D7>240<=250;"1,034";WENN(D7>250<=260;"1,033";WENN(D7>260<=270;"1,032";WENN(D7>270<=280;"1,031";WENN(D7>280<=290;"1,029";WENN(D7>290<=300;"1,029";WENN(D7>300<=400;"1,026";WENN(D7>400<=500;"1,021";WENN(D7>500<=600;"1,017";WENN(D7>600<=700;"1,014";WENN(D7>700<=800;"1,012";WENN(D7>800<=900;"1,010";WENN(D7>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
J7=SUMME(D7)*19/100
K7=SUMME(D7)*9/100
L7=SUMME(K7)/-4*1
M7=SUMME(D7)*1,5/100+0,35
O7=SUMME(C7)*10/100
Q7=WENN(D7>=E7;"ja";"nein")
E8=SUMME(J8;K8;L8;M8;N8;O8;P8;C8)
F8=WENN(D8<=10;"1,81";WENN(D8>10<=20;WENN(D8>20<=30;"1,28";WENN(D8>30<=40;"1,21";WENN(D8>40<=50;"1,16";WENN(D8>50<=60;"1,14";WENN(D8>60<=70;"1,12";WENN(D8>70<=80;"1,10";WENN(D8>80<=90;"1,09";WENN(D8>90<=100;"1,08";WENN(D8>100<=110;"1,08";WENN(D8>110<=120;"1,07";WENN(D8>130<=140;"1,06";WENN(D8>140<=150;"1,06";WENN(D8>150<=160;"1,055";WENN(D8>160<=170;"1,052";WENN(D8>170<=180;"1,049";WENN(D8>180<=190;"1,046";WENN(D8>190<=200;"1,043";WENN(D8>200<=210;"1,041";WENN(D8>210<=220;"1,039";WENN(D8>220<=230;"1,037";WENN(D8>230<=240;"1,036";WENN(D8>240<=250;"1,034";WENN(D8>250<=260;"1,033";WENN(D8>260<=270;"1,032";WENN(D8>270<=280;"1,031";WENN(D8>280<=290;"1,029";WENN(D8>290<=300;"1,029";WENN(D8>300<=400;"1,026";WENN(D8>400<=500;"1,021";WENN(D8>500<=600;"1,017";WENN(D8>600<=700;"1,014";WENN(D8>700<=800;"1,012";WENN(D8>800<=900;"1,010";WENN(D8>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
J8=SUMME(D8)*19/100
K8=SUMME(D8)*9/100
L8=SUMME(K8)/-4*1
M8=SUMME(D8)*1,5/100+0,35
O8=SUMME(C8)*10/100
Q8=WENN(D8>=E8;"ja";"nein")
E9=SUMME(J9;K9;L9;M9;N9;O9;P9;C9)
F9=WENN(D9<=10;"1,81";WENN(D9>10<=20;WENN(D9>20<=30;"1,28";WENN(D9>30<=40;"1,21";WENN(D9>40<=50;"1,16";WENN(D9>50<=60;"1,14";WENN(D9>60<=70;"1,12";WENN(D9>70<=80;"1,10";WENN(D9>80<=90;"1,09";WENN(D9>90<=100;"1,08";WENN(D9>100<=110;"1,08";WENN(D9>110<=120;"1,07";WENN(D9>130<=140;"1,06";WENN(D9>140<=150;"1,06";WENN(D9>150<=160;"1,055";WENN(D9>160<=170;"1,052";WENN(D9>170<=180;"1,049";WENN(D9>180<=190;"1,046";WENN(D9>190<=200;"1,043";WENN(D9>200<=210;"1,041";WENN(D9>210<=220;"1,039";WENN(D9>220<=230;"1,037";WENN(D9>230<=240;"1,036";WENN(D9>240<=250;"1,034";WENN(D9>250<=260;"1,033";WENN(D9>260<=270;"1,032";WENN(D9>270<=280;"1,031";WENN(D9>280<=290;"1,029";WENN(D9>290<=300;"1,029";WENN(D9>300<=400;"1,026";WENN(D9>400<=500;"1,021";WENN(D9>500<=600;"1,017";WENN(D9>600<=700;"1,014";WENN(D9>700<=800;"1,012";WENN(D9>800<=900;"1,010";WENN(D9>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
J9=SUMME(D9)*19/100
K9=SUMME(D9)*9/100
L9=SUMME(K9)/-4*1
M9=SUMME(D9)*1,5/100+0,35
O9=SUMME(C9)*10/100
Q9=WENN(D9>=E9;"ja";"nein")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
to top
#2
Hi!
Da ich jetzt erstmal weg bin:
Dein höchster Wert 1,43 ist falsch zugeordnet!
Mache Dir eine Hilfstabelle, beginnend mit 0 und greife per Sverweis() mit dem 4. Parameter 1 oder WAHR darauf zu:

ABCDE
101,55SucheWert
2101,4381,55
3201,28271,28
4301,21171,43
5401,16331,21
Formeln der Tabelle
ZelleFormel
E2=SVERWEIS(D2;A:B;2;1)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Ralf
to top
#3
Geht auch ohne Hilfstabelle mit einer Verweisformel:

ABCDEFG
101,55SucheWert
2101,4381,551,551,55
3201,28271,281,281,28
4301,21171,431,431,43
5401,16331,211,211,21
Formeln der Tabelle
ZelleFormel
E2=SVERWEIS(D2;A:B;2;1)
F2=VERWEIS(D2;{0.10.20.30.40};{1,55.1,43.1,28.1,21.1,16})
G2=VERWEIS(D2;A:A;B:B)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
to top
#4
Ja das ist fast die Lösung, ein kleines Problem gibt es allerdings dabei die Einteilungen sind wie folgt:

0-10 EUR = 1,82
10,01-20 EUR = 1,43
20,01-30 EUR = 1,28 usw...

Beim sverweis so wie ich ihn jetzt hinterlegt habe nimmt Excel beim Wert 14 EUR den Faktor 1,82 und nicht 1,43...

Hier meine Tabelle, sverweis ist in Spalte "G":

Tabelle1

ABCDEFGHIJKLMNOPQR
1ArtikelNr.BezeichnungIhr PreisVK eBaymindest VKAufschlagSA PreisDifferenzVersandMwSteBay VerkaufsgebührVmtBPaypal GebührFF-KostenGewinn 10%VersandkostenGewinn
2STR-065.08/BLLenkergriffe STR8 CNC, transparent / blau6,0814,0011,351,431,8213,910,093,92,661,26-0,3150,560,50,6080ja
3STR-065.08/BKLenkergriffe STR8 CNC, transparent / schwarz6,0814,0011,351,431,8213,910,093,92,661,26-0,3150,560,50,6080ja
4STR-065.06/BKLenkergriffe STR8 CNC, schwarz / schwarz6,7414,0012,081,431,8213,910,093,92,661,26-0,3150,560,50,6740ja
5STR-065.06/BLLenkergriffe STR8 CNC, schwarz /  blau7,0614,0012,431,431,8213,910,093,92,661,26-0,3150,560,50,7060ja
6STR-065.06/ALLenkergriffe STR8 CNC, schwarz / Aluminium7,0614,0012,431,431,8213,90,13,92,661,26-0,3150,560,50,7060ja
7STR-065.06/WHLenkergriffe STR8 CNC, schwarz / weiß7,0614,0012,431,431,8213,90,13,92,661,26-0,3150,560,50,7060ja
8STR-065.06/RELenkergriffe STR8 CNC, schwarz / rot7,0614,0012,431,431,8213,90,13,92,661,26-0,3150,560,50,7060ja
9MF16.30030Benzintank Motoforce RACING, inkl. Benzinleitung / Benzinhahn, 1.5L10,121,9017,931,431,4321,903,94,1611,971-0,492750,67850,51,010ja
Formeln der Tabelle
ZelleFormel
E2=SUMME(K2;L2;M2;N2;O2;P2;Q2;C2)
F2=WENN(D2<=10;WENN(D2>10<=20;1,55;WENN(D2>20<=30;"1,28";WENN(D2>30<=40;"1,21";WENN(D2>40<=50;"1,16";WENN(D2>50<=60;"1,14";WENN(D2>60<=70;"1,12";WENN(D2>70<=80;"1,10";WENN(D2>80<=90;"1,09";WENN(D2>90<=100;"1,08";WENN(D2>100<=110;"1,08";WENN(D2>110<=120;"1,07";WENN(D2>130<=140;"1,06";WENN(D2>140<=150;"1,06";WENN(D2>150<=160;"1,055";WENN(D2>160<=170;"1,052";WENN(D2>170<=180;"1,049";WENN(D2>180<=190;"1,046";WENN(D2>190<=200;"1,043";WENN(D2>200<=210;"1,041";WENN(D2>210<=220;"1,039";WENN(D2>220<=230;"1,037";WENN(D2>230<=240;"1,036";WENN(D2>240<=250;"1,034";WENN(D2>250<=260;"1,033";WENN(D2>260<=270;"1,032";WENN(D2>270<=280;"1,031";WENN(D2>280<=290;"1,029";WENN(D2>290<=300;"1,029";WENN(D2>300<=400;"1,026";WENN(D2>400<=500;"1,021";WENN(D2>500<=600;"1,017";WENN(D2>600<=700;"1,014";WENN(D2>700<=800;"1,012";WENN(D2>800<=900;"1,010";WENN(D2>900<=1000;"1,009")))))))))))))))))))))))))))))))))));1,43)
G2=SVERWEIS(D2;Tabelle2!A2:B38;2;1)
K2=SUMME(D2)*19/100
L2=SUMME(D2)*9/100
M2=SUMME(L2)/-4*1
N2=SUMME(D2)*1,5/100+0,35
P2=SUMME(C2)*10/100
R2=WENN(D2>=E2;"ja";"nein")
E3=SUMME(K3;L3;M3;N3;O3;P3;Q3;C3)
F3=WENN(D3<=10;"1,81";WENN(D3>10<=20;WENN(D3>20<=30;"1,28";WENN(D3>30<=40;"1,21";WENN(D3>40<=50;"1,16";WENN(D3>50<=60;"1,14";WENN(D3>60<=70;"1,12";WENN(D3>70<=80;"1,10";WENN(D3>80<=90;"1,09";WENN(D3>90<=100;"1,08";WENN(D3>100<=110;"1,08";WENN(D3>110<=120;"1,07";WENN(D3>130<=140;"1,06";WENN(D3>140<=150;"1,06";WENN(D3>150<=160;"1,055";WENN(D3>160<=170;"1,052";WENN(D3>170<=180;"1,049";WENN(D3>180<=190;"1,046";WENN(D3>190<=200;"1,043";WENN(D3>200<=210;"1,041";WENN(D3>210<=220;"1,039";WENN(D3>220<=230;"1,037";WENN(D3>230<=240;"1,036";WENN(D3>240<=250;"1,034";WENN(D3>250<=260;"1,033";WENN(D3>260<=270;"1,032";WENN(D3>270<=280;"1,031";WENN(D3>280<=290;"1,029";WENN(D3>290<=300;"1,029";WENN(D3>300<=400;"1,026";WENN(D3>400<=500;"1,021";WENN(D3>500<=600;"1,017";WENN(D3>600<=700;"1,014";WENN(D3>700<=800;"1,012";WENN(D3>800<=900;"1,010";WENN(D3>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
G3=SVERWEIS(D3;Tabelle2!A2:B39;2;1)
K3=SUMME(D3)*19/100
L3=SUMME(D3)*9/100
M3=SUMME(L3)/-4*1
N3=SUMME(D3)*1,5/100+0,35
P3=SUMME(C3)*10/100
R3=WENN(D3>=E3;"ja";"nein")
E4=SUMME(K4;L4;M4;N4;O4;P4;Q4;C4)
F4=WENN(D4<=10;"1,81";WENN(D4>10<=20;WENN(D4>20<=30;"1,28";WENN(D4>30<=40;"1,21";WENN(D4>40<=50;"1,16";WENN(D4>50<=60;"1,14";WENN(D4>60<=70;"1,12";WENN(D4>70<=80;"1,10";WENN(D4>80<=90;"1,09";WENN(D4>90<=100;"1,08";WENN(D4>100<=110;"1,08";WENN(D4>110<=120;"1,07";WENN(D4>130<=140;"1,06";WENN(D4>140<=150;"1,06";WENN(D4>150<=160;"1,055";WENN(D4>160<=170;"1,052";WENN(D4>170<=180;"1,049";WENN(D4>180<=190;"1,046";WENN(D4>190<=200;"1,043";WENN(D4>200<=210;"1,041";WENN(D4>210<=220;"1,039";WENN(D4>220<=230;"1,037";WENN(D4>230<=240;"1,036";WENN(D4>240<=250;"1,034";WENN(D4>250<=260;"1,033";WENN(D4>260<=270;"1,032";WENN(D4>270<=280;"1,031";WENN(D4>280<=290;"1,029";WENN(D4>290<=300;"1,029";WENN(D4>300<=400;"1,026";WENN(D4>400<=500;"1,021";WENN(D4>500<=600;"1,017";WENN(D4>600<=700;"1,014";WENN(D4>700<=800;"1,012";WENN(D4>800<=900;"1,010";WENN(D4>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
G4=SVERWEIS(D4;Tabelle2!$A$2:B40;2;1)
K4=SUMME(D4)*19/100
L4=SUMME(D4)*9/100
M4=SUMME(L4)/-4*1
N4=SUMME(D4)*1,5/100+0,35
P4=SUMME(C4)*10/100
R4=WENN(D4>=E4;"ja";"nein")
E5=SUMME(K5;L5;M5;N5;O5;P5;Q5;C5)
F5=WENN(D5<=10;"1,81";WENN(D5>10<=20;WENN(D5>20<=30;"1,28";WENN(D5>30<=40;"1,21";WENN(D5>40<=50;"1,16";WENN(D5>50<=60;"1,14";WENN(D5>60<=70;"1,12";WENN(D5>70<=80;"1,10";WENN(D5>80<=90;"1,09";WENN(D5>90<=100;"1,08";WENN(D5>100<=110;"1,08";WENN(D5>110<=120;"1,07";WENN(D5>130<=140;"1,06";WENN(D5>140<=150;"1,06";WENN(D5>150<=160;"1,055";WENN(D5>160<=170;"1,052";WENN(D5>170<=180;"1,049";WENN(D5>180<=190;"1,046";WENN(D5>190<=200;"1,043";WENN(D5>200<=210;"1,041";WENN(D5>210<=220;"1,039";WENN(D5>220<=230;"1,037";WENN(D5>230<=240;"1,036";WENN(D5>240<=250;"1,034";WENN(D5>250<=260;"1,033";WENN(D5>260<=270;"1,032";WENN(D5>270<=280;"1,031";WENN(D5>280<=290;"1,029";WENN(D5>290<=300;"1,029";WENN(D5>300<=400;"1,026";WENN(D5>400<=500;"1,021";WENN(D5>500<=600;"1,017";WENN(D5>600<=700;"1,014";WENN(D5>700<=800;"1,012";WENN(D5>800<=900;"1,010";WENN(D5>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
G5=SVERWEIS(D5;Tabelle2!$A$2:B41;2;1)
K5=SUMME(D5)*19/100
L5=SUMME(D5)*9/100
M5=SUMME(L5)/-4*1
N5=SUMME(D5)*1,5/100+0,35
P5=SUMME(C5)*10/100
R5=WENN(D5>=E5;"ja";"nein")
E6=SUMME(K6;L6;M6;N6;O6;P6;Q6;C6)
F6=WENN(D6<=10;"1,81";WENN(D6>10<=20;WENN(D6>20<=30;"1,28";WENN(D6>30<=40;"1,21";WENN(D6>40<=50;"1,16";WENN(D6>50<=60;"1,14";WENN(D6>60<=70;"1,12";WENN(D6>70<=80;"1,10";WENN(D6>80<=90;"1,09";WENN(D6>90<=100;"1,08";WENN(D6>100<=110;"1,08";WENN(D6>110<=120;"1,07";WENN(D6>130<=140;"1,06";WENN(D6>140<=150;"1,06";WENN(D6>150<=160;"1,055";WENN(D6>160<=170;"1,052";WENN(D6>170<=180;"1,049";WENN(D6>180<=190;"1,046";WENN(D6>190<=200;"1,043";WENN(D6>200<=210;"1,041";WENN(D6>210<=220;"1,039";WENN(D6>220<=230;"1,037";WENN(D6>230<=240;"1,036";WENN(D6>240<=250;"1,034";WENN(D6>250<=260;"1,033";WENN(D6>260<=270;"1,032";WENN(D6>270<=280;"1,031";WENN(D6>280<=290;"1,029";WENN(D6>290<=300;"1,029";WENN(D6>300<=400;"1,026";WENN(D6>400<=500;"1,021";WENN(D6>500<=600;"1,017";WENN(D6>600<=700;"1,014";WENN(D6>700<=800;"1,012";WENN(D6>800<=900;"1,010";WENN(D6>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
G6=SVERWEIS(D6;Tabelle2!$A$2:B42;2;1)
K6=SUMME(D6)*19/100
L6=SUMME(D6)*9/100
M6=SUMME(L6)/-4*1
N6=SUMME(D6)*1,5/100+0,35
P6=SUMME(C6)*10/100
R6=WENN(D6>=E6;"ja";"nein")
E7=SUMME(K7;L7;M7;N7;O7;P7;Q7;C7)
F7=WENN(D7<=10;"1,81";WENN(D7>10<=20;WENN(D7>20<=30;"1,28";WENN(D7>30<=40;"1,21";WENN(D7>40<=50;"1,16";WENN(D7>50<=60;"1,14";WENN(D7>60<=70;"1,12";WENN(D7>70<=80;"1,10";WENN(D7>80<=90;"1,09";WENN(D7>90<=100;"1,08";WENN(D7>100<=110;"1,08";WENN(D7>110<=120;"1,07";WENN(D7>130<=140;"1,06";WENN(D7>140<=150;"1,06";WENN(D7>150<=160;"1,055";WENN(D7>160<=170;"1,052";WENN(D7>170<=180;"1,049";WENN(D7>180<=190;"1,046";WENN(D7>190<=200;"1,043";WENN(D7>200<=210;"1,041";WENN(D7>210<=220;"1,039";WENN(D7>220<=230;"1,037";WENN(D7>230<=240;"1,036";WENN(D7>240<=250;"1,034";WENN(D7>250<=260;"1,033";WENN(D7>260<=270;"1,032";WENN(D7>270<=280;"1,031";WENN(D7>280<=290;"1,029";WENN(D7>290<=300;"1,029";WENN(D7>300<=400;"1,026";WENN(D7>400<=500;"1,021";WENN(D7>500<=600;"1,017";WENN(D7>600<=700;"1,014";WENN(D7>700<=800;"1,012";WENN(D7>800<=900;"1,010";WENN(D7>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
G7=SVERWEIS(D7;Tabelle2!$A$2:B43;2;1)
K7=SUMME(D7)*19/100
L7=SUMME(D7)*9/100
M7=SUMME(L7)/-4*1
N7=SUMME(D7)*1,5/100+0,35
P7=SUMME(C7)*10/100
R7=WENN(D7>=E7;"ja";"nein")
E8=SUMME(K8;L8;M8;N8;O8;P8;Q8;C8)
F8=WENN(D8<=10;"1,81";WENN(D8>10<=20;WENN(D8>20<=30;"1,28";WENN(D8>30<=40;"1,21";WENN(D8>40<=50;"1,16";WENN(D8>50<=60;"1,14";WENN(D8>60<=70;"1,12";WENN(D8>70<=80;"1,10";WENN(D8>80<=90;"1,09";WENN(D8>90<=100;"1,08";WENN(D8>100<=110;"1,08";WENN(D8>110<=120;"1,07";WENN(D8>130<=140;"1,06";WENN(D8>140<=150;"1,06";WENN(D8>150<=160;"1,055";WENN(D8>160<=170;"1,052";WENN(D8>170<=180;"1,049";WENN(D8>180<=190;"1,046";WENN(D8>190<=200;"1,043";WENN(D8>200<=210;"1,041";WENN(D8>210<=220;"1,039";WENN(D8>220<=230;"1,037";WENN(D8>230<=240;"1,036";WENN(D8>240<=250;"1,034";WENN(D8>250<=260;"1,033";WENN(D8>260<=270;"1,032";WENN(D8>270<=280;"1,031";WENN(D8>280<=290;"1,029";WENN(D8>290<=300;"1,029";WENN(D8>300<=400;"1,026";WENN(D8>400<=500;"1,021";WENN(D8>500<=600;"1,017";WENN(D8>600<=700;"1,014";WENN(D8>700<=800;"1,012";WENN(D8>800<=900;"1,010";WENN(D8>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
G8=SVERWEIS(D8;Tabelle2!$A$2:B44;2;1)
K8=SUMME(D8)*19/100
L8=SUMME(D8)*9/100
M8=SUMME(L8)/-4*1
N8=SUMME(D8)*1,5/100+0,35
P8=SUMME(C8)*10/100
R8=WENN(D8>=E8;"ja";"nein")
E9=SUMME(K9;L9;M9;N9;O9;P9;Q9;C9)
F9=WENN(D9<=10;"1,81";WENN(D9>10<=20;WENN(D9>20<=30;"1,28";WENN(D9>30<=40;"1,21";WENN(D9>40<=50;"1,16";WENN(D9>50<=60;"1,14";WENN(D9>60<=70;"1,12";WENN(D9>70<=80;"1,10";WENN(D9>80<=90;"1,09";WENN(D9>90<=100;"1,08";WENN(D9>100<=110;"1,08";WENN(D9>110<=120;"1,07";WENN(D9>130<=140;"1,06";WENN(D9>140<=150;"1,06";WENN(D9>150<=160;"1,055";WENN(D9>160<=170;"1,052";WENN(D9>170<=180;"1,049";WENN(D9>180<=190;"1,046";WENN(D9>190<=200;"1,043";WENN(D9>200<=210;"1,041";WENN(D9>210<=220;"1,039";WENN(D9>220<=230;"1,037";WENN(D9>230<=240;"1,036";WENN(D9>240<=250;"1,034";WENN(D9>250<=260;"1,033";WENN(D9>260<=270;"1,032";WENN(D9>270<=280;"1,031";WENN(D9>280<=290;"1,029";WENN(D9>290<=300;"1,029";WENN(D9>300<=400;"1,026";WENN(D9>400<=500;"1,021";WENN(D9>500<=600;"1,017";WENN(D9>600<=700;"1,014";WENN(D9>700<=800;"1,012";WENN(D9>800<=900;"1,010";WENN(D9>900<=1000;"1,009";0))))))))))))))))))))))))))))))))));1,43))
G9=SVERWEIS(D9;Tabelle2!$A$2:B45;2;1)
K9=SUMME(D9)*19/100
L9=SUMME(D9)*9/100
M9=SUMME(L9)/-4*1
N9=SUMME(D9)*1,5/100+0,35
P9=SUMME(C9)*10/100
R9=WENN(D9>=E9;"ja";"nein")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Hilftabelle

Tabelle2

AB
101,81628521
2101,81628521
3201,42598077
4301,28171867
5401,20516668
6501,16395259
7601,13738166
8701,11685926
9801,10267017
10901,09176963
111001,0819354
121101,07503126
131201,06868835
141301,06350742
151401,05878595
161501,05509304
171601,05152731
181701,04856518
191801,04572405
201901,04342147
212001,04104132
222101,03933849
232201,03747215
242301,03584011
252401,03390601
262501,03292647
272601,03162422
282701,03053354
292801,02931106
302901,02864694
313001,02606712
324001,02100064
335001,01699491
346001,01377929
357001,01178767
368001,01035513
379001,00904862
3810001,00835537

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
to top
#5
(20.02.2016, 22:50)NRG schrieb: ... ein kleines Problem gibt es allerdings dabei ...

Hallo, ich das ist gelinde ausgedrückt...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hallo,

Du solltest vielleicht mal intensiver mit Excel befassen!

Falsche Syntax:


Code:
WENN(D5>10<=20

Außerdem wenn etwas nicht <10 ist, dann prüft Excel, ob es kleiner als die nächste Angabe ist, also reicht


Code:
Wenn(D5<20


umständlich:

Code:
=SUMME(K2;L2;M2;N2;O2;P2;Q2;C2)


besser:


Code:
=SUMME(K2:Q2;C2)

Offensichtlich sind die Zahlen in Tabelle2 Spalte A Texte, deswegen ergibt der Sverweis falsche Werte!

Außerdem sind die Werte in B mit einer Formel ermittelt, also könnte man auch diese Formel einsetzen um den Faktor zu erhalten!

Deine Wenn-Formel ergibt auch nur Texte als Ergebnis! Alles was in "" steht sind für Excel Texte und keine Zahlen!


Zitat:K2
=SUMME(D2)*19/100
L2
=SUMME(D2)*9/100
M2
=SUMME(L2)/-4*1
N2
=SUMME(D2)*1,5/100+0,35
P2
=SUMME(C2)*10/100

Summe kann man hier komplett weglassen, Es ist unsinnig aus einer einzelnen Zahl eine Summe zu bilden!
Außerdem ist Excel nicht doof, es genügt z.B. sowas:


Code:
=D2*19%

in M2 kannst Du das *1 auch weglassen!


Arbeite Dich mal hier durch, bevor Du mit Excel weitermachst:

http://online-excel.de/
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste