Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

mehrfach wenn und Pulldown
#1
Hallo zusammen,

habe wieder ein kleines Problem.
in der Tabelle siehe Anhang.

solte folgendes geschehen.Wenn der Wert in der Zelle Tabelle1 "B5" aus dem Pulldown Menue gewählt wird, sollte auf der Tabelle2 in Zelle "C5" der Wert der in Tabelle3 in der Zelle "G4 oder G5" steht eingestzt werden je nachdem welcher Wert in Tabelle1 gewählt wird und wenn in Tabelle1 in Zelle "B5" nichts steht soll 0,00 bleiben.

Mit dem Pulldown habe Ich es garnicht hinbekommen und  auf der Tabelle1 in Zelle"B7" habe ich es ohne Pulldown versucht , das geht solange gut bis ich die 2 Abfrage einfüge dann kommen die Fehler.

ist für die Profis unter euch betsimmt ein Klacks.


Angehängte Dateien
.xlsx   WLG.xlsx (Größe: 9,61 KB / Downloads: 4)
to top
#2
Hallo,

mein Vorschlag:

Code:
=WENNFEHLER(WENN(Tabelle1!B5<>"";SVERWEIS(RECHTS(Tabelle1!$B$5;3);Tabelle3!$E$4:$G$6;3;0);0);0)

Gruß
Aloys
Win 7, Office 2010
[-] Folgende(r) 1 Benutzer sagt Danke an aloys78 für diesen Beitrag:
  • wavemaster
to top
#3
(19.04.2015, 08:29)aloys78 schrieb: Hallo,

mein Vorschlag:



Code:
=WENNFEHLER(WENN(Tabelle1!B5<>"";SVERWEIS(RECHTS(Tabelle1!$B$5;3);Tabelle3!$E$4:$G$6;3;0);0);0)

Gruß
Aloys

Hallo Aloys,

Formel klappt Prima,

wenn Ich die Formel an meine Tabelle anpasse nimmt er die Preise nicht an.

Habe die Tabelle auf Tabellenblatt 3 mit den Orginalzellen in rot eingefügt die Zahl in Spalte M sollte gewählt werden.

was heißt bzw bewirkt die Zahl 3.

Bin kein Excel Profi.


Angehängte Dateien
.xlsx   WLG01.xlsx (Größe: 10,22 KB / Downloads: 5)
to top
#4
Danke

habe den Fehler gefunden.

In der Tabelle 3 darf in der Spalte E nur Zahlen stehen und keine Buchstaben.
to top
#5
Hi,

warum so umständlich?

Gib diese Formel in deinem Tabellenblatt2 ein:


Code:
=WENNFEHLER(WENN(Tabelle1!B5<>"";SVERWEIS(Tabelle1!$B$5;Tabelle3!$E$6:$K$7;7;0);0);0)
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste