Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Die Updates sind abgeschlossen. Bitte meldet eventuelle Bugs und Auffälligkeiten im entsprechenden Forum.
Sollte das Loginfenster nicht sichtbar sein, ist es unten links. Entweder Ihr loggt Euch dort ein oder löscht den Browsercache und versucht es noch einmal.


mehrere Mittelwerte für eine Spalte mit unterschiedlichen Abständen
#1
Photo 
Hallo Zusammen,

ich versuche mal mein Problem so gut es geht zu schildern.
Ich habe Sekundenwerte oder auch andere Werte (z.B. 7 Sekundenabschnitte) über einen längeren Zeitraum (Monate).
Die Werte gehören zu einer PV Anlage und sind von der Sonneneinstrahlung abhängig, d.h. in der Nacht werden keine Werte aufgenommen, sondern erst wenn es zu einer Einstrahlung auf die PV-Anlage kommt. Das hat zur Folge, dass die Anzahl der Werte einer Stunde nicht gleich sind, da die Start und Endpunkte unterschiedlich sind.
Ich möchte nun aus den Sekundenwerten Stundenmittelwerte erzeugen. Ich habe mit einer Funktion die Stundenübergänge mir markieren lassen, so dass ich die Werte innerhalb einer Stunde erhalte.
Im der Datei zu sehen sind die Stundenübergänge ("x"). Nun möchte ich die Mittelwerte der jeweiligen Stunden ermitteln. Das Probelm hierbei ist, das die Abstände nicht gleich sind und ich mit meinem Wissensstand für jede Stunde einzeln den Mittelwert ausrechnen muss, da mit der Funktion des Doppelklicks auf das schwarze Kreuz unten rechts einer Zelle nicht funktioniert.
Daher nun meine Frage, ob es eine Funktion gibt, die die dargestellten Zeilen als Start und Endpunkt für die Mittelwertberechnung nimmt.
Ich möchte die Mittelwerte wie folgt ermitteln:
=mittelwert(C2:C3)
=mittelwert(C3:C554)
=mittelwert(C554:C1670) und so weiter.
Aber wie oben schon gesagt, lässt sich das nicht für die restliche Spalte mit der Doppelklick auf das schwarze Kreuz Funktion vereinfachen, da die Abstände variieren Sad
Gibt es dafür eine bessere Lösung als mit Hand? Die datei ist auch nochmal im Anhang hochgeladen.

Vielen Dank im Voraus.

zeileEINS


Angehängte Dateien
.xlsx   PV1.xlsx (Größe: 637,96 KB / Downloads: 6)
Antwortento top
#2
Hi,

ich sehe das so:

 ABCDEFGH
1IdTimeStampLeistung WStunden    
2101.01.2017 00:00:1400001.01.2017 00:0000
3201.01.2017 07:26:36-107 01.01.2017 01:00  
4301.01.2017 07:26:4007 01.01.2017 02:00  
5401.01.2017 07:28:00-107 01.01.2017 03:00  
6501.01.2017 07:28:0107 01.01.2017 04:00  
7601.01.2017 07:28:47-107 01.01.2017 05:00  
8701.01.2017 07:28:5107 01.01.2017 06:00  
9801.01.2017 07:29:10107 01.01.2017 07:0010,290381110,2903811
10901.01.2017 07:29:11-107 01.01.2017 08:0099,659498299,6594982
111001.01.2017 07:29:13-207 01.01.2017 09:0048,510067148,5100671
55054901.01.2017 07:59:20207 23.01.2017 20:00  
55155001.01.2017 07:59:23307 23.01.2017 21:00  
55255101.01.2017 07:59:44207 23.01.2017 22:00  
55355201.01.2017 07:59:4730710,290381123.01.2017 23:00  

ZelleFormel
E2=WENN(STUNDE(B3)<>STUNDE(B2);WENNFEHLER(SUMMEWENNS(C:C;B:B;">="&KÜRZEN(B2;)+STUNDE(B2)/24;B:B;"<"&KÜRZEN(B2;)+STUNDE(B2)/24+1/24)/ZÄHLENWENNS(B:B;">="&KÜRZEN(B2;)+STUNDE(B2)/24;B:B;"<"&KÜRZEN(B2;)+STUNDE(B2)/24+1/24);"");"")
G2=WENN(STUNDE(B3)<>STUNDE(B2);WENNFEHLER(SUMMEWENNS(C:C;B:B;">="&F2;B:B;"<"&F2+1/24)/ZÄHLENWENNS(B:B;">="&F2;B:B;"<"&F2+1/24);"");"")
H2=WENNFEHLER(MITTELWERTWENNS(C:C;B:B;">="&F2;B:B;"<"&F2+1/24);"")
E3=WENN(STUNDE(B4)<>STUNDE(B3);WENNFEHLER(SUMMEWENNS(C:C;B:B;">="&KÜRZEN(B3;)+STUNDE(B3)/24;B:B;"<"&KÜRZEN(B3;)+STUNDE(B3)/24+1/24)/ZÄHLENWENNS(B:B;">="&KÜRZEN(B3;)+STUNDE(B3)/24;B:B;"<"&KÜRZEN(B3;)+STUNDE(B3)/24+1/24);"");"")
F3=$F$2+ZEILE(A1)/24
G3=WENNFEHLER(SUMMEWENNS(C:C;B:B;">="&F3;B:B;"<"&F3+1/24)/ZÄHLENWENNS(B:B;">="&F3;B:B;"<"&F3+1/24);"")
H3=WENNFEHLER(MITTELWERTWENNS(C:C;B:B;">="&F3;B:B;"<"&F3+1/24);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#3
[...] ob es eine Funktion gibt, die die dargestellten Zeilen als Start und Endpunkt für die Mittelwertberechnung nimmt. Ich möchte die Mittelwerte wie folgt ermitteln:
=mittelwert(C2:C3)
=mittelwert(C3:C554)
=mittelwert(C554:C1670)
und so weiter.
ist methodisch VERBOTEN! Denn die Übergänge würden doppelt gewichtet.

=mittelwert(C2:C2)
=mittelwert(C3:C553)
=mittelwert(C554:C1669)
ist statistisch korrekt. Mit dieser Erkenntnis gehst Du wie folgt vor:

Pivot-Tabelle auf A1 nach H1 hin erstellen mit
  • Bericht: nix
  • Spalten: nix
  • Zeilen: Timestamp
  • Werte: Leistung (Aggregation Mittelwert wählen, nicht Anzahl oder Summe)
  • Timestamp gruppieren (mit Rechtsklick auf die Zeileneinträge, nicht -überschrift) nach ✔ Tag und ✔ Stunde (ein neues Feld Zeilen: "Tage" entsteht dadurch automatisch)
@Bosko: Ich hätte die Lösung in einer eigenen Tabelle dargestellt, so wie Pivot es auch darstellt (Pivot hat es mir abgenommen). Denn willst Du wirklich mehrfach 19.000 mal ZÄHLENWENNS(B:B;...) und andere Funktionen rechnen? Das geht ja Richtung 1 Billion.
Antwortento top
#4
Hallo,

zuerst eine Hilfsspalte mit "=Text(B2;"TT.MM.JJJJ h"), dann eine Pivot-Tabelle mit der Hilfsspalte für die Zeilen und der Leistung bei Werte, Einstellung "Mittelwert".

Es ist wieder einmal ein Beispiel, dass "das Atomdorf" nicht nur Europa zerstören wird (kein Endlager, in nächsten Krieg/Bürgerkrieg werden alle atomaren "Abfälle" freigesetzt), sondern auch noch unentgeltlich Hilfe erwartet.

kein weiterer Kommentar
Antwortento top
#5
Vielen Dank für die schnellen Antworten!!
Ich werde mein Glück mal nach der Arbeit probieren.
Antwortento top
#6
Hallo lupo,

ich habe drei Möglichkeiten aufgezeigt. Wie die auf die Performance wirken habe ich nicht getestet.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#7
Hallo z...,

ich habe zwei Bemerkungen zum Verfahren:

1) Zeitwichtung

Zitat:Ich habe Sekundenwerte oder auch andere Werte (z.B. 7 Sekundenabschnitte)
...
Ich möchte die Mittelwerte wie folgt ermitteln:
=mittelwert(C2:C3)
=mittelwert(C3:C554)
=mittelwert(C554:C1670) und so weiter.
Das ist meines Erachtens das falsche Verfahren. Da sich der Messwert bei jedem Zeitstempel ändert sieht es für mich so aus, als ob der Messwertgeber nur die Zeitpunkte der Messwertänderungen protokolliert. Der jeweilige Messwert muss also noch mit dem Zeitraum für den er gültig ist gewichtet werden.
In deiner Art der Berechnung hat ein Wert, der für eine Sekunde gemessen wurde die gleiche Wichtung wie ein Wert der für 20 Sekunden oder sogar (am 2. Tag 9Uhr 19) für mehr als 7 Minuten gültig war.

Bei der Zeitwichtung  sind zwei Besonderheiten zu berücksichtigen:
a) Gültigkeit eines Messwertes über den Stundenwechsel
b) Zwei Messwertaufzeichnungen in der gleichen Sekunde (hier hilft es vielleicht, wenn man auch die Millisekunden aufzeichnet).

2) Ausreisser/Messfehler
Zumindest der Wert 180 am ersten Tag um 7Uhr 30 sieht für mich nicht realistisch aus. Da solltest du dir Gedanken machen wie sich diese Messfehler eliminieren lassen. Vielleicht relativieren sich die Einflüsse dieser Messfehler, wenn man die Millisekunden aufzeichnet und über die Zeit wichtet.


ps. Zuerst hatte mich gewundert, dass die Sonne bei euch rechtzeitig vor Feierabend untergeht (~15:15).
Aber an den sonnenarmen Tagen Anfang Januar war es im Osten Deutschlands wohl so.
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste