Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

leere zellen im monat nach name
#1
Hallo

Habe ne Tabelle mit 2 Laschen
Änderungen werden in der Meldungen gemacht und in der Auswertung die Berechnung.

Inhalt Meldung
Spalten
Name und Tage
Name = Vor und Nachname
Tage = Leer oder Buchstabe

Inhalt Auswertung
Spalten
Namen und Monat
Name = Vor und Nachname (nicht alle aus der Meldung)
Monat = anzahl der Leerzellen im Monat abhängig vom Namen...

wie bekomme ich das hin?

Danke

.xlsx   TEST.xlsx (Größe: 92,01 KB / Downloads: 8)
to top
#2
Hi,

als erstes mal eine blöde Frage: wieso füllst du alle Spalten bereits mit Daten? Ich denke nicht, dass die Tabelle bereits bis ins Jahr 2059 reichen soll.

Dann würde ich hier mit Hilfsspalten arbeiten, die du einfach ausblendest.

1. In der Tabelle "Meldung" direkt hinter deiner Namensspalte den Namen und Vornamen zusammenschreiben. Formel:

Code:
=C3&D3

und runterziehen bzw. Doppelklick am Ausfüllkästchen.

2. Nach jedem Monat eine Hilfsspalte, in der du die leeren Zellen zählst. Formel:

Code:
=ANZAHLLEEREZELLEN(BX3:CT3)

ebenfalls soweit runterziehen wie nötig.

3. In dieser Spalte in Zeile 1 die Formel

Code:
=SPALTE()-4

Diese dient lediglich dazu, dass du für den später folgenden SVERWEIS den Spaltenindex hast.

Nun im Tabellenblatt "Auswertung" ebenfalls nach der Namensspalte eine Hilfsspalte mit zusamengefügten Vor- und Nachnamen einfügen und die Spalte ausblenden. In den Monatspalten gibst du dann die Formel

Code:
=SVERWEIS(D7;Meldung!E3:CU8;Meldung!$CU$1)

ein.

Den Spaltenindex musst du natürlich für jeden Monat anpassen. Im Anhang findest du eine Testmappe für Dezember



.xlsx   delenn-Testmappe.xlsx (Größe: 348,43 KB / Downloads: 4)
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste