Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

dynamisches Diagramm x-Achse stimmt nicht
#1
Hallo Leute,
hab wieder einmal ein Problem!!
Habe ein dynamischs Diagramm erstellt das so funktioniert wie ich will außer dass ich es nicht schaffe dass die x-Achse richtig skaliert bzw übernommen wird!!
die x Werte sind Meter angaben die aufeinanderfolgend sein können aber auch Sprünge machen können, jetzt ist das Problem dass er im Diagramm nicht die x Werte nimmt sondern einfach von 1 beginnend nummeriert (1, 2, 3, 4 usw)
hab schnell eine Bsp Datei gebastelt die vom Aufbau gleich ist und wo ihr das Problem sehen könnt

Wäre super wenn mir wär helfen könnte.. bin am verzweifeln20

lg phil


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 35,9 KB / Downloads: 10)
to top
#2
Hallo Phil, ich kann dem Ganzen so noch nicht ganz folgen... ... Aber, was ich mit Gewissheit sagen kann Deine Formeln für die BereichsNamen sind - sagen wir mal so - unglücklich gewählt. a) Du benutzt BEREICH.VERSCHIEBEN() und b) ANZAHL2(), was hier nicht sinnvoll ist, weil Deine leeren Zellen nicht leer sind... ... schau mal hier..:

Arbeitsblatt mit dem Namen 'Tabelle2'
 A
3499
4201

ZelleFormel
A3=ANZAHL2(B:B)
A4=VERGLEICH(-9^9;B:B;-1)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo Jockel,
danke für die Antwort!
Ok ich seh schon dass Anzahl2() nicht sinnvoll ist weil die Zellen nicht leer sind, aber ist es möglich ein Zelle mit Formel für excel leer erscheinen zu lassen? 0, "" , #NV geht ja nicht.....

wenn ich das ganze jetzt ohne einem dynamischen Diagramm versuche, hab ich wieder das gleiche Problem, dass er bei der x Achse nicht die wahren Werte nimmt sondern einfach durchnummeriert!!!
keine Ahnung wie ich das ändern soll

Das ist jetzt mein Datenreihe, wenn nicht dynamisch
Code:
=DATENREIHE("ohne dyn";Tabelle2!$B$3:$B$500;Tabelle2!$C$3:$C$500;2)

ich brauche bis zur Zeile500 "Leerzeilen mit Formeln", weil diese bis dorthin voll werden....

der Punkt 100/161 ist in diesem Diagramm jetzt 100/2860...

ich hoff es war jetzt verständlicher was mein Problem ist

lg
to top
#4
Hallo, ich habe mal ff. genommen

für xAchse =Tabelle2!$B$3:INDEX(Tabelle2!$B:$B;VERGLEICH(-9^9;Tabelle2!$B:$B;-1))
für yAchse =Tabelle2!$C$3:INDEX(Tabelle2!$C:$C;VERGLEICH(-9^9;Tabelle2!$B:$B;-1))

und mein Diagramm sieht dann so aus..:

?mage
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • turbophil
to top
#5
Vielen vielen Dank Jockel!!!! Du hast mir den Tag aber sowas von gerettet
Genau so hab ichs mir vorgestellt!!!! Funktioniert einwandfrei!!!

Danke
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste