Das letzte Clever-Excel-Forum.de - Treffen
fand vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt.

bedingte Formatierung
#1
Hallo,

habe ein kleines Problem.
Wer kann helfen?
Ich habe eine Tabelle mit mehreren Spalten.In der Spalte C wird ein Feld über bedingte Formatierung"wenn man rot schreibt,
rot mit weißer schrift ausgefüllt.
grün mit schwarzer Schrift usw.

Nun soll in Spalte B bei rot-rt bei grün-gr blau-bl usw.eingetragen werden.
Geht so etwas?


Huh Bernd
to top
#2
Hallo,

du könntest die Bedingung in der Bedingten Formatierung für die Wenn-Funktion verwenden.

Als Beispiel: Du hast in der Bedingten Formatierung stehen, dass die Schrift rot werden soll wenn der Wert der Zelle größer 10 ist.

In der Wenn-Formel kannst du dann darauf Bezug nehmen: =Wenn(C1>10;"rot";Wenn(C1>5;"grün";"blau")

Wenn du mit diesem Hinweis nicht weiterkommst dann wäre es interessant zu erfahren welche Bedingungen du in der der Bedingten Formatierung verwendest du wie viele unterschiedliche du hast, zumindest lässt das usw. darauf schließen, dass es nicht bei rt, gr und bl bleibt.
Gruß
Peter
to top
#3
Hi Bernd,

wenn ich dich richtig verstanden habe, dann schreibst du in B1:

=WENN(C1="ROT";"rt";"")
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#4
Hallo,

die Variante von Günter geht mit rot.
Wie muss aber die wenn Funktion aussehen,wenn ich die Möglichkeit habe 7 Farben einzutragen,
rot;grün;gelb;blau;braun;grau;weiß



Bernd
to top
#5
Hallo,

bei 7-Wenn-Verschachtelungen könnte die Formel so aussehen:

=WENN(C1="rot";"rt";WENN(C1="Grün";"gr";WENN(C1="Gelb";"ge";WENN(C1="Blau";"bl";WENN(C1="Braun";"br";WENN(C1="Grau";"gr";WENN(C1="weiß";"we";"")))))))

Du könntest aber auch einen Matrix aufbauen, z.B. in E1 bis E7 die Farben und in D1 bis D7 die Abkürzungen und dann einen Sverweis verwenden:

=Sverweis(C1;E:D;2;0)

Das hätte den Vorteil, dass du, falls notwendig weitere ergänzende Farben und Beschreibungen problemlos hinzufügen kannst.
Gruß
Peter
to top
#6
Danke Peter,

klappt bestens.
Habe die wenn Funktion genutzt.
Bei der Matrix habe ich so meine Probleme.

Schönes WE

Bernd
to top
#7
Hallo,

die Variante mit Sverweis würde so aussehen:

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDE
1AAntonAntonA
2A BertaB
3  CäsarC
4  DoraD
5    

ZelleFormel
B1=SVERWEIS(C1;D:E;2;0)
B2=VERWEIS({"Anton"."Berta"."Cäsar"."Dora"};{"A"."B"."C"."D"})
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Und wenn du jetzt in D5 und E5 einen weiteren Namen/Farbe eingibst dann wird das sofort in der Formel berücksichtigt - und die Formel ist übersichtlicher.

Man könnte auch auf die Matrix verzichten und z.B. wie in B2 mit einer Funktion wie Verweis() arbeiten - nur so als Hinweis.
Gruß
Peter
to top
#8
Danke

auch das habe ich jetzt verstanden.Nun habe ich alle Möglichkeiten.

Nochmals ein schönes WE

Bernd
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste