Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Am Sonntag (23.09.) wird das Forum zwischen 06:00 Uhr und 09:00 Uhr kurzzeitig nicht erreichbar sein. Wir stellen auf SSL / HTTPS um.


Zwei Datenblätter mit Sverweis zusammenführen
#1
Hallo Zusammen,

wir haben folgendes Problem: wir haben eine Exceltabelle vorliegen wo in zwei Datenblättern Artikelnummern, Artikel und die dazugehörigen Preise vorhanden sind. Zudem ist noch zu sagen, dass in jedem Datenblatt auch die gleichen Artikel vorkommen können, nur mit anderen Preisen.

Wir möchten Excel nun sagen, dass es aus beiden Blättern die Artikel miteinander vergleicht und uns letzendlich den Artikel anzeigt, welcher den geringeren Wert hat.

Sinn und Zweck hierbei ist eine Vereinbarung für unseren Kunden. Er soll ein Schreiben erhalten wo die Preise der Artikel stehen. Die Preise werden einmal aus unseren Standardkonditionen gezogen und einmal aus dem Debitor selber. Der Kunde soll nur den Preis angezeigt bekommen, welcher geringer ist.

Lieben Dank für eure Hilfe.
Antwortento top
#2
Hallo,

nicht sonderlich elegant, aber für eine einmalige Aktion sollte es reichen.

Anschließend im Tabellenblatt Tabelle2 die Spalte C markieren und über Strg-C Inhalte Einfügen - Werte die Formeln in Werte umwandeln. Danach die Spalte B löschen.

Wenn das nicht deinen Vorstellungen entspricht dann wäre eine anonymisierte, abgespeckte Beispielsdatei, aus welcher der Tabellenaufbau der beiden Blätter ersichtlich ist, sinnvoll.


Angehängte Dateien
.xls   2457.xls (Größe: 26 KB / Downloads: 9)
Gruß
Peter
Antwortento top
#3
Hallo, erst einmal lieben Dank dafür.

Nur besteht momentan noch das Problem, dass wenn Artikel D in einer der beiden Tabellen nicht existiert, dass der Preis von dem Datenblatt angezeigt wird  wo der Artikel existiert.

Lieben Dank schonmal!
Antwortento top
#4
Hallo,

ich bin aufgrund dieses Satzes
Zitat: Der Kunde soll nur den Preis angezeigt bekommen, welcher geringer ist.
davon ausgegangen, dass für jeden Artikel ein Preis angezeigt werden soll.

Aus dem Posting habe ich nicht herausgelesen, dass es entscheidend ist, dass der Artikel auf beiden Tabellenblättern vorkommt.

Was soll angezeigt werden wenn der Artikel nur in einem Tabellenblatt existiert. Nichts?
Gruß
Peter
Antwortento top
#5
Hi,

Zitat:Nur besteht momentan noch das Problem, dass wenn Artikel D in einer der beiden Tabellen nicht existiert, dass der Preis von dem Datenblatt angezeigt wird  wo der Artikel existiert.

was genau meinst du damit? Bei mir kommt #NV. Was soll denn angezeigt werden. Gib uns mal ein Beispiel.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#6
Hallo,

wenn in dem einen Datenblatt der gleiche Artikel nicht existiert soll aber der Preis des Artikels auf dem Datenblatt angezeigt werden, wo dieser existiert.

Zum Beispiel:

Tabelle1: Artikel A             Preis 5
                        B                      6
                        C                      7


Tabelle2: Artikel A             Preis 4
                        B                      5
                        C                      4
                        D                      1

Da Artikel D nicht in Tabelle2 existiert, soll nun nur der Preis von D aus Tabelle 2 angezeigt werden.

Danke schon einmal im Voraus!
Antwortento top
#7
Hallo,

dann probier es mal mit der folgenden Formel in C1:

=WENN(ISTNV(SVERWEIS(A1;Tabelle1!A:B;2;0));B1;MIN(B1;(SVERWEIS(A1;Tabelle1!A:B;2;0))))

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
1a5
2b6
3c3
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

bzw. Tabelle2:

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABC
1a44
2b55
3c43
4d11

ZelleFormel
C1=WENN(ISTNV(SVERWEIS(A1;Tabelle1!A:B;2;0));B1;MIN(B1;(SVERWEIS(A1;Tabelle1!A:B;2;0))))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
Antwortento top
#8
Super danke Peter!

Kann man deine erste und die jetztige Formel auch miteinander kombinieren?
Antwortento top
#9
Hallo,

die erste Formel ist m.E. gar nicht mehr notwendig - die zuletzt gepostete Formel sollte ausreichen.
Gruß
Peter
Antwortento top
#10
Hallo Peter,

du hast uns sehr geholfen. Dankeschön!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste