Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zusammenfügen von 2 Tabellen mit Verschiedenen Werten für dasselbe Produkt
#1
Hallo zusammen,

ich habe zwei Tabellen, die Werte bezüglich derselben produkte enthalten. Da jedoch nicht jedes Produkt einen Wert in der zweiten Tabelle hat, ist die Zuordnung nicht so einfach(für mich). Gibt es eine Formel mit der ich zu z.B. DE 304040144991 die Werte aus der zweiten Tabelle DE 304040144991, 7, 9, 6,5 etc. zuordnen kann? Ich kann mich an der ersten Nummer orientieren.

Ihr würdet mir sehr weiterhelfen.

MfG,

deschi9400
Antwortento top
#2
Hallo,

könntest Du einen Ausschnitt deiner Tabellen hier posten? Wie das geht findest du hier.
Gruß Stefan
Win 7 / Office 2007
Antwortento top
#3
Hi,

(26.05.2016, 09:15)deschi9400 schrieb: Gibt es eine Formel mit der ich zu z.B. DE 304040144991 die Werte aus der zweiten Tabelle DE 304040144991, 7, 9, 6,5 etc. zuordnen kann? Ich kann mich an der ersten Nummer orientieren.

Was heißt "zuordnen"?
Soll statt der letzten 1 der IBAN nun die 7 oder die 9 oder die 6 oder die 5 stehen oder sollen diese 4 Ziffern in weiteren Spalten stehen oder angehängt werden? Ohne eine Beispieldatei /-Ausschnitt mit Ist-Soll-Anzeige kann keine genaue Hilfe gegeben werden.

Darum nur ungenau:
Schaue Dir mal die Funktion SVERWEIS() an. beachte/benutze den 4. Parameter.
Antwortento top
#4
Hallo Ralf,

(26.05.2016, 09:24)Rabe schrieb: Soll statt der letzten 1 der IBAN nun die 7 oder die 9 oder die 6 oder die 5 stehen oder sollen diese 4 Ziffern in weiteren Spalten stehen oder angehängt werden?

Für eine IBAN ist die Zahl zu kurz.
Gruß Stefan
Win 7 / Office 2007
Antwortento top
#5
Hi Stefan,

(26.05.2016, 09:26)Steffl schrieb: Für eine IBAN ist die Zahl zu kurz.

stimmt, drum dachte ich, dass die Zahlen vielleicht angehängt werden sollen.
Antwortento top
#6
Hallo zusammen,

danke für die schnelle Antwort.

Es sind keine IBAN, es sind Lebensnummern von Pferden, so wie die Steuernummer bei uns.

Ich habe die restlich Tabelle mal ausgeblendet. Rechts stehen Lebensnummern mit Noten, diese Lebensnummer stehen auch schon links in der Tabelle. Ich möchte sie gerne an die Tabelle und die passende LN anfügen, um dann die zweite Lebensnummer entfernen zu können und eine einheitliche und filterbare Tabelle daraus zu machen.

Ich hoffe es ist etwas verständlicher.

LG,
deschi9400


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#7
Hallo,

wie schon Ralf geschrieben hat, verwende SVERWEIS. Den Tabellennamen, den Tabellenbereich und die Bezugszellen mußt Du natürlich anpassen.

Code:
=WENNFEHLER(SVERWEIS($A1;Tabelle2!$A$1:$G$100;SPALTE(D1);0);"")
Gruß Stefan
Win 7 / Office 2007
Antwortento top
#8
Hallo Stefan,

mit diesem Code funktioniert es nicht und wieso steht das WENNFEHLER vor SVERWEIS.

Code:
=WENNFEHLER(SVERWEIS($A1;Tabelle2!$A$1:$G$100;SPALTE(D1);0);"")

 Ich hatte SVERWEIS schon einmal probiert, aber irgendwas markiere ich falsch, da es nicht das tut, was ich gerne möchte. Muss ich in die Spalte die Formel eingeben in der ich die Daten später haben möchte?

LG
Antwortento top
#9
Hola,

dann bitte eine richtige Beispieldatei, denn "funktioniert nicht" sagt nur dir etwas.

Gruß,
steve1da
Antwortento top
#10
Ich habe jetzt eine Datei mit Beispielen hochgeladen. Die grünen Daten sollen, wenn es geht direkt hinter die 1. LNR-Spalte und zur passenden LNR in der 1. Spalte hinzugefügt werden.

LG,
deschi9400


Angehängte Dateien
.xlsx   BEISPIEL.xlsx (Größe: 9,83 KB / Downloads: 5)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste