Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zelleninhalt anhand des Anfangsbuchstaben einer Unterkategorie zuordnen!
#1
Question 
Hallo zusammen,

ich möchte gerne einen Zelleninhalt (mit Text) je nach Anfangsbuchstabe einer Unterkategorie bzw. Kategorie ID zuordnen.

Anbei eine exemplarische Excel Tabelle
Es gibt "Oberkategorien" - in Zeile 2-26 (A-Z) - welche jeweils eine ID haben (Spalte A).
Es gibt "Unterkategorien" - in Zeile 27-fortlaufend -  welche einer Oberkategorie (bzw. der ID der Oberkategorie (Spalte A)) zugewiesen werden sollen (Spalte C)
Diese Zuweisung soll anhand des ersten Anfangsbuchstaben des Zelleninhalts erfolgen (Spalte B).

In Zeile 27 und 28 habe ich dies manuell und exemplarisch vorgenommen.
Ich habe eine Excel Tabelle mit vielen tausenden Zeilen, wo ich die Formel entsprechend anwenden möchte.

Ich freue mich über jede Hilfe!

Danke!

Viele Grüße,
Florian


Angehängte Dateien
.xlsx   test.xlsx (Größe: 26,77 KB / Downloads: 5)
Antwortento top
#2
Hola,

Code:
=INDEX($A$2:$A$26;VERGLEICH(LINKS(B27;1);$B$2:$B$26;0))


Gruß,
steve1da
Antwortento top
#3
Hallo, meinst du so..?

C27=CODE(B27)-64

Bei Steves Formel noch eine Fehlerabfrage umzu und bei mir

=WENN(CODE(B34)-64=19;"";CODE(B34)-64)

Wenn "S" wirklich nicht vorkommen kann
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#4
(02.06.2016, 16:07)steve1da schrieb: Hola,

Code:
=INDEX($A$2:$A$26;VERGLEICH(LINKS(B27;1);$B$2:$B$26;0))


Gruß,
steve1da

Hallo Steve, bei Süßkirsche versagt deine Formel, da müßte eine Fehlerabfrage umzu... (Dass ausgerechnet kein "S" vorkommen soll, wäre ungewhönlich, aber möglich)
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#5
Hola Jörg,


Zitat:Hallo Steve, bei Süßkirsche versagt deine Formel, da müßte eine Fehlerabfrage umzu... (Dass ausgerechnet kein "S" vorkommen soll, wäre ungewhönlich, aber möglich)


deshalb schreib ich das immer mit V für Vogel-Kirsche  19 19

Aber du hast natürlich Recht!

Gruß,
steve1da
Antwortento top
#6
Danke Euch! Hat wunderbar funktioniert!

Great help!! Heart
Antwortento top
#7
(08.06.2016, 12:47)wflorian schrieb: Danke Euch! Hat wunderbar funktioniert!

Hallo, was hat denn wunderbar geklappt...? Und was ist denn mit dem "S"?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste