Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Die Updates sind abgeschlossen. Bitte meldet eventuelle Bugs und Auffälligkeiten im entsprechenden Forum.
Sollte das Loginfenster nicht sichtbar sein, ist es unten links. Entweder Ihr loggt Euch dort ein oder löscht den Browsercache und versucht es noch einmal.


Zellenformeln verkürzen durch Namen definieren (variable)
#1
Hallo zusammen,
ich möchte gerne meine Zellen übersichtlicher gestalten.

z.B. so

=SUMMEWENNS([1.xlsb]Bericht!$I:$I;[1.xlsb]Bericht!$A:$A;A11)......

dies möchte ich ersetzen ersetzen durch

=SUMMEWENNS(Pfad1;Pfad2;A11)

____________________________________
Dazu definiere ich die Namen wie folgt:

Private Sub Workbook_Open()

ActiveWorkbook.Names.Add Name:="Pfad1", RefersTo:="[1.xlsb]Bericht!$I:$I"
ActiveWorkbook.Names.Add Name:="Pfad2", RefersTo:="[1.xlsb]Bericht!$A:$A"
End Sub
__________________________________
Das Ergebnis ist #WERT (Ein in dieser Formel verwendeter Wert ist vom falschen Dateityp)

Wenn ich in einer Zelle =Pfad1 eingebe steht dort korrekt  [1.xlsb]Bericht!$I:$I
Wieso klappt das nicht in einer Formel? ´Hat jemand eine Idee wo es klemmt?
Antwortento top
#2
Ist mein Weg gänzlich falsch? Wie vereinfacht Ihr eure Formeln in den Zellen?
Antwortento top
#3
Hallo,



das Makro gehört in DieseArbeitsmappe und sollte so aussehen:


Code:
Private Sub Workbook_Open()

ActiveWorkbook.Names.Add Name:="Pfad1", RefersTo:=Workbooks("1.xlsb").sheets("Bericht").Range("I:I")
ActiveWorkbook.Names.Add Name:="Pfad2", RefersTo:=Workbooks("1.xlsb").sheets("Bericht").Range("A:A")
End sub
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste